none
Do you want to open this file - lnk security warning RRS feed

  • Question

  • I have several links on my desktop that now give a security warning:

    "Do you want to open this file?" 

    Publisher: "Unknown Publisher"

    It appears that older links still work without the warning message but any new links have this issue.  I am using Windows 7 x64.

    If I pin the link, it works in the toolbar without the message.

    Any idea how to resolve this for new shortcuts moving forward?

    One of the shortcuts is just a link to a program on the c: drive.  If I run it from the start-> program menu it doesn't give me this warning.  It appears to give me this warning only when it is on my desktop.

    Saturday, April 30, 2011 3:27 AM

Answers

  • Hi,

    This may be caused by the incorrect setting of the integrity level.

    Please refer to the following link to resolve it.

    http://www.winhelponline.com/blog/fix-start-menu-shortcuts-open-file-security-warning-windows-7-vista/ 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, May 6, 2011 2:10 AM
    Moderator
  • Hi,

    It is nothing to do with SID. You may just back up the usefull files, and rename the profile, then recreate it.

    The following link for your reference.

    http://msdn.microsoft.com/en-us/library/bb625964.aspx 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, May 12, 2011 2:24 AM
    Moderator

All replies

  • Hi,

    As I know, this behavior is to make sure that the user really want to take this operation.

    For a work around, I would like to propose the following suggestions:

    1. Change User Account Control Settings.

    1) Click the Start button and type: UAC in the Search box.
    2) Click "Change User Account Control Settings".
    3) Drag the slider to a lower setting.
    4) Click OK.

    2. Configure Group Policy Settings.

    1) Click the Start menu and type: GPedit.msc in the Search box.
    2) Click on gpedit.
    3) Navigate to the following entry:

    User Configuration\Administrative Templates\Windows Components\Attachment Manager

    In the right panel of the Local Group Policy Editor, find the entry: Inclusion list for moderate risk file types. Double click the entry and check "Enabled".

    4) Under 'Inclusion list for moderate risk file types', type the file types: .ink (shortcut types)
    5) Click OK and restart the computer.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, May 3, 2011 9:29 AM
    Moderator
  • I have two Windows 7 machines in a workgroup.  This only happens on one of them.  This behavior just started recently. 

     

    It looks like something happened to this PC only that causes this behavior.  While I appreciate the idea of changing security, I don't believe this is the issue per say.

     

    Any other ideas on how to figure out what is wrong?

    Friday, May 6, 2011 12:48 AM
  • Hi,

    This may be caused by the incorrect setting of the integrity level.

    Please refer to the following link to resolve it.

    http://www.winhelponline.com/blog/fix-start-menu-shortcuts-open-file-security-warning-windows-7-vista/ 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, May 6, 2011 2:10 AM
    Moderator
  • I had already tried your suggested link above.  That did not make any difference for me.

    I tried another user on the same machine, and they do not have this issue for the same desktop shortcut.

    In general, it looks like this only happens on one user profile on one machine.  If I login as the same user on a different machine, it works.  If I login as a different user on the same machine, it works.

    I have another program (Google Chrome) on the desktop that shows this issue.  If I pin it to the task bar, it doesn't have this issue.

    Any other ideas?

    Monday, May 9, 2011 1:03 AM
  • Hi,

    This is indeed caused by the integrity level.

    You may backup the usefull file in the problematic profile or rename the profile, then create a new user profile for a test.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, May 10, 2011 2:21 AM
    Moderator
  • What is the best way to recreate a profile?  I don't think I want to just delete it and create a new one.  I believe this leaves registry SID settings.  Can I really just back up the profile, rename it and create a new one, then restore it?
    Thursday, May 12, 2011 12:12 AM
  • Hi,

    It is nothing to do with SID. You may just back up the usefull files, and rename the profile, then recreate it.

    The following link for your reference.

    http://msdn.microsoft.com/en-us/library/bb625964.aspx 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, May 12, 2011 2:24 AM
    Moderator
  • Thank you, this was the solution for me as well.

    I had the same problem with a few shortcuts on my desktop.

    I Spend hours searching on the net and found workarounds, but this solution really solved the problem!

    thnx!!


    • Edited by Hijmen Tuesday, June 18, 2013 2:13 PM
    Tuesday, June 18, 2013 2:12 PM