none
HAS ANYBODY TRIED PORT FORWARDING ON WINDOWS 7 ?? I CAN'T GET IT TO WORK!!!

    Question

  • Hey everyone, this is my first post. I just cannot get port forwarding to work on Windows 7. I'm using a D-Link DI-634M wireless router.  I set up a static IP that is outside of the DHCP range so it doesn't get assigned to someone else on my network. I live with 3 other guys and there are also smartphones on the network. I'll go ahead and provide some information for you to look at.

    (All of this is under CMD: ipconfig /all)
    IP Address (before): 192.168.0.113
    Static IP that I've Selected: 192.168.0.119
    DHCP Range (changed by me to a much smaller range): 192.168.0.100 - 192.168.0.110
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.0.1
    Name Servers (DNS): 192/168.0.1

    (All of this is under Status > WAN in my router confgurations)
    Connection Type: DHCP Client
    Router's IP Address: 172.17.104.84
    Subnet Mask: 255.255.255.0
    Default Gateway: 172.17.104.65
    Primary DNS Server: 172.17.104.65
    Secondary DNS Server: 0.0.0.0

    *There are two options on my router configuration page: DHCP Renew & DHCP Release. Can anyone tell me what these are?

    *I click on the Network icon on the bottom right of the Windows 7 taskbar > Open Network and Sharing Center > Change adapter settings > right-click the wireless connection > Properties > select Internet Protocol Version 4 (TCP/IPv4) > select Properties.

    *Here, I'm supposed to type in the required information such IP Address, Subnet Mask, Default Gateway as well as my Primary and Alternate DNS Servers, all in order to set up my static IP. The static IP that I chose should be the one I type into the IP Address field, right? In that case, which Default Gateway do I use? The one from my computer or the one from my router?

    *Also, what numbers should I place in the Primary and Alternate DNS Server spots? Is it unusual that my router is showing a Secondary DNS of 0.0.0.0?

    *My main problem here is that I can't find any ports that are open for forwarding. That could be because I don't have my static IP set up properly.

    All in all, I'm just majorly confused, can anyone help me out?

    Thanks a bunch!
    Wednesday, December 02, 2009 5:06 PM

Answers

All replies

  • DHCP Renew & DHCP Release is what is says it is, it to release or renew the IP address from your ISP.
     your Ipconfig gives you all you need to set the ip
     set the
    IP Address : 192.168.0.113
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.0.1
    Name Servers (DNS): 192.168.0.1

    The ports are forward in the router and then you ALLOW traffic thru the firewall on the PC.


    Wednesday, December 02, 2009 5:55 PM
  • Does anyone else have any input? I'm still very confused as to why my Alternate DNS is 0.0.0.0. Anyways, I tried what Bubbapcguy said. When windows asks for the Primary and Alternate DNS servers, I typed 192.168.0.1 for both. Windows wouldn't let me use the same number for both and it also would not let me use 0.0.0.0 as a Secondary or Alternate DNS. Any ideas?

     - John
    Thursday, December 03, 2009 8:07 AM

  • John you can use open DNS you wish
    4.2.2.2 is one
    • Proposed as answer by Bubbapcguy Thursday, December 03, 2009 10:14 AM
    Thursday, December 03, 2009 10:13 AM
  • Is there a particular way to find out whether setting up my static IP worked? I used 4.2.2.2 as the Alternate DNS, just like you said. Windows accepted it, but I have no idea if it really worked. If I run ipconfig /all, I noticed that my IPv4 address did change to the IP address I chose.

     - John
    Thursday, December 03, 2009 11:35 AM
  • Is there a particular way to find out whether setting up my static IP worked? I used 4.2.2.2 as the Alternate DNS, just like you said. Windows accepted it, but I have no idea if it really worked. If I run ipconfig /all, I noticed that my IPv4 address did change to the IP address I chose.

     - John

    by the way, I still have internet access even after changing the settings. If this helps..
    Thursday, December 03, 2009 11:44 AM
  • If you have Inet access then yes the settings are working.

    You say you want to forward some ports to the box, is this for running a server or for gaming?
    Thursday, December 03, 2009 11:52 AM
  • If you have Inet access then yes the settings are working.

    You say you want to forward some ports to the box, is this for running a server or for gaming?
          I do have internet access..I'm trying to port forward uTorrent (sounds like everyone else's story). I tried out a uTorrent-recommended torrent file just to check my speeds. It was downloading at over 300 kB/second, so that's not too bad in my opinion. Yet, I've never been able to port forward on any of my computers, so now I'm just doing it because I want it to work haha.
          Every single port I choose is closed according to the "Test if port is forwarded properly" link on uTorrent's Speed Guide. Btw, whether I use 4.2.2.2 or just blanks for the Secondary DNS (when setting up the static IP) doesn't matter as I get net access either way. Any clue?

     - John
    Thursday, December 03, 2009 12:52 PM
  •       I've got another question. When I look up my IPv4 address in ipconfig /all, I see the address I set as my static IP with the word "preferred" after it. However, whenever I go to ANY website that tells me my own IP address, it definitely does not list the static IP I set up. As a matter of fact, the number is completely different. The static IP I set up starts with the usual 192.168.0.***. When I see my IP address on websites, it tells me it's 71.42.218.***. I am completely lost on what this "new" IP address is. Thx

     - John
    Thursday, December 03, 2009 12:59 PM
  • OK the 192.168.0.xxx is the LOCAL ip address which is given out by the router.
    The 71.42.218.***. is the public WAN ip given to your routers wan port by your ISP.

    You would need to login to the router and forward the port(s) you wish to use to the IP address you gave your box (192.168.0.119)

    you may also need to allow those ports in the firewall on the PC


    Your question are more of a networking 101 and not really windows 7 related.

    I guess you should use the link below to get up to speed.
    http://portforward.com/english/routers/port_forwarding/Dlink/DI-634M/Utorrent.htm

    Thursday, December 03, 2009 1:15 PM
  •       I've actually already used that particular site. If I go to Windows Firewall > Advanced Settings > Inbound Rules, I see two rules for uTorrent: uTorrent (TCP-In) and uTorrent (UDP-In). Pick either one and right-click > Properties > Protocols and Ports. I can select from a wide range of protocols, but its default setting is TCP or UDP, respectively. There are also pull-down bars for "Local Port" and "Remote Port". Within both pull-down bars, I can select "All Ports" or "Specific Ports" and sometimes there is an "Edge Traversal" option. For both TCP-In and UDP-In under "Inbound Rules", I have Local and Remote Ports set to "All Ports".
          On the other hand, there isn't a single rule for uTorrent that I can find under "Outbound Rules". Should I have some rules set for uTorrent under "Outbound Rules"? Are my settings correct for the two inbound rules? Should I keep the settings at "All Ports" or should I switch it to "Specific Port" and pick a port #? Thx.

     - John
    Thursday, December 03, 2009 1:36 PM
  • Once more this is really not a windows 7 question but more of a uTorrent question.

    Google is your friend.

    http://lmgtfy.com/?q=utorrent+and+windows+7

    Thursday, December 03, 2009 2:20 PM
  • Hi,

     

    Please also refer to:

     

    µTorrent Connection Setup Guide

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    If it still doesn't work, please also try to create a rule for the ports or the application:

     

    Windows Firewall with Advanced Security Getting Started Guide

     

    Thanks.


    Nicholas Li - MSFT
    Monday, December 14, 2009 10:13 AM
    Moderator
  • I also have an issue forwarding ports with windows 7 ultimate 64.

    I have done everything including bypassing the router, setting the firewall rules and its all in vein.

    The only fix I have found is to uninstall windows 7 {vista in a new wrapper} and install xp, then

    miraculously the ports open.

    Who's the next dummy who is going to say it's not windows 7 ?

    This issue seems to be on the 64bit platform.

    Vista 64 did the exact same thing.

    Sunday, August 08, 2010 5:21 AM
  • Not sure if anyone's going to respond to this seemingly mindless thread, but I must say I am encountering the exact issues.

    I would describe myself as an "amateur expert" on networking and I have been forwarding ports successfully for years with different routers and computers of different configurations, that is, until I started using Windows 7.

    Basically port forwarding is a router side thing and true, it shouldn't have anything to do with the OS, but well, I have to concede that win7 64bit has something to do with the problem; here's what I did:

    1. I first assigned a static IP to the LAN card of my PC. Since the router recognizes only the MAC when assigning IPs, using different OSs should have no influence on the IP. Then, I did the steps necessary for port forwarding, which worked for all my other PCs.

    2. After having no avail in connecting to the remote desktop service on my unit with win7, I installed XP (Professional, 32bit, which was sitting on my shelf without purpose) on the units second hard drive (did a dual boot), just to prove the issue is OS-dependent.

    3. After booting into XP...well, if you've gone this far, you should be able to guess what happened next. Without making any changes to the router-settings, I was able to connect to the remote desktop service of the unit mentioned. Note that in all attempts network level authentication was set to be not required.

    Now if it's not something in Win7 64bit causing the issue, please tell me what is. 

    Thursday, August 19, 2010 4:43 PM
  • Come on Microsoft, 'What' "Cat got your tongue ?"

    I know it's something in win7 64bit as 32bit works fine.

    It's a shame i have to use my New Mac for port forwarding to work.

    Thursday, October 28, 2010 6:40 AM
  • I would like to know why no one replies to this question on Windows Forum! Isnt this suppose to be a forum from a brand called Microsoft that has millions of users world wide?! If this is the official site, where is the professionalism in helping people?

     

    I would also want to share the same issue as i've been reading around the internet and here:

    I port forwarded before, with Win XP. i know the essentials basics of how it works and which are the steps... But now that i have Win7, i cant get port 26900 (ejamming program) to unblock. I have an ARRIS modem. We are 2 people using it, but i disconnected completely the other pc everytime i tried to unblock this ports and use the program. I have a static IP and the other pc doesnt.

    I already tried the following:

    1- DMZ with my IP address (which is Static, by the way)! My router wasnt possibly interfeering and still my ports were blocked. So IT HAS to be my computer.

    2- Disabled and even UNINSTALLED all firewalls and antispywares, as well as disabled completely Windows firewall. (i had the exceptions in both win firewall and antivirus programs for this program and i created inbound rules for this ports, both TCP and UDP).

    3- One i disabled the Win firewall and, as by magic, i thought THERE was the problem! the door was unblocked. but after 5 minutes, just to make a test, i got WIn firewall on again and then off, and never more i got the port open... So, unless i can´t see somethign very obvious here, there is something not right in this system.

    4- All the IP's are matching, the number of ports were checked over and over again... The door unblocked once and got blocked again IN THE EXACT SAME CONDITIONS!

     

    So, i would advise people on Microsoft to take a look at this issue more carefully and dont discard people has they are doing the most basic error. I would like very much to see an effective reply to this thread, but i must say im not seeing it happen, which is very disrispectfull and unprofessional from Microsoft. So if none of the geniuses who work there can answer to their own creations, what are we dealing with here?! total ignorance? And how more coward and disrispectful can it get when people are left with an issue standing by for years?!!?!?!!?!

    DOES SOMEONE KNOW HOW TO GO AROUND THIS ISSUE, OTHER THAN UNINSTALLING WIN 7?!

    Thanks for your time.

    Sorry but I have to be pissed off.

     

    Wednesday, July 06, 2011 11:09 AM
  • Rarely, if ever, will you find a direct response from a Microsoft engineer or developer with a solution, never mind even an acknowledgement that the problems is real, on these forums. On any of the thousands of problems reported here. In over four years browsing here regularly since Vista RC, I have yet to see it.  If you are lucky some other person has a suggestion or workaround that works. Good luck.


    Wednesday, July 06, 2011 6:28 PM
  • thanks man! incredible!!!

    Money is really a destroyer! :)

    Be well fanfarenj. thanks


    Rui
    Wednesday, July 06, 2011 7:05 PM
  • BUmp! Isit fixed yet? 2 years :x
    Friday, January 13, 2012 4:15 AM