none
Windows 7 "Unidentified network" with internet connection after sleep

    Question

  • Hi guys

    After a sleep, many of our laptops/notebooks which are members of a AD domain shows "unidentified network" with "internet access" and interestingly allows us to access all network objects as well internet.

    The only solution we have right now is to manually restart the "Network Location Awareness" service which resolves everything and the connection status once again shows the network with domain information as well "internet access". We disable the power saving for the network adaptors, still the problem exists.

    Any inputs?

     

    Saturday, March 27, 2010 1:54 PM

Answers

  •  

    Hi,

     

    First, I would like to confirm whether the issue only occurs on several laptops which are the same model? Can you let me know the model?

     

    Please also try the following steps.

     

    1. Manually assign a static IP address and DNS address on the machine for a test.

     

    2. Modify the relevant security settings.

     

    a. Type "gpedit.msc" in Start menu, right click it and click "Run as administrator".

    b. Open Computer configuration -->Windows Settings -->Security Settings -->select Network list manager policies on the right Side you will see options for :

     

    Double click -->Unidentified networks

     

    e. Then you can select the option to consider the Unidentified networks as private and if user can change the location.

     

    If the issue persists, please collect the following log file for research.

     

    Collect the Netmon trace

    =========================

    a. Download NetMon3.3 from the following website and install it on the computer

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

     

    b. Launch NetMon3.3.

    c. In the Microsoft Network Monitor 3.3 window, click Create a new capture tab …

    d. In the new tab, select all the Network Adapters in the Select Networks window.

    e. Then, switch to Network Monitor, press F5 to start NetMon.

    f. Try to enter in Sleep Mode. When it failed, go to step 7.

    g. Go back to the NetMon window and press F7 to stop the NetMon.

    h. Press Ctrl+S to save the Netmon file named test.

     

    Then please upload to SkyDrive (www.skydrive.live.com ) and share the link to me.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Tuesday, April 06, 2010 2:29 AM
    Friday, April 02, 2010 2:24 AM

All replies

  • btw if somebody is interested read about the exercises we had gone through to come across certain fixes for these annoyance with network connections in Windows 7, do visit http://windows7bugs.wordpress.com

    Though not notorious like Vista, I must say, as far W7 has issues with networking and authentications, would definitely draw a negative opinion from the corporate users!

    Saturday, March 27, 2010 7:58 PM
  • Hi,

     

    First, I would like to thank you for your feedback about Windows 7. Your opinions are import to improve our products.

     

    At this stage, I would like to confirm whether the issue occurs on each Windows 7 machines in your AD domain. If the issue only occurs on several laptops, can you tell me whether the laptops are the same model? Can you let me know the model?

     

    This issue can occur by several factors, such as incompatible driver, group policy restricted or incompatible third party programs. I suggest you try the following steps on certain problematic machine for a test.

     

    1. Temporarily leave the domain and login on the machine with a local user account. Then, please let the machine in Sleep Mode. Does the issue persist after reverting back?

     

    2. Upgrade the NIC driver.

     

    3. Perform a Clean Boot to check the result.

     

    Thanks,

    Novak

    Monday, March 29, 2010 7:09 AM
  • Hi Novak

    As I had mentioned with my previous post, we had already gone through an extensive testing to resolve this issue in our lab. Clean boot and upgrading the drivers etc etc. However, till now, the problem persist. The only exercise we are yet to perform is leaving the domain and reproducing the scenario.

    Once necessary backups are taken, I will come back to you with the latest status.

    Thank you very much for the input meanwhile.

    Monday, March 29, 2010 2:32 PM
  •  

    OK. I will wait here for your reply.

     

    Thanks,

    Novak

    Tuesday, March 30, 2010 6:29 AM
  • Hello Novak

    I had gone through the suggested exercises and the results are following:

    removing from the domain didn't solve the problem (We have ISA, AD Domain etc)

    Narrowing down the problem has identified that, once I physically unplug the network cable from my laptop (HP6530b, BroadCom Netlink Gigabit) driver dated 02.sep.2009 (latest from Broadcom site) and plugging it back brings back the exclamation with the network connection indicator and while pointing mouse clearly shows "Unidentified network no internet access"

    Hence I am doubting the service "Network list service" is not restarting once after the cable is plugged back. The ground for my argument depends upon following exercises.

    I stopped and restarted "Network location awareness" services which in due restarts "network list service" and the right discovery for the network is re-initiated and the connection status turns back to "abc.com internet access"

    To deal with the situation (frequently I am into meetings carrying my notebook, hence cannot avoid disconnecting the cable) I created a .cmd file in which I stop and restart both "Network location awareness" and "network list service" manually.

    You have any thoughts?

     

    regards

    raj

     

    Tuesday, March 30, 2010 9:25 AM
  •  

    Hi,

     

    First, I would like to confirm whether the issue only occurs on several laptops which are the same model? Can you let me know the model?

     

    Please also try the following steps.

     

    1. Manually assign a static IP address and DNS address on the machine for a test.

     

    2. Modify the relevant security settings.

     

    a. Type "gpedit.msc" in Start menu, right click it and click "Run as administrator".

    b. Open Computer configuration -->Windows Settings -->Security Settings -->select Network list manager policies on the right Side you will see options for :

     

    Double click -->Unidentified networks

     

    e. Then you can select the option to consider the Unidentified networks as private and if user can change the location.

     

    If the issue persists, please collect the following log file for research.

     

    Collect the Netmon trace

    =========================

    a. Download NetMon3.3 from the following website and install it on the computer

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

     

    b. Launch NetMon3.3.

    c. In the Microsoft Network Monitor 3.3 window, click Create a new capture tab …

    d. In the new tab, select all the Network Adapters in the Select Networks window.

    e. Then, switch to Network Monitor, press F5 to start NetMon.

    f. Try to enter in Sleep Mode. When it failed, go to step 7.

    g. Go back to the NetMon window and press F7 to stop the NetMon.

    h. Press Ctrl+S to save the Netmon file named test.

     

    Then please upload to SkyDrive (www.skydrive.live.com ) and share the link to me.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Tuesday, April 06, 2010 2:29 AM
    Friday, April 02, 2010 2:24 AM
  • Hello again Novak

    I made the following changes you had suggested:

    2. Modify the relevant security settings.

     

    a. Type "gpedit.msc" in Start menu, right click it and click "Run as administrator".

    b. Open Computer configuration -->Windows Settings -->Security Settings -->select Network list manager policies on the right Side you will see options for :

     

    Double click -->Unidentified networks

     

    e. Then you can select the option to consider the Unidentified networks as private and if user can change the location.

     

    I unplugged the cable and connected it again, the network connection identified the domain almost after 4-5 minutes, against it was always "unidentified network" in earlier cases.

     

    I will closely monitor the behavior for a while and report back if the problem comes back after a sleep.

     

    Thank you very much for the suggestions.

     

     

    regards,

     


    if it is a door, it will open
    Wednesday, April 07, 2010 7:51 AM
  • Hi Novak

    I made the PC to enter into sleep mode and once after resuming, as reported earlier, the network connection shown "unidentified network" for more than 4-5 minutes before showing the correct domain name followed by Internet access.

    I may roll back the settings I had made earlier and see whether the group policy has really worked out in our case.

    Thanks again


    if it is a door, it will open
    Wednesday, April 07, 2010 7:59 AM
  • Hi Novak

    Well the problem persist :o. The latest scenario is like following. I have a desktop machine at home running Windows 7 64bit Professional and a traditional DSL connection. I use the wireless connection @ home for the work notebook. Yesterday instead of shutting the machine down, forced to sleep and today when connected to the work network, the connection failed to detect the domain network and the notorious "Unidentified network with no internet access" notification came in.

    I had to restart the machine to resolve this issue. Unfortunately I was not in a position to capture the network activity data using the netmon. I will do the same soon and post the results.

     

    Regards


    if it is a door, it will open
    Monday, April 12, 2010 5:27 AM
  • I am running Windows Vista and started having the problem you are describing after the most recent round of updates.  If I restart the computer or the router I can see my network.  It is inconvenient and time consuming to do this each time the computer sleeps.  I have not looked over the last 30 updates for Vista (as of june 18, 2010), but I suspect the culprit is there. 

     

    From what I have observed, network discovery turns off after a sleep and cannot be turned on in private mode.  Restarting the machine resets this.

    David

    Monday, June 21, 2010 4:45 PM
  • Make sure your router firmware is up-to-date.  We upgrade all the drivers in our PC for Windows 7 but forget to upgrade the router firmware.  I upgraded my router firmware and all those unidentified network problems went away.  It is much easier than forcing windows 7 to work with an out-dated router firmware.  I wish this forgotten upgrade of the router is promulgated by Microsoft.   Consequently many of us wasted a lot of time on this one.
    Friday, July 02, 2010 4:36 AM
  • Type "Services" in the start menu,

    Check to see if you have this one in your services list: 
    "##Id_String2.6844F930_1628_4223_B5CC_5BB94B879762 ##"

    Disable it and Stop it.

    This is the Apple Bonjour DNS Responder Service

    Source:

    http://windows7forums.com/windows-7-networking/1706-unidentified-network-local-access.html

    Tuesday, December 28, 2010 1:46 PM