none
WDS not auto selecting install image

    Question

  • Hello,

    Trying to get WDS Auto-Image selection working correctly, and sadly failing :-(. You should be able to add in the following lines (At the bottom of post) into the client unattended answer file (Using SIM) and it should select the image listed. the problem i am having is that i have added the nessacary components and it still prompts for image selection. Has anyone actually had this working?? and mabey they could tell me what i am doing wrong?? 

                        <InstallImage>
                            <Filename>Image.wim</Filename>
                            <ImageGroup>College</ImageGroup>
                            <ImageName>Image</ImageName>
                        </InstallImage>
    • Edited by Frostdragon Monday, October 08, 2012 1:11 AM
    Monday, October 08, 2012 1:04 AM

Answers

  • Have you already tried the willshowui = never setting.  If that don't work or the install fails, you had better double-check your image and group names are correct. 

                    <ImageSelection>

      <Filename>Image.wim</Filename>
                            <ImageGroup>College</ImageGroup>
                            <ImageName>Image</ImageName>

    <WillShowUI>Never</WillShowUI>

                    </ImageSelection>


    Don't forget to mark your posts as answered so they drop off the unanswered post filter. If I've helped you and you want to show your gratitude, just click that green thingy.






    Monday, October 08, 2012 4:02 AM
  • Hi
    I suggest you take the following steps to troubleshoot the issue.
    1. What do you use to build the image, Windows 7 or Windows 7 SP1?
    If the first one, please use Windows 7 SP1 to build the image.
    2. Remove all language selection setting from the answer file from Microsoft-Windows-International-Core-WinPE phase.
    3. If the above cannot help, use Shift+F10 to open a command prompt, change the directory to X:\Windows\Panther and upload setupact.log and setuperr.log on the Skydrive.

    Tracy Cai

    TechNet Community Support

    • Marked as answer by Frostdragon Wednesday, October 17, 2012 1:17 AM
    Wednesday, October 10, 2012 12:41 PM
    Moderator
  • Hey Hey :-) Issue Resolved.

    I added the <WillShowUI>Never</WillShowUI> Section as well as changing the language location to en-US for the International-Core-WinPE and adding the International-Core Language setting [en-NZ] as well and away it goes!! 

    Marked all three as an answer because i used part from all three posts to fix the issue :-) 
    • Marked as answer by Frostdragon Wednesday, October 17, 2012 1:17 AM
    • Edited by Frostdragon Wednesday, October 17, 2012 1:17 AM
    Wednesday, October 17, 2012 1:16 AM

All replies

  • Have you already tried the willshowui = never setting.  If that don't work or the install fails, you had better double-check your image and group names are correct. 

                    <ImageSelection>

      <Filename>Image.wim</Filename>
                            <ImageGroup>College</ImageGroup>
                            <ImageName>Image</ImageName>

    <WillShowUI>Never</WillShowUI>

                    </ImageSelection>


    Don't forget to mark your posts as answered so they drop off the unanswered post filter. If I've helped you and you want to show your gratitude, just click that green thingy.






    Monday, October 08, 2012 4:02 AM
  • Hi
    I suggest you take the following steps to troubleshoot the issue.
    1. What do you use to build the image, Windows 7 or Windows 7 SP1?
    If the first one, please use Windows 7 SP1 to build the image.
    2. Remove all language selection setting from the answer file from Microsoft-Windows-International-Core-WinPE phase.
    3. If the above cannot help, use Shift+F10 to open a command prompt, change the directory to X:\Windows\Panther and upload setupact.log and setuperr.log on the Skydrive.

    Tracy Cai

    TechNet Community Support

    • Marked as answer by Frostdragon Wednesday, October 17, 2012 1:17 AM
    Wednesday, October 10, 2012 12:41 PM
    Moderator
  • Hey, sorry for the long time between posts, just had a flat out week and a half :-)

    I tried the <WillShowUI>Never</WillShowUI>  at which stage it returned an error "WdsClient: A matching language pack was not found. please check you client unattended installation file. Language pack [en-NZ]". 

    The Boot image that i am using is Windows 7 SP1. when i tried removing the language selection settings it returns error "WdsClient: a target language was not specified in the client unattended installation file." Uploading logs to SkyDrive.

    https://skydrive.live.com/redir?resid=AED306CFE758A69C!1560&authkey=!AHAYXxmYN4uRCMI
    • Edited by Frostdragon Tuesday, October 16, 2012 10:53 PM
    Tuesday, October 16, 2012 10:50 PM
  • Hey Hey :-) Issue Resolved.

    I added the <WillShowUI>Never</WillShowUI> Section as well as changing the language location to en-US for the International-Core-WinPE and adding the International-Core Language setting [en-NZ] as well and away it goes!! 

    Marked all three as an answer because i used part from all three posts to fix the issue :-) 
    • Marked as answer by Frostdragon Wednesday, October 17, 2012 1:17 AM
    • Edited by Frostdragon Wednesday, October 17, 2012 1:17 AM
    Wednesday, October 17, 2012 1:16 AM