none
Computer Browser (Browser) Service missing RRS feed

  • Question

  • I was directed by a response from the support centre of Microsoft to check a PC which was unable to see other network computers in the Network tab in File explore.

    They suggested that a number of services should be changed to Automatic (Delayed Start)

    These included

    a. Computer Browser (Browser)

    b. Function Discovery Provider Host (FDPHOST)

    c. Function Discovery Resource Publication (FDResPub)

    d. Network Connections (NetMan)

    e. UPnP Device Host (UPnPHost)

    f. Peer Name Resolution Protocol (PNRPSvc)

    g. Peer Networking Grouping (P2PSVC)

    h. Peer Networking Identity Manager (P2PIMSVC)

    On the machine I was having trouble with there was no service named Computer Browser (Browser).

    I checked the other PC and found the service there, but it would not allow the Start type to be changed giving an error message.

    <quote>

    The delayed auto-start flag could not be set.

    Error 87: The parameter is incorrect

    </quote>

    My question is why did the two PCs  have different settings and in one case a missing one?

    The two PCs were updated to Win 10 Pro 1803 but by different methods. The problematic one by allowing the Windows Update to 1803 to proceed and then applying all the available cumulative and other updates to proceed. The one with the error 87. by using the Windows.iso setup.exe to run and allowing any updates to be found and applied.

    The other changes appear to have fixed the problem of not seeing other machines on the LAN.


    Alan Cameron

    Saturday, June 2, 2018 8:20 AM

Answers

All replies

  •   Windows 10 version 1803 has SMB 1.0 disabled by default. The computer browser service is a legacy service which was part of the old SMB 1.0 file sharing system. If SMB 1.0 is disabled there is no computer browser service.

      I am surprised that support even mentioned it. Microsoft is working hard to persuade people not to use SMB 1.0.

    https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/


    Bill

    • Marked as answer by AlanCam Sunday, June 3, 2018 8:21 AM
    Sunday, June 3, 2018 12:49 AM
  • I am not surprised in the least.

    As for the link it is all but unreadable to anyone who has no training or knowledge of PowerShell.

    It appears to me that the consumer should not be advised to use anything contained in the text until they can tell what they are trying to use it for.

    There must be a simpler method for the common or garden user.


    Alan Cameron

    Sunday, June 3, 2018 8:20 AM
  •   Simpler method for what?

      SMB 1.0 is now disabled by default in Windows 10. There is nothing further to do if this is the case.

      The article I referred to was simply to point out that SMB1 is dangerous and that Microsoft is trying to discourage its use, and has been for some time. Obviously this has not been taken up by support.

      The only time this will affect the average user of this forum is if they are trying to support legacy devices (such as XP or some NAS devices) which cannot operate without SMB1. All Windows OSs from Vista on include the newer file sharing system and had SMB enabled purely for backwards compatibility. They do not depend on it or on the computer browser service.

     

     


    Bill

    Monday, June 4, 2018 3:07 AM
  • Point taken.

    Alan Cameron

    Monday, June 4, 2018 9:13 AM
  • There was one Windows 10 computer on the network that had SMB 1.0 enabled.  I stopped the browser service and went to Add / Remove Features and unchecked smb1.0.  Restarted PC when prompted and the "Network Neighborhood" for lack of a better term is working correctly now.  +1 for netbios.  Thanks Bill!
    • Edited by RickkeeC Saturday, October 6, 2018 5:12 PM
    Saturday, October 6, 2018 5:11 PM
  • I am trying to enable SMB 1.0 - have all the relevant ticks in Add/Remove features but I get Error 87 when trying to change Computer Browser to the delayed auto-start flag. Can anyone advise - thanks.
    Thursday, November 14, 2019 11:05 PM