none
Windows 7 Home Premium cannot map a Network drive - The "RED X" Syndrome RRS feed

  • Question

  • My network consists of Windows Home Premium plus a Buffalo NAS drive. Every time I boot I get a notification that is "Could not reconnect all network drives" I then go to Computer and there is a red X on the mapped NAS drive. When I double click on the Red X,  I get the directory listing of the mapped drive and the red X goes away.

    This issue has been addressed with some positive results for other versions of Windows 7, However I am using WIN 7 HOME PREMIUM.... and the suggested corrective methods offered are not able to be utilized with Home Premium due to its lack of certain registry tools and options, as I understand.

    This problem does not appear to be universal, in that not everyone with identical equipment (Both Home Premium and a Buffalo NAS) see this exact problem. so I am hoping that a corrective method is known that will restore my ability to utilize my Network NAS.

    Wednesday, July 31, 2013 2:30 PM

Answers

All replies

  • Hi,

    From your post, I understand that your network attached storage always appeared with a read X on it once you restart the computer and error message is “Could not reconnect all network drives”, but you can double click it like waking up the drive and the red X disappeared.

    Based on my research, I suggest we follow these steps to check the issue:

    Update your network adapter driver:

    To update your network adapter driver, you can follow steps “To update drivers using Windows Update” or  “To manually update drivers” on following link:

    http://windows.microsoft.com/en-us/windows/update-driver-hardware-isnt-working-properly#update-driver-hardware-isnt-working-properly=windows-7/

    You can also download and update the driver yourself from the manufacturer's website.

    If it doesn’t work, I recommend that we test whether the issue can be caused by third part conflict.

    Let’s try to start the Windows in Clean boot mode to check the results:

    To start system in Clean boot mode:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista

    http://support.microsoft.com/kb/929135

    Note After clean boot troubleshooting, please follow steps under “How to reset the computer to start as usual after clean boot troubleshooting” in above article.

    Please take time to perform above troubleshooting steps and let me know the results.

    Hope these could be helpful and keep post.


    Best Regards, StarSprite

    Thursday, August 1, 2013 7:32 AM
  • Thank you SS for your suggestion, however it produced no changes.  The NAS is connected via Ethernet, and the Buffalo NAS has had the latest drivers.... none are required to reside on the WIN 7 machine. Previous posts speak at length that the sequence of the Mapped Drives / NAS loading vs. Windows is the fault. The question is how to overcome this specific Windows problem, as it's not an NAS Equipment issue.
    Thursday, August 1, 2013 1:37 PM
  • Hi Rob,

    I suggest we try steps including hotfix, manual fix and command line in this article:

    Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

    Also, I would like to share this similar thread with solution for you:

    http://social.technet.microsoft.com/Forums/windows/en-US/2eeb2d1b-2715-4b3d-8007-d9bb52522a7c/red-x-cross-over-network-drive-on-startup-could-not-reconnect-all-network-drives

    Hope these could be helpful.


    Kate Li TechNet Community Support



    Tuesday, August 6, 2013 1:31 AM
    Owner
  • Kate..

    Kate..

    Thank you, however the first link is bad..... It says its not available. Could you recheck its source please?

    I have partially solved the issue, by pointing the Backup Program not to the RED X Mapped drives, but to the NETWORK Drives as shown under Network itself. Though the Drives are not Mapped with a Drive Letter, it is still recognizing them and allowing connection, even though the Letter Mapped Drives are still X'd out.

    If you can find a good link for me, that would be most appreciated!

     

    Marc

    Tuesday, August 6, 2013 4:40 AM
  • Hi Marc,

    The link is fine for me, please try again:

    http://support.microsoft.com/kb/297684

    Thanks.


    Kate Li TechNet Community Support

    Tuesday, August 6, 2013 5:45 AM
    Owner
  • Kate...

    The link did work today and I ran it. Though the FIX is marked for WIN XP (I have WIN7 Home Premium) it failed to remove the Red X in this application.  The link was one not suggested by others so at least it pertained to the exact issue. From my observations and others who have attempted to correct this ongoing fault, it appears the problem lies in the loading times of the mapped drives, where the sequence delay is too short or non existent. Some have tried batch files that delay the loading, however these macro's cause unintended problems in some cases which I have tried. This is not a universal issue, but no one seems to be able to identify the cause that many of us experience. I've spoken to several NAS Manufacturers and they are aware of the issue through customer complaints blaming the devices themselves, but they all agree that it's a Windows issue and direct the user to contact Microsoft for resolution.  I welcome any further suggestions from you or if you know of a way we can escalate this to a higher tier at MS as this issue is years old with no apparent fix otherwise....

    Tuesday, August 6, 2013 1:58 PM
  • Hi,

    Since this issue just only occurs after boot up, this may be related to some setting about fast logon, try to check if we can disable this setting by the following registry:

    HKLM\Software\Policies\Microsoft\WindowsNT\CurrentVersion\Winlogon

    SyncForegroundPolicy = dword:00000001

    Hope these could be helpful and keep post.


    Kate Li

    TechNet Community Support

    Wednesday, August 7, 2013 10:44 AM
    Owner
  • Kate,

    Thanks again for not giving up!

    The WIN 7 Home Premium registry does not contain the "Current Version" entry you advise...

    Marc

    Wednesday, August 7, 2013 2:03 PM
  • Hi Marc,

    The autodisconnect feature on win7 may cause this, please turn off this feature.

    net config server /autodisconnect:-1

    please run this command with administrator permissions.

    restart the client to take effect.

    Best Regards,

    Mike

    Tuesday, August 13, 2013 8:47 AM
  • Mike,

    Thanks for your suggestion----   Performed your idea, and also checked the registry to confirm it's change... Unfortunately the RED X Syndrome continues....... No Joy.....

    I should add I completely reinstalled my Windows (Home Premium) on a newly formatted HDD over the weekend and used a different copy I have of WIN7...again,  no changes....

    Marc


    • Edited by Marc Rob Tuesday, August 13, 2013 3:14 PM
    Tuesday, August 13, 2013 3:10 PM
  • Hi Marc,

    I found a useful link, please make it as a reference.

    Red X on Mapped Drive in Windows 7 and Windows Vista [SOLVED]

    http://ptihosting.com/blog/it-blog/red-x-on-mapped-drive-in-windows-7-and-windows-vista-solved/

    Mike

    Wednesday, August 14, 2013 4:33 AM
  • Mike...

    Thank you for the Batch File suggestion. I will try it, though If I recall, similar files I have tried in the past cause unexpected issues.. especially for the Home Premium version I utilize. The Red X problem is one that as as you point out even Microsoft has not fully solved for some reason. The batch file is a work around, when it works of course.  As I have mentioned in a previous post, I use ALLWAY SYNC, and only recently I realized that I can point Allway Sync at the Unmapped Drives on the NAS in the Network folder, as this connection appears now to operate, as opposed to the  typical connection one does to the Mapped Network Drive letter equipped shares.  At this point I'm going to say thank you to all and say it works, but will certainly keep the Batch File  for a future solution should my current method fail. 

    Wednesday, August 14, 2013 2:05 PM