none
WMPNetworkSvc taking 100% CPU

    Question

  • WMPNetworkSvc is taking up to 100% CPU and really slows down the computer. If I stop this service it wokrs OK for awhile, then the problem reappears.
    It's a computer in a home network. Connected to a linksys router via cable. it's Windows 7 RC 32 bit.
    WMPNetworkSvc is a Windows media player sharing service. I did not even enable that feature in WMP.

    Hardware: Intel Pentium 3GHz, 3GB RAM, network adapter on-board: Broadcom NetLink (TM) Gigabit Ethernet

    Wednesday, May 20, 2009 6:28 AM

All replies

  • If this service is causing slowdown and problems, you can search for "services.msc" in the Start menu, run it, and then disable the Windows Media Player Network Service so it will never run again.

    -Nick
    Thursday, June 25, 2009 4:03 PM
  • This is a bad answer. U could answer "uninstall windows 7 and put windows xp instead". This is not the resolution, just to shut down a service. He asked why.
    Friday, July 03, 2009 3:41 PM
  • see the same. Why would this occur while no multimedia application is running.. just a clean started pc not running any user program shows this behaviour.
    Tuesday, December 08, 2009 8:14 AM
  • Please use the Windows Perfomance Toolkit to see which thread is causing this issue:

    http://www.msfn.org/board/get-cause-high-cpu-usage-caused-apps-t140264.html

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, December 15, 2009 4:41 PM