locked
How do I turn off media streaming? RRS feed

  • Question

  • How do I turn off / disable media streaming?
    I have tried going into the advanced sharing settings and choose blocked but that doesn't actually turn off the media streaming. I have 3 systems running Windows 7 but I only want one of them to stream media for my PS3, but at some point my sister decided not to wait for me to share the printer and turned on media sharing on a second computer. So now I just want to turn it off so that the PS3 only see's the 1 media server.
    Wednesday, August 12, 2009 8:03 PM

Answers

  • Go to Advanced sharing settings and click on Choose media streaming options. Then next to 'Show devices on' select all networks. Remove all devices. You'll be left with 'Media programs on this PC and remote connections...'. Select blocked or block all. That's it!
    • Marked as answer by Crazie-J Thursday, August 27, 2009 4:28 PM
    Thursday, August 27, 2009 4:26 PM

All replies

  • I'm guessing no one has been able to figure this out yet.
    Thursday, August 13, 2009 11:38 PM
  • Hi,

    In Network and Sharing Center Advanced sharing settings, there are some network profiles. Could you please check Your current profile Media Streaming setting?

    Thanks.
    Friday, August 14, 2009 3:19 AM
  • It says Media Streaming is ON
    • Proposed as answer by uoods Tuesday, August 16, 2016 5:01 PM
    Friday, August 14, 2009 1:32 PM
  • Can you close it?

    thanks.
    Saturday, August 15, 2009 3:10 AM
  • No I cannot turn it off, that is why I am asking how to turn it off.

    Saturday, August 15, 2009 5:14 AM
  • If you block all in options, and back to the window, it still show Media Streaming ON, or any error mesasge was encountered when trying to block it?

    Thanks.

    Saturday, August 15, 2009 8:07 AM
  • It still shows Media Streaming ON, if I set everything to block all. There are no error messages.
    Saturday, August 15, 2009 9:59 AM
  • Hi,

    Please open Windows Media Player, click Stream on tool bar. Did you have check any item? If so, please uncheck them.

    Does it help?

    Thanks.
    Monday, August 17, 2009 8:27 AM
  • Got the same problem, followed all of these instructions. No, streaming still shows as ON.
    Saturday, August 22, 2009 9:40 AM
  • Had the same problem.  Just figured this out, but this is from memory so bear with me- instead of setting everything to block, click remove. The remove option wasn't available for one of the settings, but if you remove everyone except that one, it will turn media streaming off.

    • Proposed as answer by Jitesh Patel Tuesday, October 18, 2011 4:48 AM
    Wednesday, August 26, 2009 5:40 PM
  • Go to Advanced sharing settings and click on Choose media streaming options. Then next to 'Show devices on' select all networks. Remove all devices. You'll be left with 'Media programs on this PC and remote connections...'. Select blocked or block all. That's it!
    • Marked as answer by Crazie-J Thursday, August 27, 2009 4:28 PM
    Thursday, August 27, 2009 4:26 PM
  • thanks. It was getting annoying.
    Thursday, August 27, 2009 4:28 PM
  • How do I turn off / disable media streaming?
    I have tried going into the advanced sharing settings and choose blocked but that doesn't actually turn off the media streaming. I have 3 systems running Windows 7 but I only want one of them to stream media for my PS3, but at some point my sister decided not to wait for me to share the printer and turned on media sharing on a second computer. So now I just want to turn it off so that the PS3 only see's the 1 media server.


    Why isn't this a common-sense setting like it appears to be? The option to turn Media Sharing On looks as though it is a simple Boolean operation: ON/OFF  but once you turn it ON, there's no going back except to trick your PC into Blocking all Media Center Services? If I block all, then I can't access the ONE PC I have setup for media sharing.

    RULE 30493827766:If you are going to use a toggle switch option (such as ON/OFF or TRUE/FALSE) you MUST make it as easy to turn it from one state to the other...If not, you should approach the interface from another direction (like "Click Here For Advanced Media Center Configuration", Not, "Enable Media Sharing? Yes/NO"

    It is absolutely, without a doubt, poor interface design that once you click "Yes" you are sentenced to fifty convoluted steps derived from reading thousands of newsgroup posts from people equally as angry and equally disillusioned by Windows 7 promise that it was designed by the people for the people. Question 2243983: Who Asked for this many steps to turn off media sharing? Who thought it would be a good idea to enable media sharing easily, but make it difficult and incomplete to disable media sharing?

    Thanks for this thread, though I guess a complete reinstall is the only way to avoid the problem of Blocking All media sharing when I just don't want to have one pc on my network  be the media server. UGGH. On second thought, I am disabling it all and using Boxee...much better interface, free, open source. I give up on Media Center--it has never worked right and it will never be worth using.

    jase
    Saturday, January 9, 2010 2:31 AM
  • If you remove yourself from the homegroup, it will turn off media sharing :)

    Control Panel > HomeGroup > Leave the HomeGroup
    • Proposed as answer by drdbrown Monday, August 1, 2011 8:00 PM
    Wednesday, January 13, 2010 1:16 AM
  • All posts that I've seen on this question only disable connection points but not the actual network sharing service.

    To disable the service, use Computer Management (right click on Computer select "Manage").
    Select the Services tree from "Services and Applications", find "Windows Media Player Network Sharing Service". 
    Right click on the service, select Properties.
    Click the "Stop" button to stop the service if is is running.
    Set the startup type to "Manual".
    Click OK.

    The Network Sharing Service will be disabled.


    • Proposed as answer by GPSJane Wednesday, September 19, 2012 10:00 AM
    Sunday, February 14, 2010 9:36 PM
  • PS3MediaServer is much, much better. It transcodes on the fly, seamlessly, and it plays ALL my content on the PS3, even iso's and img's, at the highest quality possible given the source. An added plus is that it doesn't require a Media Library to be built, which given the size of my library, takes more than 24 hours to build (on a Q6600 with 6GB RAM).
    • Proposed as answer by Steldrago_ Saturday, May 15, 2010 1:31 PM
    • Edited by TanMan1217 Thursday, January 26, 2012 9:48 PM Technocrate's post is no longer in the thread, so my rant was useless.
    Saturday, March 6, 2010 3:48 PM
  • http://www.mydigitallife.info/2010/01/27/how-to-disable-windows-7-media-player-network-sharing-service-wmpnetwk/#

     

    this is your answer

    • Proposed as answer by Steldrago_ Saturday, May 15, 2010 1:36 PM
    Saturday, May 15, 2010 1:34 PM
  • pffff, and I thought I was the only with these problems and frustrations!
    Tuesday, June 8, 2010 6:50 PM
  • I am having problem with the direction you gave  every time I deleted the unknown device it keeps coming back how do i get rid of it the unknown device my ps3 completely because my network keeps detecting it then comes back as a default plz help
    Friday, June 18, 2010 6:47 AM
  • http://www.mydigitallife.info/2010/01/27/how-to-disable-windows-7-media-player-network-sharing-service-wmpnetwk/
    Saturday, July 3, 2010 8:37 PM
  • If you disconnect your PC from the network, it works too. Sort of. Well, it doesn't solve the issue (just like leaving the homegroup doesn't) but I appreciate your attempt to help.
    Monday, November 15, 2010 8:35 PM
  • To stop once and for all media service, go to:

         - Click on "Choose media streaming options..."

         - There are 4 links on the bottom, click on "Choose homegroup and sharing options"

         - Uncheck "Stream my pictures, music and videos to all devices on my home network"

         - Click on "Save changes" and "Ok"

    That's it, now the media streaming should read "Media Streaming is off".

    Friday, January 7, 2011 2:49 AM
  • What you want to do to Disable Media Sharing (the Windows Media Player Libary sharing) is this

    - Go to your Control Panel

    - Open Admin Tools

    - Open the Services

    - Stop then Disable "Windows Media Player Network Sharing Service"

    • Proposed as answer by DavorJ Sunday, April 14, 2013 2:29 PM
    Saturday, April 23, 2011 9:13 PM
  • All posts that I've seen on this question only disable connection points but not the actual network sharing service.

    To disable the service, use Computer Management (right click on Computer select "Manage").
    Select the Services tree from "Services and Applications", find "Windows Media Player Network Sharing Service". 
    Right click on the service, select Properties.
    Click the "Stop" button to stop the service if is is running.
    Set the startup type to "Manual".
    Click OK.

    The Network Sharing Service will be disabled.



    Thanks. Worked like a dream.
    Saturday, May 7, 2011 6:31 PM
  • Use Device Manager, in the category, Digital Media Devices, Uninstall Microsoft Digital Media Server Module.  That sets you back to you were before you clicked on Enable Media Streaming).  Personally I find the whole think stinks of social engineering.  Ooooo click on the bright shiny button...Ooooo.  I guess expecting MS to insert an uninstall button on something that they are trying to promote as a "feature", is a bit too much eh?
    • Proposed as answer by Warden Hawke Monday, May 16, 2011 7:08 PM
    Monday, May 16, 2011 7:02 PM
  • worked for me as well, thnx
    Tuesday, October 18, 2011 4:48 AM
  • Go to Advanced sharing settings and click on Choose media streaming options. Then next to 'Show devices on' select all networks. Remove all devices. You'll be left with 'Media programs on this PC and remote connections...'. Select blocked or block all. That's it!

    Thanks this is just what i was looking for ... its off now :)

     

    Oh and he means by Advanced sharing settings it this...

    right click on your connection to the network icon by the clock and click Open Network and sharing Center then click on the top left where it says.. Change Advance Sharing Settings and you in...now follow the rest of this...

    Go to Advanced sharing settings and click on Choose media streaming options. Then next to 'Show devices on' select all networks. Remove all devices. You'll be left with 'Media programs on this PC and remote connections...'. Select blocked or block all. That's it!


    Spanner..

    • Edited by spannernick Monday, November 7, 2011 4:44 PM
    Monday, November 7, 2011 4:42 PM
  • You could go into 'Services' and disable 'Windows Media Player Network Sharing Service'. This will keep other computers or media players like the Sony Playstation and Microsoft X-Box from seeing a media server.

     

    Sunday, November 13, 2011 10:15 AM
  • ok, i have a slight different issue, I have 2 user profiles on my PC and i only want windows media server to work on ONE of the profiles, is that possible?

    so my question is it possible to somehow only enable "Windows Media Player Network Sharing Service" to start for one profile so my PS3 only sees 1 media server instead of two?

    Thursday, January 26, 2012 9:18 PM
  • @chonka1234, you should have started a new thread instead of hijacking this one. But I'll try to help anyway.

    Since "Windows Media Player Network Sharing Service" is a service, it's not linked to any individual profile. Therefore, your PS3 should only see one media server, no matter how many profiles are on that PC. It sounds to me like you have another PC with the "Windows Media Player Network Sharing Service" turned on.

    With that said, I have a large media library and several PS3's. I've used several different media servers, including Windows Media Player, and the best one I've found is Samsung's AllShare. AllShare loads the library much faster than Windows Media Player, and the PS3 loads the library faster and starts playing it faster. It even seems to stream smoother.

    Direct download link:

    http://www.samsung.com/global/allshare/pcsw/download/AllSharePCSW.exe

     


    • Edited by TanMan1217 Thursday, January 26, 2012 9:50 PM
    Thursday, January 26, 2012 9:44 PM
  • Thank you for agreeing with my assessment of Microsoft in general as to their ability to make user programing interfaces logical.  Just look at folder tabs.  When you press one it changes all the others.  Confusing as hell and why.  Never could figure their removing program thing either cause you have to uncheck a Microsoft program from windows installation to remove it instead of the other way around (check the program to be removed) which would be normal.  It get really confusing which programs were checked and by who.
    Wednesday, March 7, 2012 12:53 AM
  • i dont need to leave home group, because i use it for other  functions. also, i do not want to disable the complete share service.

    i just want to get the Media Streaming OFF

     Hello Mr.Bill Gate, do you think your windows is compromising our privacy? Please tell us, how to TURN THIs MEDIA SHARE OFF without stoping other services of window.

    A friend told me remove windows, USE Linux.  but you know....

    Please find us a way to turn if off ok.

    Thanks

    Monday, September 17, 2012 5:16 PM
  • Thaks duke, i didnt want it, but better than nothing, it still help me some how. thanks again
    Monday, September 17, 2012 5:21 PM
  • You could use the "Turn Windows Features On/Off" options and uninstall Media Player/Media Center from there.  I havent done it, who knows what would happen if I did.

    But I can see it's a bug because on my machine even though it says "Media streaming is on", I've disabled the Media Sharing service and now if I click "Choose media streaming options..." I have a message that states "Media streaming is not turned on" and I get the "Turn on media streaming" button.

    I also went into Media Player and clicked "Stream" then unchecked "Allow internet access to home media".  Also, I just went back into MP and now noticed that "Automatically allow devices to play my media..." is rechecked.  Aye yi yi MS.

    You can tell the development was half-assed by all the ...'s that were used at the end of all these options statements.

    Friday, October 19, 2012 8:22 PM
  • I had the same problem.  We have a few Windows 7 computers on the network and only 1 was showing it.  Since we use a Linux server to host all of our stuff, left the Homegroup in Windows 7.  I don't remember ever joining the Homegroup, but if you do not use Homegroup services, you can just leave Homegroup.
    • Proposed as answer by Khouri86 Saturday, October 20, 2012 10:23 PM
    Saturday, October 20, 2012 10:23 PM
  • Added note, you have to remove all devices on all the networks, home, work and public for media streaming to actually show as "off"
    Thursday, December 12, 2013 6:00 PM
  • hello. when i go into home group to create  one . it says join.

    deano on deano-pc which is this one but i dont have an home group . so how do i delete that one from the computer to make a complete new one? 

    Friday, July 11, 2014 6:01 PM
  • YES. The right answer.
    Monday, October 13, 2014 3:49 PM
  • The right answer was to stop the service. Actually theervice uses some CPU and on my system it makes the fan noisy having it running!

    Friday, November 21, 2014 1:01 PM
  • Apparently, when you first install windows, the "Windows Media Player Network Sharing Service" is in a Stopped state with a Manual start configuration. Basically this means sharing never turns on unless it's told to. When you click the button to enable media sharing, Windows does the following:

    1. Starts the "Windows Media Player Network Sharing Service" service
    2. Sets that service to start Automatic (delayed)

    To once again disable this as if you'd done a fresh install, do the following:

    1. Open Computer Management - (Windows 7: Right click My Computer, click Manage --- Windows 8.1: Right click Start button, click Computer Management)
    2. Expand the Services and Applications node and click Services
    3. Locate the "Windows Media player Network Sharing Service"
    4. Double click it to open the properties, or right click on it and click properties
    5. Click the Stop button to stop the service
    6. Change the Startup Type to manual. Click OK.
    7. Close Computer Management

    Now you will once again have the option to enable sharing if you wish, but it will not be enabled until you choose to do so. Once you click the button again, however, it will again start the service AND change it's startup type to Automatic (delayed).

    Saturday, April 18, 2015 3:43 AM
  • THANKS BAWOODRUFF! 

    I'M NOW ABLE TURN OFF

    Thursday, November 19, 2015 9:48 AM
  • Thanks. You da real mvp.
    • Proposed as answer by Faress21 Monday, October 24, 2016 3:37 AM
    Monday, October 24, 2016 3:37 AM
  • Thank You For The INFO
    Tuesday, February 21, 2017 12:47 AM