none
How do I disable Credential/Device Guard? RRS feed

  • Question

  • Hello, I have Windows 10 Enterprise on my PC. I recently enabled Credential Guard and Device Guard for fun. I heard they were new features for Windows 10 Enterprise. My problem started when, I wasn't able to open VM's on VMware Workstation Pro. It gave the error: 

    VMware Workstation and Device/Credential Guard are not compatible. VMware Workstation can be run after disabling Device/Credential Guard. Please visit http://www.vmware.com/go/turnoff_CG_DG for more details

    I tried the link and disabled "Virtualization Based Security" the same way I enabled it in the first place. Then I disabled Hyper-V in control panel. There's a bunch of CMD lines (from the link) I didn't use because it told me to use an "unused drive" and I don't know what that means...I tried C:. If I can get what drive to use figured out that might fix it, but I'll continue. I had geek squad remotely connect and try disabling it but they couldn't get VMware to run and got the same error. 

    Now, I decided to perform a clean install of Windows from my bootable Windows 10 Enterprise USB. After installing Windows, I installed VMware Workstation from a back-up on a SD Card. I installed a VM of Windows 8.1 Enterprise and started it up. Then I got the same error that "VMware Workstation and Device/Credential Guard are not compatible." I went into gpedit and it says device guard is set to "not configured" like it was before I enabled it for the first time (off.) So how do I disable Device/Credential Guard so I can use VMware? Isn't it weird that it's still on after reinstalling Windows (clean) and shows up as "not-configured" in GPO? If I want to try the CMD lines from the VMware link (see above) what should I enter for the unused drive? I've got a blank SD card. 

    Please reply with how to disable the Guards so I can get VMware working. And what drive letter I should use in CMD (or an explanation of what that means.) Thank you

    Friday, June 2, 2017 7:18 AM

All replies

  • Hi, I got it working! I used the unused drive letter "A" and ran the commands (from the above link) and rebooted and disabled the two Guards during boot. Now it's working fine.
    Friday, June 2, 2017 10:26 PM
  • Hi ,

    Very glad to hear that you have got it working. Please "mark it as answer" to close the case and help other community members who have similar questions find the helpful reply quickly.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 5, 2017 1:41 AM
    Moderator
  • I meet the same problem and use the same way , how to find the unused dirve?
    Tuesday, July 3, 2018 5:32 AM