Windows 7 64 bit won't join domain running sbs 2003 32 bit with sp2


  • I have a Windows 7 64 bit laptop that won't join a domain.
    Server = sbs 2003 with sp2

    Tried listing computer in active directory and then joining domain
    Tried the wizard.
    Tried disabling ip6

    I'm not running exchange, and the domain is local.

    Any help would be appreciated.

    Tuesday, January 26, 2010 5:51 PM

All replies

  • Steve,

    I can assure you that the problem is not the fact that you are using Windows 7 64 bit. I'm using the same and I'm joined into domain without a problem.

    Here are some things to check:

    1. DNS setting on your Win7 computer. Your Win 7 computer should use a DNS server capable of resolving names in your domain.

    2. General connectivity. Can you ping your domain controller using:
      a) IPv4 address.
      b) Fully Qualified Domain Name.

    3. If points 1 and 2 above are OK, ask your Domain Admin to check your computer ac count in AD. He may need to reset or even delete your computer account  in AD.

    4. You may need credentials that allow you to join computer in AD.

    5. Is your computer name correct? You should avoid names longer than 15 characters and names that use special characters (like underscore).
    Wednesday, January 27, 2010 8:32 AM
  • I'll give it a try and let you know, Thank you for the info.
    Wednesday, January 27, 2010 3:49 PM
  • Do you get any errors?  There's no problem running Win 7 with Win 2003 DC, that usually works fine. 

    When joining the domain, ensure you have the proper rights, and check the PC & DC eventlogs for errors when you try to join your computer to the domain.  Maybe there will be some error message which will shed light on the issue, and you could post that here if you cant get it fixed.

    Wednesday, February 22, 2012 2:10 PM
  • Hi,

    I am having trouble joining Windows 7 x64 to SBS 2003 x86 with SP2.

    Ignoring the errors, and restart Windows 7, issues follows with relationship error, and I found some tips on Internet to modify my SPN to add the machine name.

    It allows me to logon, but when looking at the Local Users and Groups; Administrators group. Domain admin is showing with a SID ID instead of the name, i.e S-1-5-21-2009958510-2831610812-1974053125-512

    When you trying to add a new domain/user, it will not allowed. 

    But joining Windows 7 32 bit to SBS 2003 has no issues. Name list of users are showing the correct information, NOT SID, and adding domain/user have no error.

    Is there something that I need to install or patch required on my SBS 2003 x86?

    There is no problem with Win 7 x64, as I have tried to join to SBS 2008 on my test environment, it join with no errors.


    Tuesday, March 06, 2012 5:26 AM
  • Hi

    I've been having the same problem - just with Win7 x64. Win 7x32 is fine.

    Sorry, haven't found solution yet but am thinking it may have something to do with ISA ?? as problem only seems to occur where there is ISA installed. 

    Friday, March 09, 2012 9:32 PM
  • I too have ISA installed on SBS 2003.

    I could not work out how it is associated. I am more relying on some update likely needed on SBS 2003 for a mixed mode environment of workstations, But what it is I am not sure. Will keep you post it if I found something.



    Monday, March 12, 2012 5:15 AM
  • Hi,

    Anyone out there have an answer to this as yet?

    Or any instruction or link to how am I able to reslove this.

    Friday, June 01, 2012 2:27 AM
  • This flaw is fixed by editing the section ADSIEDIT computer and directly on the computer you want to join the domain and attribute properties servicePrincipalName, we add HOST / FQDN of the computer

    After that I have not been possible to apply GPO

    When I have the solution with the taste informs

    Saturday, July 14, 2012 1:31 PM
  • Hi!

    anybody have an answer? I could join win7 x64 and server2008 x64 to my sbs2003 domain using the workaround sugested by Antonio, but now I can't apply GPO and I need it...

    thanks in advance!

    Wednesday, April 10, 2013 10:59 AM