Windows 7 startup error 0x490 + windows partition size 0


  • Hi folks,

    My workstation has run into a windows startup problem and I would really appreciate any sort of help.

    1.When i start windows it goes till the splash screen and then I see  the blue screen for a second and it restarts. When I ran windows repair using the win7 dvd i observed these 2 things:

    a) it shows the size of windows installation to be 0 and the location to be (unknown local disk).

    b) windows startup repair can't fix it and returns this error 
    "Root cause found
    Boot configurations is corrupt.
    Repair Action : Partition table repair.
    Result: Failed. Error code = 0x490."

    2. When I tried to reinstall windows, the setup only shows 107mb system reserved partition on the SSD and nothing else.

    3. a)I tried using boootrec.exe command with /FixBoot and /FixMbr options, they return action successful even though the problem is still persisting. 
        b) I also tried the /ScanOs and /RebuildBcd options with bootrec.exe but they return "total identified windows installations:0"

    4. I booted from a linux live usb and tried to see whats going on. The filesystem seems to be there but the size of the ssd drive is a meagre 107mb and its labeled "system reserve" even when it has all the os files in there.

    Just before this happened, I was trying to make some partitions by shringking one of the existing volumes in the data drive (which is 2tb hdd) and it gave me an error "drive already has max number of partitions".

    So I So i tried using partition magic which had compatibility issues and didn't run properly. It tried to fix some corrupt boot sectors but then failed. so I closed it down and restarted the pc. It hasn't booted up after that.

    Now I I think it messed up the partition table because in addition to the problems on the ssd, I cannot see 2 of my partitions on the data drive as well.

    I would really appreciate any help on this. 
    Thanks a lot.

    Friday, September 28, 2012 6:30 PM


All replies

  • There has been to much changes to repair your installation. Namely the shrinking boot partition when partition table is not adapted is fatal.

    Try to  boot from installation DVD and go to Update.



    Friday, September 28, 2012 6:43 PM
  • I'm having the same issues. I shrunk my W7 Partition to create a partition for W8 RTM and after install I'm unable to get back into W7 it just BSOD's after boot animation.

    When I use the install DVD it shows Windows 8 and "Windows 7 (Recovered)" "Partition 0 Megabytes" "(Unknown Location) Local Disk"

    Personal Files are intact and reachable using W8 and a Linux Partition.

      • Normal Startup BSOD
      • Safe Mode BSOD
      • Last Known Configuration BSOD
      • Startup Repair was unable to repair my windows installation.
      • ChkDsk found no errors.
      • SFC will not run on partition requires, Repair Operation in progress please restart and try using SFC again, or something to that effect not verbatim.
      • Update Windows requires me to run it from desktop.

    Any possible solutions would be greatly appreciated.



    • Proposed as answer by Nyktelios Tuesday, October 09, 2012 4:10 PM
    • Unproposed as answer by Nyktelios Tuesday, October 09, 2012 4:10 PM
    Tuesday, October 09, 2012 9:51 AM
  • At some point the disks have been changed from logical to dynamic, which apparently caused a lot of these to be unable to read/recognise the partition.

    As much I love Microsoft and there was not a way to convert my disk back without wiping using their tools. So I used "Easus Partition Master" to convert it back logical, I then ran the start-up repair it found C:\....\Windows\winlogon.exe to be corrupted fixed and rebooted W8 found a second W7 Partition it then ran ChkDsk and booted into my W7.

    • Proposed as answer by Nyktelios Tuesday, October 09, 2012 4:23 PM
    Tuesday, October 09, 2012 4:23 PM