none
An error occurred while reconnecting...The local device name is already in use. The connection has not been restored. RRS feed

  • Question

  • I have a Windows Server 2008 R2 domain. A user with a laptop running Windows 7 Professional opens some network folders and leaves them open. His computer goes to sleep. When the computer wakes and he unlocks it, the network folders appear empty and the following error dialog is open:

    An error occurred while reconnecting <drive letter> to \\<file server>\<share>
    Microsoft Windows Network: The local device name is already in use.
    This connection has not been restored.

    After clicking OK, he has to refresh the network folder for the contents to reappear.

    The shared drives are mapped via Group Policy Preferences. The issue is not limited to that computer.

    I have already tried this hotfix linked in this question, but it did not help. I've since uninstalled it.

    I've turned on the Reconnect option on the GPP (had it off because I thought it wouldn't matter since GP gets applied frequently). No change.

    The problem computer already has NIC power saving turned off from a previous issue.

    Thursday, August 2, 2012 4:15 PM

All replies

  • If i am correct, Windows shuts off all network cards when the computer goes to sleep.  When this happens, all open connections will be severed.  In order to get them back, you must refresh the connection.

    I don't know if there is a fix for this or not... I've never found one.

    Thursday, August 2, 2012 5:20 PM
  • Hi,

    As this issue is more related to the domain share configuration, in order to get the answer effectively, it is recommended to submit a new question in Windows Server Forum.

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Regards,

    Sabrina

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Friday, August 3, 2012 4:40 AM
  • Hi Sabrina,

    I already posted in the Windows Server\Platform Networking forum and was told to post here instead. Which is correct?

    Thanks.

    Friday, August 3, 2012 5:48 PM
  • Still looking for help with this.
    Tuesday, August 7, 2012 8:26 PM
  • Hi,

    You may try to check if there are any third party services which caused this issue.

    Regards,

    Sabrina

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Thursday, August 9, 2012 3:48 AM
  • Hi,

    You may try to check if there are any third party services which caused this issue.

    Regards,

    Sabrina

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Okay, that's actually rather vague. Can you be more specific?

    These Windows installations are pretty typical. I can reproduce the issue on multiple computers so it's not specific to that one.

    It seems to me that this is a bug in Windows itself. Windows tries to reconnect to the network drive after the computer wakes before the network connection is ready. I can demonstrate this by disabling NICs and attempting to open the network drive. I receive the same error.

    Thursday, August 9, 2012 4:31 PM
  • Hi,

    Is there any third party security programs installed on the computers and server? Did you check if they will cause this issue?

    Also, you may try to boot in Clean Boot to see if the issue persists.

    Regards,

    Sabrina

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Friday, August 10, 2012 5:25 AM
  • Hi,

    Is there any third party security programs installed on the computers and server? Did you check if they will cause this issue?

    Also, you may try to boot in Clean Boot to see if the issue persists.

    Regards,

    Sabrina

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    ESET Endpoint Protection 5.0 is installed. Disabling it has no effect.

    Doing a clean boot has no effect.

    Friday, August 10, 2012 9:04 PM
  • let you try  persistent mapping options

    NET USE N: \\[IP address or machine name]\[path] /PERSISTENT:YES

    let me know..

    Monday, August 13, 2012 3:15 AM
  • let you try  persistent mapping options

    NET USE N: \\[IP address or machine name]\[path] /PERSISTENT:YES

    let me know..

    Haven't had a chance to try this yet, I'll do that as soon as I can. Thanks.
    Wednesday, August 15, 2012 11:45 PM
  • Have you seen this post

    http://social.technet.microsoft.com/Forums/en-US/winserverPN/thread/d74eb1c2-7b67-4b51-87d5-f7e02e6968a7

    Hi Josh,

    Thanks for posting here.

    It seems a known issue and had been fixed in KB 2663418, not sure if this is the patch you referred but could we first patch it and see how is going ?

    You have to wait more than two minutes before you can access mapped drives when you wake a Windows 7-based computer from sleep

    http://support.microsoft.com/kb/2663418

    We also had a similar issue before:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/94ca19d9-0732-48aa-8896-b576d780cdf2

    And this issue appears to be related to Windows client OS. For peer experience and suggestions, you may wish to post to the Windows 7 support forum. This will provide access to others who read the public forum regularly who will either share their knowledge.

    http://social.technet.microsoft.com/Forums/en/category/w7itpro

    Regards,

    Tiger Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    Tiger Li

    TechNet Community Support

    • Proposed as answer by gerrym52 Wednesday, September 17, 2014 1:28 PM
    Thursday, August 16, 2012 3:56 AM
  • Have you seen this post

    http://social.technet.microsoft.com/Forums/en-US/winserverPN/thread/d74eb1c2-7b67-4b51-87d5-f7e02e6968a7

    Hi Josh,

    Thanks for posting here.

    It seems a known issue and had been fixed in KB 2663418, not sure if this is the patch you referred but could we first patch it and see how is going ?

    You have to wait more than two minutes before you can access mapped drives when you wake a Windows 7-based computer from sleep

    http://support.microsoft.com/kb/2663418

    We also had a similar issue before:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/94ca19d9-0732-48aa-8896-b576d780cdf2

    And this issue appears to be related to Windows client OS. For peer experience and suggestions, you may wish to post to the Windows 7 support forum. This will provide access to others who read the public forum regularly who will either share their knowledge.

    http://social.technet.microsoft.com/Forums/en/category/w7itpro

    Regards,

    Tiger Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    Tiger Li

    TechNet Community Support

    Yes, I mentioned trying that hotfix in the original post.

    Thursday, August 16, 2012 3:57 PM
  • Hi Josh,

    I would like to know if you have any opportunity to try mappring persistent by the command:

    NET USE N: \\[IP address or machine name]\[path] /PERSISTENT:YES

    After that, please let me know your result.

    Thanks.

    Best Regards,

    Annie

    Friday, August 17, 2012 8:06 AM
  • let you try  persistent mapping options

    NET USE N: \\[IP address or machine name]\[path] /PERSISTENT:YES

    let me know..

    @zon-ze.com @AnnieGu I get the same error. I excluded the user from the drive map group policy, disconnected the mapped drives, and ran that command with a new drive letter.
    Friday, August 17, 2012 11:01 PM
  • I now think that this isn't problem with any GP or mapped drives.

    I think it's the computer problem. I want you to make it not to sleep at all.. just screen goes saver thing but not sleeping.. I want you try it first.. 

    Friday, August 17, 2012 11:48 PM
  • No problem when using screen saver/DPMS only.
    Friday, August 17, 2012 11:50 PM
  • guess they it's one of driver is messing around.. 

    could be graphic card or could be network card..

    i guess this can be network card.. try to update the card..

    that's all I can think of for now.

    www.zon-ze.com
    • Edited by zon-ze.com Saturday, August 18, 2012 12:09 AM
    Saturday, August 18, 2012 12:01 AM
  • Hi Josh,

    1.    Have you tried to modify the KeepConn key on the client:
    a. Click Start, click Run, type regedit and then click OK.
    b. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters
    c. In the right pane, click the KeepConn value, and then on the Edit menu, click Modify. If the KeepConn value does not exist, follow these steps:
    d. On the Edit menu, point to New, and then click REG_DWORD.
    e. Type KeepConn, and then press ENTER.
    f. On the Edit menu, click Modify. Click decimal.
    g. In the Value data box, type 65535, and then click OK.

    2.    Please also change the autodisconnect key on the server.
    a. Click Start, click Run, type regedit and then click OK.
    b. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
    c. In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps:
    d. On the Edit menu, point to New, and then click REG_DWORD.
    e. Type autodisconnect, and then press ENTER.
    f. On the Edit menu, click Modify. Click Hexadecimal.
    g. In the Value data box, type ffffffff, and then click OK
    Note that: After you changing the registry, please reboot the server side and the client side.

    Best Regards,

    Annie Gu


    Tuesday, August 21, 2012 8:09 AM
  • I rarely have an opportunity to reboot the file server but I have made those changes and rebooted the client. I opened a network folder, let the computer sleep for a few minutes, and woke it. I got the same error.

    Note that the Microsoft KB at http://support.microsoft.com/kb/297684 doesn't say that a reboot is required.

    I'll settle for the folder being empty on wake, as technically this happens when the network connection is lost just before the computer enters sleep, I just want to stop getting the error. The error only comes up because Windows attempts to enumerate the folder contents before the network is ready. If I let it sleep for 30 seconds I see an empty folder but no error. This might just be one of those unsolvable issues.

    Tuesday, August 21, 2012 4:44 PM
  • Hi Josh,

    Thanks for your reply.

    I understand that you are unable to reboot the server. However, to ensure the registry changes affect the machines, we usually suggest to reboot the machine. And these two registry are related to the lanman service, so please restart the lanmanserver service(server service) and the lanmanworkstation service(client service).

    Then, try again to see if the issue will be improved.

    Besides, I noticed that you said the issue can be related to the network connection lost, we could do the test to see if the problematic client's connection is kept alive or not:

    When the client goes to sleep, please use another machine to ping this problematic client to see if there is any response.

    If you got the ping response, then this problem is probably caused by SMB connections.

    Please test this and let me know the result of it.

    Thanks for your help.

    Best Regards,

    Annie Gu

    Wednesday, August 22, 2012 8:03 AM
  • Hi Jeremy, I was wondering if you ever got a solution to this issue?  I was experiencing exactly the same issue.  Thank you.


    • Edited by p1n Thursday, May 29, 2014 3:45 PM
    Thursday, May 29, 2014 3:39 PM
  • I had the same issue, to fix it all I did was disconnect the drive, went to my computer, right click, map network drive and when setting up the path to the share folder I placed a check mark on the option "Connect using different credentials"..for some reason it was using the local admin credentials.

    so all I had to do was use the username and password for the domain user and woa la! it worked..

    although don't forget to  check the box to remember credentials when logging in as the domain user to access the map drive.

    hope that helps

    Tuesday, June 10, 2014 2:45 PM
  • This plagued me for some time with no resolution.  Every morning I would have to reconnect all my network resources.  Sometimes, while actively using my PC, network connections would drop out then fail to let me reconnect.  I would then either have to log off or reboot.

    Then, I told my awesome IT guy about the problem and he knew just how to fix it.  He said he had seen it before with other users/systems.  Its an easy fix:

    • Start Menu
    • Right-Click "Computer", select Manage
    • Double-click Device Manager
    • Double-click Network Adapters
    • Double-click on your NIC card in the above list
    • Open up its properties
    • Under the 6th Power Management tab, find first checkbox related to letting the computer turn off this device to save power and un-check the box.
    • Leave the second box checked that allows this device to wake the computer (WOL function)

    Voila, your shared network connections and mapped network drives will persist always.  Your credentials will persist during the entire boot.  Problem is now solved.  Power bill might go up a bit though.

    Hope this helps.

    Cheers!

    • Proposed as answer by Georgewpg Monday, October 29, 2018 9:15 PM
    Sunday, February 14, 2016 12:48 AM