none
Edge Still doesn't pass domain credentials RRS feed

  • Question

  • I have been complaining about this through feedback since I first started using Edge and I see others have too.  

    See this thread:

    https://social.technet.microsoft.com/Forums/en-US/a632fcb2-0eaf-4c88-a9cf-ea2e8165e57d/ieedge-not-passing-thru-authentication-10240?forum=WinPreview2014General.  

    In this thread, MS's response was enable cookies and save your username/password.  Neither of which address the issue, and both can violate corporate policy and are just bad practice.

    Nobody has given a reason as to why Edge is not passing domain credentials to websites including SharePoint.  When browsing to our company SharePoint site, it is prompting for username/password.  This is unacceptable behavior for something that will be picked up by corporations very soon.  You're forcing them to use IE as their default browser because of this.

    I'm also highly displeased with the level of control over Edge.  There are nearly no browser settings.  Does Edge share IE's settings.  For example, if I add a site to the Trusted list in IE, will Edge also trust it?

    Can someone step up and take ownership of this issue?

    Wednesday, August 5, 2015 5:33 PM

All replies

  • Hi maxdiorio,

    Please check for updates manually and restart the machine to have a check.

    I have made a test from my own machine and I didn`t get the username/password UI  when I get into the files once I have signed into the Sharepoint website successfully.
    Have you checked the "Remember my credentials" option?
    Please sign out and sign in again to have a check.

    As for the trusted site question, "Microsoft Edge lets you continue to use IE11 for sites that are on your corporate intranet or that are included on your Enterprise Mode Site List. " The trusted site is not listed, I am afraid it is not supported.

    Microsoft Edge is the default browser experience for Windows 10. However, if you're running web apps that need ActiveX controls, we recommend that you continue to use  Internet Explorer 11 for them.

    Here is a link for reference of Internet Explorer and Microsoft Edge.

    Browser: Microsoft Edge and Internet Explorer 11

    https://technet.microsoft.com/en-us/library/mt156988%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 7, 2015 8:13 AM
    Moderator
  • Deleted
    Friday, August 7, 2015 8:24 AM
  • I have made a test from my own machine and I didn`t get the username/password UI  when I get into the files once I have signed into the Sharepoint website successfully.
    Have you checked the "Remember my credentials" option?

    This is the "response" from Microsoft that is unacceptable. I shouldn't have to enter my credentials in a Kerberos domain when logging into corporate internal sites. Especially Microsoft's own SharePoint. The browser should pass the credentials of the currently logged in user.

    I shouldn't have to enter my credentials and then save them.  Are we trying to lock out user accounts when passwords change?

    Sunday, August 9, 2015 1:08 PM
  • Alan,

    I'm curious as to what in your group policy is allowing this to happen without prompting? Are you sure you didn't save your password :) 

    Just running a gpupdate /force isn't going to make it work unless a domain admin updated a GPO.  This might possibly give me some hope that there is a setting somewhere in group policy to make this work.

    Max

    Sunday, August 9, 2015 1:12 PM
  • I agree, we have this problem as well and saving credentials rather than passing them is not acceptable. As another person pointed out, this is begging for account lock outs.

    If MS wants Edge in the workplace, it needs to pass credentials. If not, it will never gain traction there.

    Wednesday, January 6, 2016 5:47 PM
  • I cant believe that Microsoft are happy to leave issues like this with no response. You could understand this on a third party support forum, but not on their own TechNet pages.

    Sometimes I think Microsoft have people working for them who are just determined to make their products fail.

    Thursday, February 4, 2016 12:04 AM
  • This may be nothing, but it sounds like it could be similar.

    With SQL Server Reporting Services, when trying to access the SSRS web app from the machine hosting it, there are authentication issues unless the browser is running with elevation, or "Run as Administrator."

    If running elevated works, it's not exactly a solution, but could function as a temporary workaround.

    Saturday, August 6, 2016 9:46 PM
  • I'd like to keep this thread going.... It's unacceptable that MS would expect Edge to replace IE and not support their own infrastructure. I have to keep my domain users on regular HTTP access with SharePoint to ensure there is no credential pop-up.

    SSL works fine passing credentials in IE, but not edge still. I raised the issue myself while Win10 was in beta, and here we are with the first SP on Win10, and same thing.

    C'mon!

    Monday, August 22, 2016 8:26 PM
  • I agree that this is not acceptable. Even Chrome can handle this but Microsoft's own shiny new browser won't!
    Wednesday, August 24, 2016 11:17 AM
  • Agreed, this is totally unacceptable. Very frustrating.  I'm having the same issue.  Getting prompted over and over again in Edge for my credentials.  In IE11 you can set the site to a Trusted site, and call it a day.  With Edge, no so much....   Microsoft, HELP!!
    Friday, April 14, 2017 5:26 PM
  • Well folks, I do believe there is hope. 

    Just finished installing the "Creators" update, and logged onto SharePoint over SSL in Edge with no pop-ups. Can anyone else confirm? 

    Would also like to know if 1607 was patched with the fix...

    Tuesday, May 2, 2017 2:52 PM
  • Deleted
    Thursday, May 11, 2017 6:30 PM
  • I'm running version 1703 Build 15063.138 and I can tell you the problem still exists. It will save my username, but not my password.

    I can't even recreate this now, but I'll try a few other computers to make sure it's not just me. 

    Thinking back to the only other changes I made. I swapped out the cert from standard to wildcard, but that shouldn't make a difference. Also cleaned up some incorrect GPO entries for trusted sites, maybe my own domain was put in there wrong. 

    Key is to ensure the site is in your trusted sites list for IE. But shouldn't be prompting for credentials at all if it works right.

    Thursday, May 11, 2017 6:52 PM
  • Deleted
    Thursday, May 11, 2017 9:12 PM
  • This is still not fixed in Edge today. It freaking asks the domain credentials every god damn time. There is a check box to save the credentials. It doesn't do a thing. I don't want to enter my domain credentials million times a day. I made Firefox is my default browser and moved on.

    Time to time, I check the Edge browser after an update. At some point, Microsoft has to wonder why Edge browser usage is not picking up.


    <g class="gr_ gr_6 gr-alert gr_gramm gr_inline_cards gr_disable_anim_appear Style replaceWithoutSep" data-gr-id="6" id="6">Anand</g>



    • Edited by anand_pv Tuesday, November 6, 2018 7:51 PM
    Tuesday, November 6, 2018 7:49 PM
  • I have been running into this issue for a couple months and a peer of mine shared a solution that worked for me so sharing it here in case it might help someone else.

    Go to Control Panel > Internet Options > Security > Custom Level > scroll to bottom and under 'User authentication' change radio button to 'Automatic logon with current user name and password. You can do same thing with Local Intranet and Trusted Sites.

    Friday, January 4, 2019 6:59 PM
  • I have been running into this issue for a couple months and a peer of mine shared a solution that worked for me so sharing it here in case it might help someone else.

    Go to Control Panel > Internet Options > Security > Custom Level > scroll to bottom and under 'User authentication' change radio button to 'Automatic logon with current user name and password. You can do same thing with Local Intranet and Trusted Sites.

    That's exactly what is not working.

    Works perfect for IE, but Edge ignores it.

    We have the same issue.

    Wednesday, February 20, 2019 8:39 AM
  • Here at the company we just received the "approved" update 1809, OS build: 17763.593 and the issue still persists.

    By changing the Security settings under Internet Options has no effect.

    Also, if Microsoft wanted to rebuild/reinvent their browser by creating another "chromium-based" browser, they should do better, not worse.

    At the beginning of Edge browser I thought I would like it, but since we didn't see any solution for this common issue, I move away. Even Opera browser pass the current logged in user credentials to the intranet sites!

    Why Edge cannot?

    Wednesday, July 17, 2019 1:37 PM
  • Can't believe it's coming to the end of 2019 and this issue hasn't been fixed?

    Is MS trying to prevent all developers from using MS Edge? If we have IIS installed locally, every site we created get prompted for credentials over and over again! For this reason I've never used MS Edge as my primary browser even if I want to. 

    Crazy!

    Wednesday, October 9, 2019 11:01 PM
  • Integrated authentication is a vast field, so assuming you have proper corporate domains with AD and IIS servers delivering proper "Negotiate" headers and such, please note some peculiarities of Chrome and Firefox (thus including Chromium spin-offs):

    * Those browsers have an aversion regarding single-label hostnames eg. http://intranet. They do not DNS-resolve in advance as IE does and so your internal sites may a) be relayed over your corporate proxy server even if you have *.mydomain.tld in your proxy exclusion list in the browser and b) Kerberos/Negotiate won't work because they don't know whether to delegate credentials to or not (if there is an auth domain defined, see next point).

    * In recent versions both Firefox and Chromes _can certainly do_ Negotiate, but you also need the proper settings. For Chrome and Edge there are ADMX templates you can import into your central store and make a policy for default browser settings. Under HTTP settings define your authentication (internal) servers eg. *.mydomain.tld. Maybe single-label names work too, but I haven't tested that yet much (potential proxy issue). In any case after creating/applying the policy test your company servers/URLs in _FQDN form FIRST_. For Edge you may also need to take a look at the Enterprise Mode Site List and policy especially regarding the new integrated "IE" mode in the new Edge which is a Microsoft exclusive.

    At least for FQDN URLs and with the proper GPO settings I can guarantee that integrated auth/credential delegation works.

    But with non-FQDN URLs and all the things that occur in a corporate domain I understand your pain - several reasons I had always to be conservative about additional browsers to IE - people perceived me as Firefox/Chrome hater but I just saw the corporate implications the others didn't. Eg. a long time ago the early Firefoxes had no Kerberos support at all, there wasn't even a "use system proxy" setting - and only very recently they _finally_ added a config flag to use the OS certificate store instead of their cert8/9.db (I have our specific trusted CAs in Public Key GPO).

    Please note this Edge Enterprise link for MSI and templates:

    https://www.microsoftedgeinsider.com/en-us/enterprise

    Regards, HTH

    Markus

    Tuesday, November 12, 2019 11:37 AM