none
Resolution under UEFI in WINPE ADK 1703 RRS feed

  • Question

  • These was this question asked in regards to WinPE 4.0

    https://social.technet.microsoft.com/Forums/windows/en-US/eb9c59df-7f93-487e-ae59-c5954da5866f/resolution-under-uefi-in-winpe-40?forum=w8itproinstall

    But it still stands.

    WinPE from ADK 1703 used as boot image for SCCM CB 1706

    If machine is set to UEFI BUT with CSM enabled, winpe.jpg 800x600 is displayed fine "fine" on full HD screen during task sequence (resized, but nothing missing)

    If I turn off CSM then the winpe.jpg displays zoomed part only (with majority of the image missing)

    Not that I care that much about the image itself, but mine has text to display to user to explain what is happening.

    In UEFI it is just not displaying (as it gets cut off)

    I really do not fancy installing video driver in WinPE for each model , like per this

    Is there a way to just display the same as in MBR/PXE/CSM ?

    What is the "correct" winpe.jpg resolution for UEFI boot?

    Seb

    Thursday, August 10, 2017 9:19 PM

All replies

  • Hi, 

    Windows PE (Windows Preinstallation Environment) is a lightweight version of Windows used for troubleshooting an operating system while it is offline. Previously I’ve written an article on how to create a bootable Windows PE CD or USB flash drive. But the default resolution of Windows PE is 800 x 600, Is there a way to change the screen resolution to fit on your screen?

    To set screen resolution in WinPE, simply put an answer file named unattend.xml file in the root of the WinPE ISO image with the following content.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
      <settings pass="windowsPE">
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64"
    publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS"
     xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
              <Display>
              <ColorDepth>32</ColorDepth>
              <HorizontalResolution>1024</HorizontalResolution>
              <RefreshRate>60</RefreshRate>
              <VerticalResolution>768</VerticalResolution>
              </Display>
        </component>
      </settings>
    </unattend>
    


    If your Windows PE is a 32-bit Windows environment, remember to change the processor architecture from amd64 to x86. Also, since Windows PE 4.0, it doesn’t like 16-bit color depth, so when changing to 32-bit it would work perfect.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 14, 2017 6:35 AM
    Owner
  • Hi, 

    Is there any update on your issue? 

    If there is any further question, please post back the detailed information to clarify your issue.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 18, 2017 5:50 AM
    Owner
  • All my images (SCCM boot images) are 64-bit, same .wim image works under MBR or UEFI boot

    In MBR it background winpe.jpg displays correctly , in pure UEFI boot it does NOT

    That is the update on the issuewinpe.jpg is already 800x600



    • Edited by scerazy Monday, August 21, 2017 3:22 PM
    Sunday, August 20, 2017 3:58 PM
  • Hi,

    Have you tried to add the graphic driver for UEFI boot task sequence?

    You can refer to this link, please just download the proper graphic card driver according to your PC:

    https://www.niallbrady.com/2015/04/28/how-can-i-set-video-resolution-correctly-during-uefi-network-boot-dynamically-in-system-center-2012-r2-configuration-manager/

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 5, 2017 2:21 AM
    Owner
  • Thanks, will need to test it, but looks good

    Seb

    Friday, September 29, 2017 11:30 AM