Error when running "regsvr32 schmmgmt.dll" to add the Schema Management Snap In on Windows 8 RRS feed

  • General discussion

  • I am running Windows 8 Enterprise and trying to install the Active Directory Schema Management MMC Snap In.

    When I follow the procedure listed via the link below, it doesn't work, I get an error.      

    The error message that I get is shown below.

    I did a search and found schmmgmt.dll in the "C:\Windows\System32" folder, but if I do a "C:\> regsvr32 C:\Windows\System32\schmmgmt.dll", I still get the same error.

    Any ideas how I can register this .dll so that I can use the Active Directory Schema Management Snap In in Windows 8 Enterprise?

    I do not have this problem on Windows 7 or Windows XP, so I am thinking this must be a "Windows 8" thing.

    I have a support case open with Microsoft Premier Support and will post the resolution when I get it, but in the interest of saving time, if anyone already dealt with this and has a quick fix, I'd be happy to take a look at it.

    Wednesday, August 7, 2013 12:15 PM

All replies

  • Hi,

    I have not found the files in my computer. Can you please double check that.

    Juke Chou
    TechNet Community Support

    Thursday, August 8, 2013 1:04 PM
  • Hi man.
    I had the same problem , but i resolved this mode.
    first you start, you need to download the Remote Administration Tool. (RSAT)
    you can download this in: and later, you do in CMD how admin, the next comand " regsvr32 schmmgmt.dll " (remember delete " ")
    Is my first post, but i know resolve you problem .

    Un saludo !
    Wednesday, May 14, 2014 10:55 AM
  • you need to open the command prompt as administrator and then run 'regsvr32 schmmgmt.dll' from the command prompt
    • Edited by master1982 Friday, July 5, 2019 9:21 AM
    Friday, July 5, 2019 9:21 AM