none
Windows 7 and .NET Framework 4.5.2 RRS feed

  • Question

  • Hi,

    I have a new application that we are planning to deploy which requires Windows 7 to be at .NET Framework 4.5.2. Is it necessary to install all .NET versions leading up to 4.5.2 or does this latest version include all of the other Frameworks? Do I need to install each of the versions?

    • .NET Framework 4.0
    • .NET Framework 4.5
    • .NET Framework 4.5.1
    • .NET Framework 4.5.2

    I'd just like to make sure in case it's not necessary to install all of these version to get to 4.5.2 yet fully support the older Frameworks.

    Thanks,

    Rob

    Wednesday, October 5, 2016 6:37 PM

Answers

  • Hello,

    There is no need to install all the .NET versions until the one you require.

    cheers,

    nuno


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, October 5, 2016 6:40 PM

All replies

  • Hello,

    There is no need to install all the .NET versions until the one you require.

    cheers,

    nuno


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, October 5, 2016 6:40 PM
  • Nuno,

    Thanks for your feedback! I will try that out and report back on the results.

    -Rob

    Wednesday, October 5, 2016 6:44 PM
  • Hi rob,

    How about the issue now? Is there anything to update?

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 11, 2016 8:50 AM
    Moderator
  • Rick,

    I have added it to my SCCM task sequence and it is deploying fine. I still need to conduct testing to validate backwards compatibility.

    -Rob

    Wednesday, October 12, 2016 7:28 PM
  • The Outlook Add-in we are using requires .NET Framework 4.5.2 but I opted to install .NET Framework 4.6.2. The Outlook Add-in is working as expected even with the latest .NET Framework installed. So it looks like the answer is that the Frameworks are indeed backwards compatible (at least with like major versions).

    Thanks to everyone that helped on this one!

    Wednesday, October 26, 2016 6:00 PM
  • Vista uses .NET 4.5.2  however Win 7 uses .NET v4.6

    Also,.NET is a required software for windows/update,if the software isnt available,forget updates.To verify,

    1st open windows components,chk the boxes for .NET,once thru,open run,or cmd,type: services.msc

    Locate .NET software,double click on one,at least set to "manual" this way the OS can/will run it as needed.

    Also,.NET 4 series is good,but .NET 1.1 2.0 3.5 are all needed,each runs as C++ versions do,seperate,but all

    needed...Youre OS will determine the running of all....Forget the replies ".NET isnt needed" its a must.

    Thursday, October 27, 2016 3:43 AM
  • Andrew,

    I suppose this post could be a little misleading but I have always included .NET 1.1 2.0 3.5 because sooner or later something will require those older versions. I usually run into drivers that require an older version of .NET. My main question was centered on .NET v4.x.x because I didn't know if it would be backwards compatible. It turns out that it appears to be backwards compatible based upon our Outlook Add-in testing with the latest .NET version installed.

    -Rob

    Thursday, October 27, 2016 9:48 PM