HomeGroup stops working Streaming Tab in MC disappears Remote connections refused after SP1


  • After installing SP1 on Windows7 Enterprise, the home group screen just says “ ! HomeGroup is not ready yet. Please try again in a few minutes. If this message . . . . “ and there is the option to start the HomeGroup troubleshooter, which results in no fixes.

    Also in Windows Media Centre the “Stream” tab in the library screen no longer appears. If you go to the advanced sharing options and try to turn on media streaming the button greys out for a few seconds then comes back with the option “Turn on media streaming”

    RDP connection can no longer find the computer.

    Has anybody got an answer other than the obvious, don’t install SP1?

    Sunday, March 06, 2011 4:44 PM

All replies

  • Hi,


    I cannot reproduce your issues; I suggest you try the following steps to see how it works:


    1.    For your HomeGroup issue, please refer to the following link:

         Why can't I create a homegroup?


    2.    About your Media Center issue, please capture some related screenshots for further research. You can Upload to SkyDrive.


    Meanwhile, as a workaround, you could try to reset the Windows Media Center to check the result:


    1)   Open Control Panel/Programs and Features.

    2)   Click "Turn Windows features on or off" in the left pane.

    3)   Uncheck "Media Features". Click "Yes" to continue, and click OK to quit. Then Restart.

    4)   Open "Turn Windows features on or off" again. Turn on the features "Media Features". Restart.

    5)   Launch Windows Media Player, initialize the program.


    3.    What are your remote configurations? And what is the error message when you failed to connect this computer?

    For references, please check the following links:

    Configure Remote Desktop Access on Windows 7 Systems


    Remote Desktop Connection: frequently asked questions


    Hope it helps.


    Alex Zhao

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, March 09, 2011 9:59 AM
  • Hi,

    I've got the same problem as NAT2347234.

    I just installed Service Pack 1 for Windows 7 Enterprise 64bit and now if I open the network and sharing center the option to join or leave the homegroup is gone. The "turn on media streaming" button doesn't seem to do any changes, it seems to be effectless. My XBox and all other media players in my network don't find the media center pc anymore.

    All required services are running, the network profile is set to "Home network", IPv6 is enabled for all network controllers, the firewall is configured correctly or alternatively turned off and I uninstalled and reinstalled the "Media Features", successless...

    I figured out that these RDP-Settings also are gone after the installation of Service Pack 1:

    • Select Allow Connections From Computers Running Any Version Of Remote Desktop to allow connections from any version of Windows.
    • Select Allow Connections Only From Computers Running Remote Desktop With Network Level Authentication to allow connections only from Windows 7 or later computers (and computers with secure network authentication).

    Hopefully it does not affect the homegroup abilities.

    So for now I'm just heading to remove Service Pack 1 again. Should I wait for Service Pack 2? Hopefully not!

    I can't imagine that I'm the one and only user who is facing these kind of issues after Service Pack 1 is installed. I'm sure that microsoft well know about this issue but I still couldn't find any solution using google, bing or whatever.

    So please don't let us guess around and offer a solution to fix that issue. If you need further system information, please let me know.

    Thanks a lot...



    Wednesday, March 16, 2011 11:06 PM
  • any ideas?
    Saturday, March 19, 2011 8:02 PM
  • No you are not allone. Around me it is the same situation on about 20% of all users, which have installed SP1 on Windows Seven.

    1. RDP host (Remote Desktop) is  not possible to turn ON (is not working and there are no "buttons" to activate it on "remote setting" tabs nor in any other gui/msc screens/tabs). RDP client is working OK.

    2. Home Group is not able to turn ON (when you trun it on, nothing happends).

    3. Windows mobile devices are unable to synchronize thru USB cable. When you connect USB cable to them, it looks like everything is going OK, for shor time (about 0,2 to 2 seconds) you can see connected device in Sync Center, but than the device returns to inactive/disconnected state (gray icon). You can synchronize windows mobile trhu BlueTooth with no problem.

    4. In Windows Media Center is no more TV submenu in menu, so TV cards are not working. And in setup of MCE you don't have any TV card/programs setting available.

    5. Windows Media Streaming is not working, when you try to turn it on, nothing happends (perhaps some error message appears, i am not sure about that message now).

    Those all problems appears at once on about 20% of windows seven (profesional/profesional N/ultimate/ultimate N/home profesional) afther installing SP1.

    I am not sure, if MS is solving there anything, but only one sollution is able on those computers, and that is UNINSTALL SP1 and everything returns to normal.


    Thursday, April 07, 2011 1:31 PM
  • Same issue here but I used a SP1 disc to load so I cannot reverse.

    I was testing Win7 but if this most important part of the OS is not working no one has solution this is not good.

    Maybe 7 is not as good as they say. Sucks now I have to use windows xp on a core i7 2600K machine cause of silly flaws in new OS.

    Caven Barrett
    Tuesday, April 12, 2011 11:52 PM
  • Hi again, I've still not found any solution and still not got any helping response from microsoft ;( In addition to the things I wrote already, I've got the same problem as Bilka wrote in point 4. Windows Media Center does not offer the TV submenu anymore.
    Sunday, April 17, 2011 4:20 PM
  • I have the exact same problems with Win7 Ultimate 64-bit, after installing SP1 from disc (not done by windows auto update). I can do a system recover and it will all work up until I reboot again then it breaks. There's an obvious problem here. I'm guessing it happens more than Microsoft or other many people probably don't realize these features are broken.
    Sunday, April 17, 2011 6:12 PM
  • Same issue here with the SP1 installed. Not able to access the HomeGroup.

    I have uninstalled SP1, and TaDa! my HomeGroup is back like nothing ever happened. So I left the HomeGroup hoping to install SP1 and be able to create a new one, but no chance.

    It's so sad that since SP1 came out MS is not able to offer a solution to millions o people.

    Tuesday, May 17, 2011 11:01 PM
  • Hi Microsoft,

    is there a solution in sight?

    This problem still occurs and I couldn't find any solution yet.


    Wednesday, May 09, 2012 3:10 PM
  • Same problem here. I have tried to set up a homegroup between two computers: one with windows 7 home premium x86 SP1 (works well), and one with win7 enterprise 64 bit SP1. On the 64 bit system i am still getting the described problem: homegroup is not ready yet. Annoying as hell, and there is no working solutions for months.

    Go on Microsoft, that's not why I paid.

    Tuesday, November 13, 2012 12:28 PM