none
PowerShell ISE is not working. It opens with a blank white window on top of a black background. RRS feed

  • Question

  • Powershell ISE is not working on my Windows 10 laptop, not sure when this happened but i just updated to Version 1903. Does anyone know how to fix this problem. If i float my mouse where the menus would be a menu will drop down. I tried to open the Options menu it also shows blank, none of the options are visible, has anyone had this problem? I saw one post in another forum but there was no solution. It was suggested he try using Visual Studio Code, I would rather continue using ISE.

    thanks

    B

    Thursday, August 22, 2019 10:18 PM

All replies

  • Hi,

    Thanks for your question.

    Please try to run the commands below to repair your system.

    • sfc /scannow
    • DISM.exe /Online /Cleanup-image /Restorehealth

    Best regards,

    Lee


    Just do it.

    Friday, August 23, 2019 2:42 AM
  • I ran the sfc /scannow it did find errors. I ran DISM.exe it ran for hours, didn't seem to be doing anything, so after 4 hours i broke out of it. I reverted to the previous Windows version, 1803. PowerShell ISE is working again. I've paused updates for a month maybe a fix will come along.

    thanks

    B

    Friday, August 23, 2019 9:32 PM
  • Hi,

    Thanks for your response.

    I am glad that you have solved the problem temporarily.

    If I get information about the fix, I will come back to update this post.

    Good luck to you!

    Lee


    Just do it.

    Tuesday, August 27, 2019 7:23 AM
  • Any Errors or Warnings in the  Event Viewer (Application and System) after you upgraded Windows 10 to 1903.

    This could provide the clues to the next steps. 

    You can also Try below:

    Can you Press Windows Key + R 

    Type: Optionalfeatures.exe

    Press Enter

    Scroll through the Window and find Windows Powershell 2.0. 

    Uncheck the Powershell Feature

    Click on OK and then restart the Windows 10 PC.

    Follow the Same Steps to Enable the Feature Again and Test the Powershell.



    Tuesday, August 27, 2019 10:27 AM
  • After rolling back it seems there were other problems that i didn't know were caused by this update. I have use SnagIt a screen capture tool. It was not behaving normally, i thought i was going to have to purchase an update for it. I also use TeamViewer for remote administration, it was not working properly either. Both problems seemed related to a graphics driver problem. That could also be the cause with PowerShell ISE not working.

    I have a Lenovo ThinkPad T460, which i purchased with Windows 10 about two years ago. I update Windows regularly, this is the first update that cause me grief. I will try to find a way to post concerns about Windows 10 version 1903 on a Lenovo T460.

    B

    Tuesday, August 27, 2019 4:22 PM
  • Thank you Jatin for these suggestions.

    I now think my ThinkPad T460 may need a Graphics driver update for it work properly with Windows 10 version 1903.

    B


    Tuesday, August 27, 2019 4:25 PM
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Lee


    Just do it.

    Friday, September 6, 2019 11:55 AM
  • No. I have not tried the 1903 update again, I've paused updates until the end of September. I did update my Lenovo T460 laptop to the latest graphics driver. There are 2 bios update available but i haven't install them. I will update this tread if i can resolve this issue. I will have to apply this update at some point.

    B

    Friday, September 6, 2019 3:38 PM