Windows 7 update fails with error 8000FFFF


  • I've got a Windows 7 x64 installation that I've had for around three months.  Everything has been fine and working up until a few weeks ago.  When I run Windows Update it finds updates and allows me to select them, but when I run the install it fails with error 8000FFFF.  Update used to work, but then suddenly quit.

    I've dug through tons of forum and web sites regarding this specific error, but they all of their solutions do nothing to fix my problem.  In frustration I decided to put in a spare hard drive and install Windows 7 from scratch.  I did that and the first thing I tried to do after logging in was updates and it failed for the same reason (8000FFF).

    I have the same situation with a Windows Storage Server 2008 x64 that I have as well.  It has been runing for about six months or more and updates were working fine.  Then update started failing for the same or some other reason about the same time.  On this machine I can start the update and see it report a percentage downloading the update.  It gets to about 5 or 6 percent and then fails.

    Is there some possible networking issue at play in my situation?  I have earlier Windows versions (XP, XP64, Svr 2003 and Svr 2003 R2) and updates work fine on those.  I know those are using a different mechanism, but I do not notice any other kind of networking issues from my house to the Internet.  I have not changed anything or any settings in my firewall at all.  Is there some specific protocol, port or something that has to work prefectly in order for the new Windows update to work? 

    All of my machines are pretty much Intel based.  Win7 box is a Core2Duo on an EVGA 680i motherboard.  The servers are Intel Xeons with Intel motherboards, chipsets and nics.

    Thanks for any advice and help

    Wednesday, April 14, 2010 1:55 AM


  • Which updates cannot be installed? You may open Control Panel\All Control Panel Items\Windows Update\View update history to see the result and let us know. 
    Arthur Xie - MSFT
    Friday, April 16, 2010 7:14 AM

All replies

  • You may check if the updates were installed before. If so, remove it and then reinstall.

    Remove an update

    If it does not help, please temporary disable antivirus and firewall, then install the updates again.

    If the issue persists, please try the following method.

    1. Launch REGEDIT

    2. Locate to


    3. Check if these three values exist under the COMPONENTS key:


    If the keys exist, back up the Components key, then delete the three above values.

    4. Restart.

    Arthur Xie - MSFT
    Wednesday, April 14, 2010 7:57 AM
  • Thanks for the responses guys, but I tried that solution when I first started researching this problem.  I don't have any of those keys in my registry.

    I'm beginning to think this is also the same problem that is preventing me from installing the .NET 4 framework.  I see in the log log where it tries to install a component using the windows update agent and it fails with the same (generic catastrophic unknown) error 8000FFFF.

    Antivirus was turned off and the Windows firewall was disabled and still no joy.

    Thanks again

    Thursday, April 15, 2010 11:01 PM
  • Which updates cannot be installed? You may open Control Panel\All Control Panel Items\Windows Update\View update history to see the result and let us know. 
    Arthur Xie - MSFT
    Friday, April 16, 2010 7:14 AM
  • Hello, I am having exactly the same issue.  I have not had an issue with updates before on this install, and have installed numerous updates previously.

    However it is the most recent two updates which are failing, these being KB980408 & KB975496, published 27/04/10.

    The issue seems to be that it is not actually downloading the files at all.  Clicking install brings up the downloading screen, and it instantly pops to 11% and then hangs, eventually (after a few minutes) it brings up a failed screen.

    Attempting to install individually or together brings up error 8000FFFF.

    The above values you suggest do not exist in my registry, I also tried renaming the softwaredistribution folder, and although this reset windows update, the problem was still the same.

    UPDATE: I just attempted to manually install KB980408, and it takes a while before finally simply stating "the following updates were not installed".
    Wednesday, May 05, 2010 10:22 PM
  • Hi, I am getting the same error as well. Ever security update starts to download gets to 11% and hangs. Then errors out with the 8000FFFF error. All updates have failed since 6/7/2010.
    Monday, July 12, 2010 3:22 PM
  • Wow, suddenly I have the same bizarre error at 11% of downloading, then error #8000FFFF.
    Fix IT, registry keys and SoftwareDistribution folder cleaning, uninstalling previous updates, manual downloading of appropriate updates and attempt do install it and creating/deleting user profiles - don't work at all.
    Any new ideas?

    Win7 x64 SP1

    Package KB2633873 failed to be changed to the Installed state.
    Status: 0x8e5e0408.Windows update "Security Update for Windows (KB2633873)" could not be installed because of error 2388526088 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\Wiewior\Downloads\Windows6.1-KB2633873-x64.msu"        ")

    Package KB2645640 failed to be changed to the Installed state. Status: 0x8e5e0408.
    Windows update "Security Update for Windows (KB2645640)" could not be installed because of error 2388526088 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\Wiewior\Downloads\Windows6.1-KB2645640-x64.msu"        ")

    • Edited by Wiewior Monday, March 05, 2012 10:27 AM details update
    Monday, February 27, 2012 4:00 PM
  • Suddenly the whole HKLM/COMPONENTS hive is missing. I load the components file manualy into the registry (keys looks fine) but after restart it's not there. How do I attach a hive permanently to the registry? O_o
    Monday, March 05, 2012 10:40 AM
  • I gave up.
    Reinstalling windows solved the problem but it should not be a permanent solution to all the problems without fix.

    BTW Who was so dumb to label a question in this thread as an answer?

    • Edited by Wiewior Wednesday, March 07, 2012 8:33 AM
    Wednesday, March 07, 2012 8:28 AM
  • It is very odd that there are so many having exactly the same problem. Me thinks this is some issue that Microsoft has created, maybe with a previous update or perhaps a common, specific registry cleaning installed software. My Windows 7 64-bit Ultimate developed the same problem about 2 or 3 months ago. I have been pulling my hair out searching for a solution but no joy. Windows own Update FixIt did not fix it. I have tried every potential solution that I can find but I still get exactly the same results as previously described -- update downloads fail at 11% and every manual update download fails to install with the same 8000FFFF error. Someone has got to have the solution!!
    Sunday, March 02, 2014 12:39 PM
  • So Lame. So what do you recommend when those keys don't exist?
    Thursday, April 09, 2015 10:15 PM
  • Any recent findings to this solution?
    Sunday, July 12, 2015 2:03 AM