none
dcdiag error

    Question

  • Hi

    when I run dcdiag I get this log

    Line 219:          ......................... ALADIN failed test ObjectsReplicated
     Line 234:          ......................... ALADIN failed test frsevent
     Line 275:          [Replications Check,PLUTO] A recent replication attempt failed:
     Line 283:          [Replications Check,PLUTO] A recent replication attempt failed:
     Line 291:          [Replications Check,PLUTO] A recent replication attempt failed:
     Line 299:          [Replications Check,PLUTO] A recent replication attempt failed:
     Line 307:          [Replications Check,PLUTO] A recent replication attempt failed:
     Line 457: consistently failed.
     Line 982:          ......................... PLUTO failed test kccevent
     Line 1056:          ......................... PLUTO failed test systemlog
     Line 1199:          ......................... POOH failed test ObjectsReplicated
     Line 1240:          ......................... POOH failed test systemlog

    can sam one help me please

    thanks 

    • Moved by Tim QuanModerator Monday, August 8, 2011 6:34 AM (From:Network Infrastructure Servers)
    Thursday, August 4, 2011 7:48 AM

Answers

  • Hi,

     

    Please reset the DNS configuration as suggested by Mr X at first.

     

    With the information you had uploaded, I find some errors and there is some reference to troubleshooting:

     

    1.    Fatal Error:DsGetDcName (PLUTO) call failed, error 1722

     

    It seems that there is DNS related issue. The RPC server is unavailable.

     

    To troubleshooting this issue, please refer to the following link:

     

    Troubleshooting RPC Endpoint Mapper errors

    http://support.microsoft.com/kb/839880

     

    2.    An net use or LsaPolicy operation failed with error 1203, No network provider accepted the given network path..

     

    It seems that the netlogon share and also that more DCs in the domain exist can't connect to.

     

    check the status of the SYSVOL and NETLOGON shares. Also, please refer to:

            

    Troubleshooting missing SYSVOL and NETLOGON shares on Windows domain controllers

    http://support.microsoft.com/kb/257338/en-us

     


    hope this helps!

    Thursday, August 11, 2011 2:56 AM
    Moderator

All replies

  • Please post the output for repadmin \showrepl.

     

    Thank you


    MCTS...
    Thursday, August 4, 2011 8:43 AM
  •  

    repadmin running command /showrepl against server localhost

     

    Default-First-Site-Name\POOH

    DC Options: IS_GC

    Site Options: (none)

    DC object GUID: 8a5fd3ea-cab3-4d06-97ee-994105bbe7f7

    DC invocationID: f08949db-b57d-44fc-83b0-00881cb40273

     

    ==== INBOUND NEIGHBORS ======================================

     

    DC=gspaces,DC=com

        Default-First-Site-Name\ALADIN via RPC

            DC object GUID: 48211feb-9373-40eb-812d-dc970a7ab8b2

            Last attempt @ 2011-08-04 13:05:28 was successful.

     

    CN=Configuration,DC=gspaces,DC=com

        Default-First-Site-Name\ALADIN via RPC

            DC object GUID: 48211feb-9373-40eb-812d-dc970a7ab8b2

            Last attempt @ 2011-08-04 12:52:50 was successful.

     

    CN=Schema,CN=Configuration,DC=gspaces,DC=com

        Default-First-Site-Name\ALADIN via RPC

            DC object GUID: 48211feb-9373-40eb-812d-dc970a7ab8b2

            Last attempt @ 2011-08-04 12:47:19 was successful.

     

    DC=DomainDnsZones,DC=gspaces,DC=com

        Default-First-Site-Name\ALADIN via RPC

            DC object GUID: 48211feb-9373-40eb-812d-dc970a7ab8b2

            Last attempt @ 2011-08-04 13:03:43 was successful.

     

    DC=ForestDnsZones,DC=gspaces,DC=com

        Default-First-Site-Name\ALADIN via RPC

            DC object GUID: 48211feb-9373-40eb-812d-dc970a7ab8b2

            Last attempt @ 2011-08-04 12:47:19 was successful.

    Thanks.

    Thursday, August 4, 2011 10:08 AM
  • Hi,

    Check repadmin /replsummary localhost

    If you get any fails check in the eventvwr and then give us the error. Also please tell us about your domain/forest structure.

    Troubleshoot AD replication errors

    http://technet.microsoft.com/en-us/library/bb727057.aspx


    Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 4, 2011 12:29 PM
  • DC1=pooh
    C:\>repadmin /replsummary localhost
    Replication Summary Start Time: 2011-08-04 15:46:47
    Beginning data collection for replication summary, this may take awhile:

    Source DC           largest delta  fails/total  %%  error
     ALADIN                    17m:48s    0 /   5    0

    Destination DC    largest delta    fails/total  %%  error
     POOH                      17m:48s    0 /   5    0

    DC2=aladin
    C:\>repadmin /replsummary localhost
    Replication Summary Start Time: 2011-08-04 17:10:57
    Beginning data collection for replication summary, this may take awhile:

    Source DC           largest delta  fails/total  %%  error
     PLUTO                     22m:47s    0 /   5    0
     POOH                      11m:04s    0 /   5    0

    Destination DC    largest delta    fails/total  %%  error
     ALADIN                    22m:47s    0 /  10    0

    DC3=pluto
    C:\>repadmin /replsummary localhost
    Replication Summary Start Time: 2011-08-04 10:09:04
    Beginning data collection for replication summary, this may take awhile:

    Source DC           largest delta  fails/total  %%  error
     ALADIN            14d.04h:23m:51s    5 /   5  100  (2148074274) Can't retrieve message string -2146893022 ...

    Destination DC    largest delta    fails/total  %%  error
     PLUTO             14d.04h:23m:51s    5 /   5  100  (2148074274) Can't retrieve message string -2146893022 ...

    DC Pluto is in (USA) new-york but in the same domain

    Thnks for help.

    Thursday, August 4, 2011 2:22 PM
  • Hello,

    for a complete overview please upload the following files:

    ipconfig /all >c:\ipconfig.txt [from each DC/DNS Server]
    dcdiag /v /c /d /e /s:dcname >c:\dcdiag.txt
    repadmin /showrepl dc* /verbose /all /intersite >c:\repl.txt  ["dc* is a place holder for the starting name of the DCs if they all begin the same (if more then one DC exists)]
    dnslint /ad /s "DCipaddress" (http://support.microsoft.com/kb/321045)


    As the output will become large, DON'T post them into the thread, please use Windows Sky Drive (skydrive.live.com) [with open access!] and add the link from it here. Also the /e in dcdiag scans the complete forest, so better run it on COB.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Thursday, August 4, 2011 4:52 PM
  • https://skydrive.live.com/redir.aspx?cid=a9b84566cd413bd3&page=play&resid=A9B84566CD413BD3!112


    Hello,

    i have no access to the share. Please make sure to open it for public.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Sunday, August 7, 2011 8:43 AM
  • try now

    https://skydrive.live.com/redir.aspx?cid=a9b84566cd413bd3&page=play&resid=A9B84566CD413BD3!112

     

    Wednesday, August 10, 2011 7:43 AM
  • Hello,

    PLUTO is not multihomed but more then one NIC used with different ip's, not recommended on DCs. Please disable the unused NIC and run ipconfig /flushdns and ipconfig /registerdns and restart the netlogon service after also removing the public DNS servers.

    Additional you use the external DNS servers 64.105.124.154 and 64.105.159.250 on the NIC, they MUST be set as Forwarders in the DNS management console in the DNS server properties.

    On ALADAIN and POOH remove the internal DNS server from the Forwarders list 10.10.10.205. Then run also the above mentioned ipconfig commands and restart the netlogon service.

    Give time for replication and run the commands all again and upload the output files.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Wednesday, August 10, 2011 8:00 AM
  • Hello,

    for IP configuration:

    • Please disable the second NIC card of Pluto
    • Please set 64.105.124.154 and 64.105.159.250 as forwarders and not as secondary DNS servers
    • Make all DCs point to 10.10.10.205 as primary DNS server, 192.168.10.11 as secondary one and 192.168.10.15 as third one

    Once done, run ipconfig /registerdns and restart netlogon on each DC. That should make Pluto have the correct copy of your DNS zones and replicate it to others via AD replication.

    Also, please make sure that internal DNS servers are not set as forwarders.

    After proceeding like that, inform us the progress.

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator 

    Wednesday, August 10, 2011 8:51 AM
  • Hi,

     

    Please reset the DNS configuration as suggested by Mr X at first.

     

    With the information you had uploaded, I find some errors and there is some reference to troubleshooting:

     

    1.    Fatal Error:DsGetDcName (PLUTO) call failed, error 1722

     

    It seems that there is DNS related issue. The RPC server is unavailable.

     

    To troubleshooting this issue, please refer to the following link:

     

    Troubleshooting RPC Endpoint Mapper errors

    http://support.microsoft.com/kb/839880

     

    2.    An net use or LsaPolicy operation failed with error 1203, No network provider accepted the given network path..

     

    It seems that the netlogon share and also that more DCs in the domain exist can't connect to.

     

    check the status of the SYSVOL and NETLOGON shares. Also, please refer to:

            

    Troubleshooting missing SYSVOL and NETLOGON shares on Windows domain controllers

    http://support.microsoft.com/kb/257338/en-us

     


    hope this helps!

    Thursday, August 11, 2011 2:56 AM
    Moderator
  • Hi.

    Thanks for the help

    After all the revisions and change that we made- right now there is no error at all.

    Thanks a lot.


    • Edited by Idan_Simhon Tuesday, September 13, 2011 8:47 AM
    Thursday, August 18, 2011 9:43 AM