locked
Pop Under dialog boxes in Win 7 Ultimate? RRS feed

  • General discussion

  • I was wondering if anyone else was noticing problems with some advisory pop-up dialog boxes, such as ones asking for a language choice during an install, poping up behind another window?  If you do not notice the extra icon in the taskbar and probably flashing, you will not realize a user input is required.  I would not think it had been designed that way.  It doesn't always happen, but enough to be irritating.

    If you want to see the type of thing I am talking about,  open a System Window (winkey + Pause), choose Performance Information and Tools at the bottom left.  Then Advanced Tools and look at the top with the yellow warning that says "Performance can be improved ..." and click that.  A window opens but you won't know it unless you notice the task bar and see the flashing icon.
    Saturday, October 31, 2009 12:08 AM

All replies

  • I observed the same behavior when I followed your instructions. The last window in question does not contain the instruction to first appear on top of other windows.

    Saturday, October 31, 2009 8:37 AM
  • Hi,

    Thank you for reporting it.

    I did tests on our environments and confirm it. I will report it as a potential bug to our feedback team.

    Thanks. :D
    Monday, November 2, 2009 7:09 AM
  • I've noticed it since beta... hope there is a fix soon. Maybe a registry hack?
    Friday, November 13, 2009 4:06 AM
  • This is rather trivial in my opinion. There are more pressing issues. The feedback team will be notified.
    I just wish every time I empty my recycle bin it would change from empty to full without hitting refresh. Can someone please report this so I can stay sane.

    Friday, November 13, 2009 4:23 AM
  • I've had the same problem with a couple of programs and it's really annoying.
    Thursday, November 19, 2009 12:35 PM
  • Just so both sides are heard, as one who tends to do a LOT of multitasking, I simply *hate* it when an application pops itself to the top, in front of what I'm doing.

    Microsoft, please don't make it so everything pops to the top if it's not the current app.  There are those of us who *like* it when another application needing service doesn't interrupt what we're typing.

    -Noel
    Thursday, November 19, 2009 3:06 PM
  • I disagree! This is not trivial. We have printers that require password input in order to start printing. We got tons of user complaints that they couldn't print any more, simply because the users did not notice that the password dialog box had popped under the print dialog box. This needs fixing urgently!
    Wednesday, February 3, 2010 9:16 AM
  • Same - I see this happen all the time with Password dialogs or other dialogs on installation programs. Program seems hung to the user, but an alt-tab reveals a pop-up dialog waiting for user input that somehow lost focus/popped-under the current window.
    Friday, February 26, 2010 12:59 PM
  • Same - I see this happen all the time with Password dialogs or other dialogs on installation programs. Program seems hung to the user, but an alt-tab reveals a pop-up dialog waiting for user input that somehow lost focus/popped-under the current window.

    Hi Robinson

    This issue is a BIG productivity hurdle. None of the printer dialog boxes pop up and so one sits there wondering how long it is going to take to print and finally the realization comes that the dialog is waiting for input.  This is an urgent fix in my opinion.

    Tuesday, March 30, 2010 2:01 AM
  • This defect is reproducible as well when you configure an FTP connection in Windows Explorer and drag files with existing names to an FTP folder. The dialog that prompts if you wish to overwrite, pops under the progress dialog. This way it appears as if the copy action is in progress, while in fact it's waiting for the dialog that appeared under the progress dialog!

    It is extra anoying that with Windows 7, with the default Windows 7 taskbar, you can't set focus to the pop under window with a single click...

     

    A different issue I encountered was when I entered a wrong password for the FTP server the first time, I couldn't log on with that dialog anymore. Also, although the close button was available, it didn't do anything anymore after that. It wasn't possible to close the dialog...

    Wednesday, April 7, 2010 6:01 PM
  • Encountering same issue on multiple win7 ultimate installations. Win 7 dialog boxes do not pop to front. Affects various applications including Yahoo Instant Messenger. Printer dialog boxes don't come to front. However, I did find a possible fix or this issue:

    With the affected dialog box open, start Task Manager, select the affected application and then choose Options. In Options, make sure only the "Always On Top" item is checked. Windows Pop Under Dialog Boxes In Win 7 Solved.

    Friday, July 2, 2010 1:44 PM
  • Just so both sides are heard, as one who tends to do a LOT of multitasking, I simply *hate* it when an application pops itself to the top, in front of what I'm doing.

    Microsoft, please don't make it so everything pops to the top if it's not the current app.  There are those of us who *like* it when another application needing service doesn't interrupt what we're typing.

    -Noel

    How about a way to configure windows opening on top or behind similar to max min or normal - better to have new instances of IE in front :]
    Friday, July 2, 2010 11:13 PM
  • With the affected dialog box open, start Task Manager, select the affected application and then choose Options. In Options, make sure only the "Always On Top" item is checked. Windows Pop Under Dialog Boxes In Win 7 Solved.

    I'm still having an issue with printer password dialogs.  I applied the recommended settings in task manager, but the settings don't stick upon restarting.  Further I seem to have to open every conceivable program that I might print from and click "bring to front".  Still, after restarting, i have to manually reapply "bring to front," even though the "always on top" is still selected.

     

    This is a MAJOR hassle.  I have users whose programs (office) are freezing up if they don't get to the dialog box fast enough.   These are new machines, with fresh installs, and it's happening on 100% of my workstations. 

    Friday, July 16, 2010 5:08 PM
  • Hi.

    Have anyone come up with a good solution for this?

    The only suggestion I have so far is to set the taskbar button to never combine, to easier detect dialogs that pop up.

    I fear that we actually need to add code in our applications that change the user properties for the taskbar.

     

    -Knut

    Wednesday, August 4, 2010 6:35 AM
  • So it's been over 1 year since the initial report of this issue. We use Outlook for email at work and my meeting notices pop under if Outlook doesn't have focus. I have missed meetings because of this. Is there some sort of configuration setting to make windows pop up instead of under?
    Thursday, November 4, 2010 11:25 PM
  • Hi new here but would like to contribute.

    I have a similar problem, here is the scenario:

    Excel sheet containing hyperlinks to different types of documents, word excel pdf etc. for obvious reasons they are password protected. When hyperlink is opened some of these Password dialog boxes Pop-Up and some Pop-Under. Under is most annoying as original excel sheet can not be moved and dialog box does not appear in Taskbar. 

     

    Alt+tab or task manager has been my only savior opening on top does not work.
    Please bring us better solution.

    Friday, November 26, 2010 12:24 PM
  • This is a very annoying bug. Many times you will launch an application that asks you for some kind of confirmation, and you sit there staring at the screen like an idiot waiting for the progam to start, and getting aggravated, because you have no idea that the program has started. It is waiting for you to answer a question that you cannot see because it appears behind all the other windows. What kind of sense does this make? None!

    I hate to provide my design work for free, but how about if you at least don't pop it under windows right in the middle of the screen where it is most likely to be blocked? How about down in the lower right? The way it works now is the worst possible way.

     

    Please Microsoft, this isn't that difficult.

    Monday, March 21, 2011 5:25 AM
  • I say have Windows look at the Z-order, then open any new dialog just over the level of the parent window, but under any other applications that are higher in the Z-order.

    That way if the parent window is on top (or simply visible), the pop-up will be in front of it.  If the user is working on another task in front of the window creating the pop-up, it won't pop in front of his work - the flashing Taskbar button thing will be used in that case.  Best of both worlds.

    However, some app designers make the desktop the parent of the pop-up dialog, which may be the cause for what people are reporting here.  In that case the system should go find the process that started the pop-up and determine the child window it has at the highest Z-order position, and put the new dialog just in front of that.

    Windows is simply too old to follow simple rules.  It needs to better facilitate the use of our apps, which are the reason for the system's existence in the first place.  Sometimes Microsoft seems to forget that.

    -Noel

    Tuesday, March 22, 2011 2:35 PM
  • I completely agree. This is really taking us back a few steps... I just sat for over half an hour waiting for the windows live essentials 2011 update to finally finish downloading and then notices a small little box down below. Not flashing, nothing. I clicked on it and what's this? A continue button.. windows 7 home premium... I do home servicing of computers and notice that it happens ALOT... Come on microsoft...

    Saturday, March 26, 2011 3:30 AM
  • This thread was opened more than 19 months ago, and I continue to observe this problem in Windows 7 Professional.  This is not a FEATURE, it is a BUG.  Historically, a dialog box that requires user input to continue a process has always appeared on top.

    Why can't Microsoft fix this?

    Tuesday, May 3, 2011 6:09 PM
  • I'm annoyed that this bug still hasn't been addressed well over a year after being reported, it seems like such a simple issue to fix too.
    Tuesday, May 10, 2011 3:06 PM
  • This problem of "pop-unders" has existed for MANY versions of windows now, dating back to Win98 or even earlier in my experience. I think the bit of code causing this is thus very, very old and has just been inherited from one version of Windows to another all the way down through Windows 7.

     

    It's not new - it goes back probably as far as Windows. It's probably been complained about since the beginning also, never with any action taken on it.

    Wednesday, May 25, 2011 9:34 PM
  • I is a BUG in the Windows 7 32 bit system.   It does not happen in Windows 7 64 bit, windows xp, windows vista.  
    Thursday, May 26, 2011 5:24 PM
  • It is the same behaviour for both 32bit & 64bit systems, if it doesn't happen on your Windows 7 64bit system then you are a very lucky person or mistaken! The behaviour is by design from Microsoft.
    Sunday, May 29, 2011 2:06 AM
  • No, I have W 7 pro 64 bit and I have that problem, we use an engineering sofware it is almost working with dialog boxes on every design step. That bug makes the software useless !!

     

    Wednesday, September 7, 2011 10:43 AM
  • After having stuck with XP Pro long enough, I'm gradually buying and provisioning Windows 7-based machines, and I have seen this undesirable "hidden pop-under dialog box" issue on every Win7 box I've worked with. It is NOT the way Windows XP (or 2000, ME, 98, 95, 3.1, etc.) behaved, as I've seen some people claim. This thread is getting close to its two-year anniversary, and yet there have been no productive answers from MS that I've seen.

    While an advanced user can eventually figure out that there's a hidden window somewhere, awaiting input, it's confusing to normal users, and actually quite annoying even to the advanced user. Is this truly a "bug by design," Microsoft?


    • Edited by AZTopDavid Wednesday, September 7, 2011 2:16 PM
    Wednesday, September 7, 2011 2:16 PM
  • As a workaround I have changed the users foregroundlocktimeout key to zero.

    It is found under each users Hkey, i.e. HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundLockTimeOut.

    Having set this to Zero (0) the application screen requests now come to the foreground immediately.

    Log off/on to activate.

    There still may be circumstances that still hide windows but this change seens to help normal application use, i.e. one app calling another to open a file etc.

    Remember to backup your registry/system before editing.

     

     

     

    Tuesday, September 13, 2011 11:43 PM
  • As a workaround I have changed the users foregroundlocktimeout key to zero.


    TurnT, you are a life saver.   Thank you so much, it worked perfectly.    I looked at this setting my old XP box and it was indeed zero and on the Win 7 box was 30d40 hex.    


    In my experience ( just upgraded to Win 7 ) it was indeed new behavior.   I have the XP and Win 7 PC in my office and they behaved differently before the fix.

    Friday, October 7, 2011 7:36 PM
  • Do you understand what you lose by setting ForegroundLockTimeOut to 0?  Now you have the ability for applications to jump in front of you instantly while you're typing.  

    Personally, I hate it when something pops up with a confirmation, e.g., "Delete all files?" and because you're typing in another app your space bar unexpectedly causes the [OK] button to be pressed.

    http://technet.microsoft.com/en-us/library/cc957208.aspx

    Maybe a more appropriate setting would be something like 5000 (5 seconds) instead of the default of over 3 minutes?

    -Noel


    Friday, October 7, 2011 9:42 PM
  • Late to the conversation; anyway here's another two cents.  As a work around - you can try resizing the applicaiton before triggering the pop under window which may leave it visible and help with the issue going forward.  Alternatively sometimes the windows move off screen and are still not visible.  Since the popup windows usually have focus you can use alt+space to bring up the window menu, press m to move the window, use your keyboard cursor key to adjust it slightly, then move your mouse and the window will snap to your mouse cursor on screen.

    Wednesday, August 1, 2012 11:14 PM
  • I think the proper solution is twofold...

    First, make it so that you can set the default behavior for the pop-ups (or pop-unders).  Better yet would be to allow the setting to be specified for each program.  For example, you may want to be notified when outlook tells you you have an important meeting to attend... but you may not care so much if it asks for your password on the printer (this is an example... I didn't say it was realistic!)

    Second, create a type of window that pops up, on top of everything, but does NOT take focus!  This allows you to continue to work in the area that you want, without interruption, but still makes it obvious that you are about to be late to your meeting.

    From experience, I hate it when a pop-up pops up while I am typing something... and I hit enter at just the wrong moment and I never see the pop up!!!  This is caused by losing focus and the pop-up accepting the enter keystroke!

    As a programmer, I don't think it would be too difficult to implement both of these suggestions.  The first, setting a default behavior would simply be a setting in the one of the many thousands of system settings that are already there... and you could easily allow the user to add a registry entry for any program that does not use the default setting.... you don't even have to create a nice interface for the user.  Just check if there is a setting for the popup to determine if it should pop-up or pop-under (of course, you don't have to limit it to just two options... it could be a bit map to allow pop-up/pop-under, flash 83 times in the tool bar, show up in an alerts window, take control of the universe... you know... the list is limitless)

    The second would be a welcome design change in how pop-ups take control... They should not just pop up and take all keyboard input... But they need to be highly visible, possibly audible, but should be smart enough to realize that if I am busy typing while it is popping up... that the keystrokes are not intended to go to it!  Even if I am not typing for a few moments and decided to press enter just as the pop-up is popping up... the keystroke is probably not for the pop-up.  Likewise, if I am moving the mouse and just as I click on the screen, a pop-up pops up in the same spot... it was probably not intended for the pop-up!

    Your program, windows, really should be smarter!  Taking us backwards because some (not all) don't like to be notified of important things and having no thought of the consequence to your heavy handed design changes is just not acceptable.

    Another example: For years, you made us use this stupid Control-Alt-Delete (which is awkward with two hands, and very nearly impossible with one hand) to tell windows that I want to log-in... now, I have to hit Control-Alt-Delete Enter before I can enter my password!  Argh!  90% of the time I have to enter my long password twice, just to log in.... very aggravating... but not part of this thread... just an example of the stupid changes you force us into!

    Thursday, August 2, 2012 5:18 PM
  • What surprises me the most is that this issue was reported nearly 3 year ago, and you still do not have a fix!!!
    Thursday, August 2, 2012 5:21 PM
  • I have a user that has this issue and it's making us crazy. We have to click the foreground window to make the dialog box come to the front. Regrettably, this registry hack did not fix the problem. Any other suggestions? Thanks!
    Friday, August 3, 2012 2:10 PM
  • Look to whatever else the user might have installed that's affecting desktop operation, as well as updating the display drivers from the web site of the maker of his/her video card.

    Good luck.

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Friday, August 3, 2012 3:31 PM
  • Amazed this is still not fixed after two years. I get it in when opening Word documents that I share (and are often already open by someone else).

    The dialogue asking if I want to open a read-only version is completely hidden and it looks to me like nothing has happened (the Word shortcut icon I have pinned to the taskbar doesn't flash, so I have no clue).

    If I click again, thinking I didn't do it right the first time, even the second dialogue saying that a dialogue box is open and needs to be dealt with is hidden - this is very stupid and very frustrating !!

    Wednesday, August 22, 2012 9:55 AM
  • Has anyone found a stable, permanent solution for this issue?  Our CFO is having problems with Excel popping the Page Setup box under Excel itself, and even when he attempts to click on it and bring it to the front, it immediately pops back under the spreadsheet, making it impossible to manipulate.

    Geoffrey Schaller

    Monday, October 8, 2012 3:12 PM
  • Just for the excel issue:

    In my case (happening to multiple users) it is an Outlook add in that we cannot do without, and getting the programmers to recode is "pulling teeth" so......

    If Outlook is open, close it and click in the spreadsheet. Tada!

    Monday, October 15, 2012 6:58 PM
  • We've noted on our end that this behavior begins happening once the user does a "Save and Send" action from within Excel - before that, the issue doesn't seem to be occurring.  For now, we're going to avoid the Save & Send feature of Excel, and hopefully this will provide a clue for Microsoft to produce a fix for the issue.

    Geoffrey Schaller

    Friday, November 9, 2012 2:19 PM
  • This is not about unexpected dialog boxes popping-up while you're working... this is about trying to open a file and wondering why it's not opening because the stupid dialog box is hidden under other windows.  This has been annoying me for at least a decade now... with Word and Excel password-protected files.  We use a password-protected Excel file for our workgroup schedule... so dozens of users trying to look at this schedule file (maintained by the clerk) has to click around and try to find this dialog box every time.  This even happens with the Excel window already open & active on another spreadsheet.... the dialog goes underneath everything.  When you have many programs running and many screens, this is a major PITA.  Isn't there a way to prevent this dialog box in the first place, a registry setting... something?  Is there any other method for sharing a file using MS Office where one person modifies the file and the rest of the users just want to look at the file without getting all these annoying pop-unders?  Sometimes these dialog boxes will lock-up many attempts to start a file and then the user discovers multiple instances of the dialog box.  It's even more fun with the Security Warning dialog about macros at the same time.
    Tuesday, December 18, 2012 6:10 PM
  • For the Outlook issue, here is what I've found so far:

    I've seen this for months now and while I don't have an absolute definitive answer, here is what I've found.

    Here are the links to the Microsoft Blogs that explain the isse:

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/04/26/hidden-dialogs-cause-excel-2010-to-appear-to-hang.aspx

    http://blogs.msdn.com/b/dhruvkh/archive/2012/05/14/outlook-ribbon-woes-on-performing-send-as-e-mail-via-other-office-2010-apps.aspx

    Link Summary...one of your Outlook Addins uses Ribbon Designer to modify the ribbon.  Microsoft is now recommending using Ribbon XML instead.  

    I have found that using the Save and Send feature in Excel seems to trigger the problem on the second use of it.  We have also found that if you hit ESC, you can at least get control of your workbook back.

    I've resorted to, at the moment, creating a shortcut that starts Outlook in Safe Mode.  This seems to solve the problem most of the time.  If you are interested, here is the path you can use to create the shortcut:  

    "C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE" /safe

    Another thing that has worked for one of my users is to NOT maximize the Excel windows and to Cascade them.  This seems to allow for access to the dialog boxes.  So far, it has only worked for one of my users and the others promise they will try it.

    One other thing that has helped others who have a similar issue is to change a registry setting that helps with window focus:

     HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundLockTimeOut 

    change this to 0 and log off/log in to activate it.


    Thursday, January 24, 2013 4:50 PM
  • Hi folks,

    I managed to fix this today. This issue appears to occur primarily for those users who have a dual screen setup. Our dual screen users use an NVidia dual screen gfx card and I had to do the following -

    Right click on the desktop > nView Properties > Enable > Windows > Dialog box repositioning > From the drop down select Move to cursor display > Apply > OK

    If excel is already open you need to close down all instances of it and wait 30 seconds. Go back into excel and do a few tests and you should find that the dialog now appears on top of the excel window instead of behind it.


    Jeet S

    Tuesday, October 15, 2013 11:43 AM
  • That's a decent workaround, but I can't help but wonder if you have the display driver repositioning dialog boxes (and coincidentally popping them to the top) whether you lose something.

    Note that there's a registry entry that governs how Windows handles "foreground lock" activity.  It's set to what seems like a bogus value right out of the box.

    [HKEY_CURRENT_USER \ Control Panel \ Desktop]
    ForegroundLockTimeout 

        

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Tuesday, October 15, 2013 6:22 PM
  • I had this issue after our office deployed Windows 7 machines.  With your note about dual monitors (we run dual monitors here) I looked into it.  We run Intel graphics on our laptops so it's not just an nVidia driver issue.  What I found is that my system was setup with monitor 2 as primary and 1 as secondary.  A software side swap and then physically swapping my monitors on my desk and dialogue boxes and new windows now display correctly.  Thank you for pointing me in the right direction.
    Friday, January 31, 2014 9:17 PM
  • Interesting concept, NorCalAngler!

    With Windows 8.1 I noticed occasional "pop-behind" type activity vs. when I used Windows 7.

    At first bootup I found Windows 8.1 enumerated the connectors on the back of my video card differently than Windows 7 did, putting the MiniDP before the DVI.  The end result was that my monitors were swapped, and at that time I just swapped them back via the ATI Catalyst Control Center and didn't think more about it.

    Just now I've just unswapped them in software and swapped them physically.  I'll keep an eye open for more "pop-behind" windows to show up (or hopefully NOT show up).

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Saturday, February 1, 2014 5:02 AM
  • FYI, made no difference.  One of the first copies I did that would overwrite a file caused the File Explorer dialog to pop behind the drop target File Explorer window.  It flashed a Taskbar button yellow to let me know it was there, but it would still be better if it would pop in front.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Saturday, February 1, 2014 12:13 PM
  • Since the popup windows usually have focus you can use alt+space to bring up the window menu...

    Alt+space worked nicely for me.  My choices were move and close.  The close option closed the pop under and restored focus to the application.  Thanks!
    Wednesday, March 5, 2014 5:54 PM
  • That's fine if you notice that it happened.

    Trouble is, a scenario like this:  You drag some files to copy them.  A window pops (behind) asking if you want to overwrite a file, and you don't notice it did that (maybe you miss looking at the Taskbar).  Instead you think the file(s) just copied successfully (because a successful copy operation doesn't pop anything up), and do other things that depend on the copy having succeeded.

    How friggin' hard can it be to be sure the window with keyboard focus is visible?

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Wednesday, March 5, 2014 8:33 PM
  • We are experiencing a very similar issue.  

    We have a user that has an Excel sheet with hyperlinks to Word documents in the same document library.  When you click on the link in the Excel sheet, the mouse cursor turns into an hour glass (forever, and ever).  We found in task manager that a Word dialog box had popped up BEHIND the spreadsheet, and you cannot ALT-Tab to it.  I had to "Switch To" in task manager to answer the question.

    One other clue is that hyperlinks from this sheet that go to an separate Excel workbook work just fine.  PDFs work properly, also.  It's only when we try to open a Word document that we have issues.

    HOWEVER if there is an instance of Word already open on the computer, the links work perfectly.

    So the average user will not know how to find that this is a problem, and it took us a while to figure it out, too.

    Help us out Microsoft!  Win7 has been out for a while, now.

    Thursday, March 20, 2014 5:38 PM
  • Geoff,

    I am having this exact same problem. What is going on!?! I can't work like this anymore!

    Is there a solution to this?

    Thanks!

    Monday, May 19, 2014 7:16 PM
  • I found a workaround for this issue that brings the popped under dialog box to the front if Alt-Space only gives the Move and Close options:

    - When the dialog box is at the back (ie the Excel document appears locked out) hover over Excel in the taskbar.

    - Right click the preview of the spreadsheet that won't close and the dialog box should come to the front.

    I noticed the issue only occurs when saving and sending an Excel document that's not pre-existing ie Book1.xlsx

    Tuesday, January 20, 2015 1:00 AM
  • What is just as annoying as this pop under alert issue is the fact that this post is heading toward being 6 years old and the issue is still persistent. Regardless that someone here said they was going to report it but apparently the feedback team is either not passing it along to someone that can actually do something about it, or they did and Microsoft was not smart enough to be able to fix it. Regardless it is one of the most annoying problems I face every day. Anyone that wants to call this problem trivial is obviously someone that does not spend more than a few hours a week on their computer. For those of us unfortunate enough to have to trudge through working with this inferior OS day after day it is more than just an annoyance!
    Wednesday, March 25, 2015 2:27 AM