none
How I can disable Credential Guard? RRS feed

  • Question

  • Reason is simple. I CAN'T RUN VMWARE VIRTUAL MACHINES!!

    Yeah. so, I tried to disable, but I could not find 'Device Guard' folder.

    Is it hidden? or can't I just see it? Where is it??

    well..

    Friday, February 2, 2018 1:50 PM

Answers

  • So I'm just going to add this as I experienced the same problem.  I'm running Win 10 Pro on a personal machine. I'd been using VMware Workstation Player 14 (which is still free for personal use) to learn about virtual machines.

    Then I wanted to look at  MS Hyper-V. Hyper-V can be installed/turned-on quite simply, but unfortunately, doing so, turns on both Device Guard and Credential Guard which kills the ability to run VMware with the message cited by the OP. It wasn't apparent to me that was going to happen.

    The instructions provided by the VMware warning link, detail running the group policy editor and locating Device Guard. When doing so, neither Device Guard or Credential Guard are configured. Configuring them as Disabled does not solve the problem. The additional instructions provided by VMware include going to "Turn Windows Features on and Off". After de-selecting the Hyper-V feature (which takes awhile), and rebooting, VMware will once again run. I did not need to execute the boot manager DOS commands outlined int he VMware KB article.

    Friday, March 30, 2018 6:32 AM

All replies

  • Are you referring to Credential Guard or Device Guard?

    What is the error message in VMware?

    Device Guard is a feature enable by IT Administrator and you should check with them.

    Take a look at:

    https://docs.microsoft.com/en-us/windows/access-protection/credential-guard/credential-guard

    Friday, February 2, 2018 2:31 PM
  •  Credential Guard uses hardware virtualization so it will certainly interfere with VMWare (or any other virtualization software). Are you running Windows 10 Enterprise?


    Bill

    Saturday, February 3, 2018 1:26 AM
  • The error message is:

    VMware Workstation and Device/Credential Guard are not compatible. VMware Workstation can be run after disabling Device/Credential Guard. Please visit http://www.vmware.com/go/turnoff_CG_DG for more details.

    I visited and I was going to follow the steps, but I couldn't find that Device Guard folder.

    P.S: sorry but I was mistaken and what I have to disable might be Device Guard. lul 7u7

    Saturday, February 3, 2018 3:10 AM
  • No, my OS is Windows 10 Pro.
    Saturday, February 3, 2018 3:11 AM
  •   If you have Windows 10 Pro, it does not have Credential Guard.

      Is this you personal machine or a company owned machine? Device Guard is not normally enabled, and you probably can't disable it if it has been set by your employer (as noted it the first reply in this thread).

     If it is your personal machine, why is device guard enabled? It is not enabled by default. Somebody must have set it up. It has to be set using group policy, and you will have to use group policy to disable it.

    https://www.tenforums.com/tutorials/68913-enable-disable-device-guard-windows-10-a.html

     


    Bill

    Saturday, February 3, 2018 6:21 AM
  • So I'm just going to add this as I experienced the same problem.  I'm running Win 10 Pro on a personal machine. I'd been using VMware Workstation Player 14 (which is still free for personal use) to learn about virtual machines.

    Then I wanted to look at  MS Hyper-V. Hyper-V can be installed/turned-on quite simply, but unfortunately, doing so, turns on both Device Guard and Credential Guard which kills the ability to run VMware with the message cited by the OP. It wasn't apparent to me that was going to happen.

    The instructions provided by the VMware warning link, detail running the group policy editor and locating Device Guard. When doing so, neither Device Guard or Credential Guard are configured. Configuring them as Disabled does not solve the problem. The additional instructions provided by VMware include going to "Turn Windows Features on and Off". After de-selecting the Hyper-V feature (which takes awhile), and rebooting, VMware will once again run. I did not need to execute the boot manager DOS commands outlined int he VMware KB article.

    Friday, March 30, 2018 6:32 AM
  •    Partly right. Hyper-V will certainly prevent you from running VMWare, but it does not install Device Guard or Credential Guard. What it does do is prevent access to hardware virtualization because the Hyper-V hypervisor is using it. This is not just a guess, it have been shown over and over again. You can in fact run VMWare or VirtualBox with Hyper-V installed if you prevent the hypervisor from loading. You can do this from BCDEdit, setting hypervisorlaunchtype to off.

      My guess is that the VMWare message is misleading and incomplete. There are lots of other things which can cause this, including some AV software. There has been quite a lot of discussion of this problem in the VirtualBox forums.


    Bill

    • Proposed as answer by Upland Chris Wednesday, March 20, 2019 7:15 PM
    Friday, March 30, 2018 11:52 PM
  • Hi,

    I followed vmware instructions but i'm still receiving the error message about device guard. 


    Carlos L. Guadalupe

    Friday, April 6, 2018 10:22 PM
  •   That is because the VMWare instructions are misleading. Did you read the post above yours?

      The real problem is that something is locking hardware virtualization (VT-x or AMD-V). Device guard, credential guard and Hyper-V are possible culprits, but there are plenty of others.  

      


    Bill


    • Edited by Bill Grant Sunday, April 8, 2018 4:51 AM
    Saturday, April 7, 2018 11:49 PM
  • I have Fixed this problem.

    Registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

    Enabled = 0

    Reboot the machine

    • Proposed as answer by Besnik Belegu Friday, August 24, 2018 7:12 PM
    Sunday, May 27, 2018 1:10 AM
  • Thank you for this simple fix provided by Ulises2k which solved my problem.  The versions of the OS and VMware Workstations were as shown:

    OS version was: Microsoft Windows 10 Pro, Version 10.0.17134 Build 17134

    VMware Workstation version was: VMware® Workstation 14 Pro (14.1.2 build-8497320)

    I had to perform the following three steps to fix the issue:

    1) Apply this registry modification provided by Ulises2k

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

    Enabled = 0


    2) Run the following command from an elevated command prompt:

    bcdedit /set hypervisorlaunchtype off 

    (Just a side note: if you want to reverse the above command back to its original state, from elevated command type: bcdedit /set hypervisorlaunchtype auto)

    3) Reboot the PC and that should resolve your issue.




    • Edited by xpievio Thursday, June 7, 2018 1:39 AM
    • Proposed as answer by bluebossa Saturday, August 25, 2018 5:16 PM
    Thursday, June 7, 2018 1:36 AM
  • Thanks so much for posting that xpievio and Ulises2k.

    Your solutions worked perfectly.

    This had been doing my head in for weeks with no workable results and I needed a fix for a course I'm doing.

    Friday, July 6, 2018 10:18 AM
  • This is what worked for me! Thank you.
    Friday, August 17, 2018 1:41 PM
  • Thank you for this, tried several things that were waste of time on VMware and MS this simple switch should have been on MS and VMware site.
    Thursday, September 13, 2018 5:20 AM
  • The additional instructions provided by VMware include going to "Turn Windows Features on and Off". After de-selecting the Hyper-V feature (which takes awhile), and rebooting, VMware will once again run. I did not need to execute the boot manager DOS commands outlined int he VMware KB article.

    De-selecting Hyper-V under "Turn Windows Features on and off" resolved my issue.

    Windows 10 Enterprise - Version 1709 / VMware Workstation Pro 15

    Thursday, December 20, 2018 4:09 AM
  • save this first lines inside in notepad as .reg file and import it to regedit and reboot your computer now is Isolation Memory Integrity disable as you want

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity]
    "Enabled"=dword:00000000

    Enabled DWORD
    0 = Off
    1 = On




    Wednesday, January 2, 2019 4:36 PM
  • Same problem here
    Sunday, February 10, 2019 7:36 AM
  • I used this. along with gpedit.

    https://www.microsoft.com/en-us/download/details.aspx?id=53337

    This will lead you to a 

    Device Guard and Credential Guard hardware readiness tool

    I had the same problems when I decided to use VmWare instead of Hyper-V.

    also used this:

    bcdedit /set hypervisorlaunchtype off


    • Edited by rocketjetz Tuesday, May 21, 2019 10:23 PM
    Tuesday, February 12, 2019 11:56 PM
  • You are right on the money with this answer.  I was expecting VMWare not to work since i was already using Hyper-V, but the error message was misleading.  I'd experienced that in the past, but this was a newer machine.  Disabled Hyper-V using BCDEdit, rebooted, and i'm good to go.  Presumably i'll renable Hyper-V when i want to use those VMs.
    Wednesday, March 20, 2019 7:17 PM
  • tqvm .. it's work
    Tuesday, April 2, 2019 7:50 AM
  • What if I don't have that path? In DeviceGuard  I have only 4 files, not a scenario folder:

    1. (Default)

    2. EnableVirtualizationBasedSecurity

    3. RequireMicrosoftSignedBootChain

    4. RequirePlatformSecurityFeatures

    Tuesday, April 16, 2019 6:30 AM
  • right click on DeviceGuard key and select New Key name it Scenarios.

    Then right click on Scenarios Key and select New DWORD32 and name it HypervisorEnforcedCode Integrity .

    Set it 0 for enabled.

    Then run from an elevated command prompt:

    Bcdedit  /set hypervisorlaunchtype off 

    then restart your pc...


    • Edited by rocketjetz Sunday, May 26, 2019 6:49 PM
    • Proposed as answer by Twoleeland Monday, June 24, 2019 3:59 PM
    Tuesday, May 21, 2019 10:21 PM
  • BAZINGA! This worked
    Friday, May 24, 2019 2:12 AM
  • Excelente , muchas gracias, yo tenia el mismo problema y lo solucione asi....mil gracias

    Monday, June 17, 2019 3:42 AM
  • Thank you for this simple fix provided by Ulises2k which solved my problem.  The versions of the OS and VMware Workstations were as shown:

    OS version was: Microsoft Windows 10 Pro, Version 10.0.17134 Build 17134

    VMware Workstation version was: VMware® Workstation 14 Pro (14.1.2 build-8497320)

    I had to perform the following three steps to fix the issue:

    1) Apply this registry modification provided by Ulises2k

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

    Enabled = 0


    2) Run the following command from an elevated command prompt:

    bcdedit /set hypervisorlaunchtype off 

    (Just a side note: if you want to reverse the above command back to its original state, from elevated command type: bcdedit /set hypervisorlaunchtype auto)

    3) Reboot the PC and that should resolve your issue.




    Thanks!
    Friday, June 21, 2019 4:56 PM
  • thanks! Worked for me
    Friday, September 6, 2019 5:27 PM
  • Thanks
    Wednesday, September 11, 2019 1:06 PM
  • This is exactly what I needed. Thank you!

    Monday, November 4, 2019 3:04 AM
  • It's worked for me. After enable/disable Hyper-V, my PC can't use vmware.

    Thanks.

    Friday, November 15, 2019 8:25 AM
  • This solution worked !!! thank you. 

    Please note I had to disable  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard to get it working on windows 10. 

    Wednesday, November 27, 2019 12:49 AM
  • I have Fixed this problem.

    Registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

    Enabled = 0

    Reboot the machine

    After I disabled the hyper-v by turning off the windows feature, and the device guard in the Administrative template, but the error did not go away. 

    When I disabled HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\Enabled to 0 , Vmware started working! 

    Thank you so much for this. 


    Monday, December 23, 2019 12:35 PM
  • What if this continues to happen after whenever there is a windows update? 

    Pinto Kumar

    Thursday, January 2, 2020 9:31 AM