none
I need a drive A:\ in XP mode

    Question

  • I am using a dos program - menu driven - paradox2 data base that requires data to be transfered to drive A:\  i have a usb 3.5" floppy drive that shows up as drive B:\ in XP Mode but Drive A:\ in the windows 7 professional 64 bit host cmputer.  i tried to use dos commands to "Assign" A:\ to B:\ but XP Mode will not accept it.  How can i make XP Mode recoginize the Floppy as A:\ drive?  or make B: drive link to A: drive?  or Change B: drive to be A:\ drive?
    Friday, September 02, 2011 10:09 PM

Answers

  • The A: drive is enabled in a VPC VM bios by default.  You can get into the BIOS manually when you start the VM, by pressing SHIFT+ESC to open the console window and then pressing the DEL key to enter the BIOS.  This needs to be done quickly as soon as the VM is started from a powered down state.

    The .vmc file can be modified to, but I'm not sure of the section of the CMOS type that needs to be changed.  I think if you change the first "4" to a "0" you will disable the floppy (<cmos type="bytes">00004 to <cmos type="bytes">00000), but it may also cause a BIOS error on reboot and force you to go into the BIOS again.  I guess it's one easy way to get into the BIOS.

     

    . 


    Saturday, September 03, 2011 12:43 AM
  • The drive manager I was referring to is the Host, not the guest.

    You can also access the BIOS this way

    Open the Virtual Machines window.
     
    Right-click on the XP virtual machine and select "settings".

    Click the "Integration Features" setting in the left panel, then uncheck the "Enable at startup" box in the right panel.
     
    This will give you a console window that shows the BIOS as the machine starts up. Start the machine, and quickly hit the DEL key in order to get the BIOS configuration menu.


    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    Friday, September 09, 2011 3:44 PM
  • I seemed to have solved my delima with a program called "ReMount"  which allowed me to change B:\ to A:\ and all is good.

     

    Thank you again for your help.

    • Marked as answer by Roland Guil Wednesday, September 21, 2011 6:44 PM
    Wednesday, September 21, 2011 6:44 PM

All replies

  • You can change the drive letter for B: in Drive Manager in Windows 7 as long as there is no A: already (shouldn't be).  To access Drive Manager, click Start and type "Drive Manager".
    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    Saturday, September 03, 2011 12:32 AM
  • The A: drive is enabled in a VPC VM bios by default.  You can get into the BIOS manually when you start the VM, by pressing SHIFT+ESC to open the console window and then pressing the DEL key to enter the BIOS.  This needs to be done quickly as soon as the VM is started from a powered down state.

    The .vmc file can be modified to, but I'm not sure of the section of the CMOS type that needs to be changed.  I think if you change the first "4" to a "0" you will disable the floppy (<cmos type="bytes">00004 to <cmos type="bytes">00000), but it may also cause a BIOS error on reboot and force you to go into the BIOS again.  I guess it's one easy way to get into the BIOS.

     

    . 


    Saturday, September 03, 2011 12:43 AM
  • Thank you, I tried this and was not able to get into the bios setup.  Also "Drive Manager" does not list the B;\ drive or the A:\ Drive so I can not adjust there either. 

     

    Thank you again.

    Friday, September 09, 2011 3:25 PM
  • The drive manager I was referring to is the Host, not the guest.

    You can also access the BIOS this way

    Open the Virtual Machines window.
     
    Right-click on the XP virtual machine and select "settings".

    Click the "Integration Features" setting in the left panel, then uncheck the "Enable at startup" box in the right panel.
     
    This will give you a console window that shows the BIOS as the machine starts up. Start the machine, and quickly hit the DEL key in order to get the BIOS configuration menu.


    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    Friday, September 09, 2011 3:44 PM
  • Thank You again.

    I was able to access the bios as you instructed.  No matter waht i do the usb floppy appears as B:\ in the virtual machine and A:\ in the host machine.  We have tried every combination of settings in bothe the host and the virtual machine and no matter what it is B:\ drive.

    Wednesday, September 21, 2011 11:30 AM
  • I seemed to have solved my delima with a program called "ReMount"  which allowed me to change B:\ to A:\ and all is good.

     

    Thank you again for your help.

    • Marked as answer by Roland Guil Wednesday, September 21, 2011 6:44 PM
    Wednesday, September 21, 2011 6:44 PM