Cannot connect to existing Windows 7 homegroup from Windows 8


  • I am trying to evaluate the Windows 8 Professional released to Partners recently.

    I have installed it in a VirtualBox virtual machine running in a Windows 7 Host.

    The Windows 7 host has a homegroup connecting it to other Windows 7 physical machines. When I try to connect my Windows 8 machine it says there is no homegroup. So I allow Windows 8 to create a homegroup and try to connect to it from a second Windows 7 machine. When I enter the Windows 8 group password it says it is incorrect.

    At this rate I will never finish the evaluation. HELP.

    Alan Cameron

    • Edited by AlanCam Saturday, September 15, 2012 6:17 PM typo
    Saturday, September 15, 2012 6:16 PM


All replies

  • If you run "net view \\win7hostname", did you get system error? If yes, what's the error code?

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    Saturday, September 15, 2012 9:39 PM
  • Response is


    System error 1707 has occurred

    The network address is invalid


    I have found one of the problems in the network adapter in the Virtual machine was not configured correctly.

    I changed that and the access is now working in one way only.

    I can from the Windows 8 machine access files of another member of the homegroup but not the Windows 8 machine's files from that other machine.

    The Host machine does not appear to respond except to ask for a network password.

    I thought homegroups did away with the need for network passwords?

    I am still puzzled

    Alan Cameron

    • Edited by AlanCam Sunday, September 16, 2012 10:44 AM typo
    Sunday, September 16, 2012 10:43 AM
  • In this case, try to create the same username and password on both computers, Then try it. Please post back with the result.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    • Edited by chicagotech Wednesday, January 02, 2013 3:41 AM
    Sunday, September 16, 2012 2:05 PM
  • Adding a name and password for the second physical machine and on it the Windows 7 Host machine allows me to connect via the Network but does not appear to allow the homegroup to access in all directions.

    Adding the Host machine name and password to the Windows 8 machine allows the windows 8 machine to access the Host machine via the network but not via the homegroup.

    I was under the impression that network names and passwords were not required to use a homegroup and in fact I had it working between my Windows 7 machines without the need to set them up.

    What has changed?

    Alan Cameron

    Sunday, September 16, 2012 5:39 PM
  • Can you ping each by IP6v address? Also check the services . The services that need to be turned on are listed below:

    •DNS Client

    •Function Discovery Provider Host

    •Function Discovery Resource Publication

    •Peer Networking Grouping

    •HomeGroup Provider

    •HomeGroup Listener

    •SSDP Discovery

    •UPnP Device Host

    This post may help too:

    Windows 7 Homegroup IPv6 connection issues

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    • Proposed as answer by RetiredTechie Monday, December 17, 2012 7:39 PM
    Monday, September 17, 2012 12:55 AM
  • I have checked and can ping all the machiines via IPv6 both virtual and physical.

    Checking the services showed up one anomaly both of the physical machine Window Time Services were stopped.

    I have reset them to automatic and started them and then rebooted both machines. This seems to have resolved the problem partly.

    One physical machine (not the Host for the virtual machines including the Windows 8 one) is able to see and interact with all the other machine's library files and folders but none of the others can see this machine's. They can however see folders which have been specifically shared.

    Can you suggest further diagnostic tests?

    Incidentally you did not respond to the question

    Are accounts for all machines needed on all the other machines?

    Alan Cameron

    Monday, September 17, 2012 9:01 AM
  • Sorry, it doesn't required same accoutn in all joined homegroup computers.

    Since we can't access only one computer, it could be the firewall or 3dr party security software. Can you disable windows firewall and do clean boot on the problematical computer for a test?

    I also wrote a homegroup issues – case collections and I am copying here: Troubleshooting Windows homegroup issues - case collections

    1. The Network Connection Type must be assigned as Home network. Please refer to this post: Windows cannot create a homegroup on this computer
    2. Temporarily turn off firewall and antivirus program on each machine. It could be firewall or 3dr party security software. Please refer to this post: Cannot Join Windows 7 HomeGroup or homegroup cannot be created on this computer
    3. Make sure the computer is not multihomed computer meaning no multiple NICs and connections in one computer.
    4. Make sure you have enabled IPv6 and test it by png the IPv6: Windows 7 Homegroup IPv6 connection issues
    5. Make sure these Services running on both computers (Set to Automatic):
      - DNS Client
      - Function Discovery Provider Host
      - Function Discovery Resource Publication
      - Peer Networking Grouping
      - HomeGroup Provider
      - HomeGroup Listener
      - SSDP Discovery
      - UPnP Device Host
    6. Make sure Network discovery is turned off. (Correction: it should be ON)
    7. Make sure the router IPv6 compatible. Please refer to this post: Can't access homegroup
    8. Make sure all computers are in the same subnet.
    9. If the clocks are not synchronized, the HomeGroup feature may not work.
    10. The peer networking idstore.sst file is corrupted. If you see the message "Windows cannot set up a homegroup on this computer. Error code 0x80630801." and you're unable to start the Peer Networking Grouping service
    11. Change the Homegroup password: How to change Homegroup password
    12. Re-create Homegroup. Please refer to this post: Can HomeGroup be completely reset
    13. If it is domain computer, you may be able to access the share files only but not join the Homegroup to share. Can't access Domain laptop shared files
    14. If Windows 7 Starter and Windows 7 Home Basic, you can join a homegroup, but you can’t create one.
    Your computer already belongs to a homegroup. You can only belong to one homegroup at a time.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    Monday, September 17, 2012 10:10 PM
  • Thanks for the detailed information.

    May I respectfully question item 6 Make sure Network Discovery is turned off.

    This appears to contradict what was quoted in the Can't access homegroup link.

    I am still working through these steps.

    Alan Cameron

    • Edited by AlanCam Tuesday, September 18, 2012 9:07 AM better link
    Tuesday, September 18, 2012 9:06 AM
  • It should be "Make sure Network discovery is turned on".

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    Tuesday, September 18, 2012 1:18 PM
  • I thought so!

    Even having gone through all of these checks I am still unable to make a solid connection using homegroup.

    I am more and more convinced that something that was updated during September's monthly patch cycle caused all this problem. I am loathe to restore to a previous checkpoint as there are many other things that could be causing it.

    At the moment I have abandoned Homegroup and reverted to Workgroup linking.

    In my opinion the fact that all the things that have to be  correctly set to be able achieve Homegroup in a complex machine environment is not worth the trouble when it goes wrong. The Homegroup troubleshooting wizard may be able fix things but it does not tell what it has changed so is of no great help.

    One wrong indication  leads to a loss of trust.

    Sorry for the rant.

    Alan Cameron

    Tuesday, September 18, 2012 2:28 PM
  • I just brought my me new Win 8 laptop, booted, configured and much to my amazement, it does not see my Win 7 homegroup. After the disfunctionality of homegroup networking this has not been fixed in Win 8 and a search for a solution brings me to this 15-point fix? Win 8 is supposed to be a big leap to simplicity for consumers and from the get go MS has failed again.
    Sunday, December 02, 2012 10:09 PM
  • Hi Patrick,

    I am sorry I am unabe to help you. I gave up and have resorted to individual accounts on every machine. Every other attempt I have tried has me just as puzzled. The combination of changing one thing after another rebooting in between just became too much trouble. I am not sure I would agree with your last comment but I agree that soemthing is wrong, just don't ask me what!

    Alan Cameron

    Monday, December 03, 2012 9:14 AM
  • I had the same issue but I found a work around. I created a homegroup on my Win8, and joined all my Win7 to it.  Worked right away for me.
    Monday, December 03, 2012 12:14 PM
  • chicagotech,

    This was the solution for me! I had forgotten the use of IPv6 with Win 8 Homegroups. I (probably like many others) had removed Ipv6 drivers from my net adapters on my Win 7 computers since we will not be connecting to any Ipv6 networks in the foreseeable future. (Currently IPv6 is used for Government and University private networks and is not directly accessible via most home links. However Microsoft has made use of the protocol in HomeGroups so you need it.

    Adding the drivers to my other Win 7 computers solved the problem with the newer Windows 8 installation. I had previously not been able to connect using the correct HomeGroup password and producing the system error "Windows no longer detects a homegroup on this network...."


    Monday, December 17, 2012 7:37 PM
  • Thank you for the update.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    Monday, December 17, 2012 8:40 PM
  • I just got a laptop with Windows 8 and wanted to keep my Windows 7 laptop as a file server for downloaded movies/TV. I'd never used homegroup before (always been on domains), and it seemed straightforward, but it just wouldn't work. I could see the Windows 8 machine on the Windows 7 laptop, but not vice versa. I tried creating the homegroup from both machines, but neither saw a homegroup after the other had created it. I used all of the solutions listed elsewhere on this forum. I shared the C: drive on the Windows 7 laptop and then tried the Windows 8 one again. It still didn't show a homegroup at all, but when I clicked "network" in the computer menu, all of a sudden my router and Windows 7 laptop were showing. The C: folder showed as shared, and I confirmed I could access all the files. Not sure if it was sharing it that finally did it, but the homegroup function technically still doesn't work as the Windows 8 laptop isn't joined to one. It's just using basic sharing over the network that seems to be doing it.

    Wednesday, June 05, 2013 7:23 AM
  • I was having the same problem until found a solution hidden in the Control Panel -> Network and Internet -> HomeGroup page where a "warning" was visible saying "The homegroup is not available because you're not connected to your home network.".  Well this was confusing to me but I clicked the link titled: "change network location". This popped up a slide in panel saying "Do you want to find PCs, device, and content on this network, and automatically connect to devices like printers and TVs? We recommend that you do this on your home and work networks". So I clicked "Yes", and now my Windows 8 machine is visible on the homegroup.

    Question I have for Microsoft is why the heck didn't they put this on the Metro HomeGroup UI where it sends me off on a wild goose chase saying "To help keep your stuff safe, sharing and the ability to see other PCs and devices on this network is turned off.  To change this settings, open Connections in PC settings, tap or click the current network connection, and then turn on Find devices and content". 

    None of that jibberish worked for me, the Connections in PC settings had no such option.  They need to add a button to that page titled "Just fix it" :-)

    Monday, April 21, 2014 1:25 AM