none
Auto Reconnect Mapped Network Drive RRS feed

  • Question

  • Hi

     

    We have recently installed windows 7 at work. We use 3 mapped drives (P,Z andT). Sometimes when turning the pc on in the morning the computer will not reconnect to the drives automaticley, Which is a pain. My question is, is there a way to stop this, can you make them auto reconnect on start up.

     

    Thanks       

    Tuesday, April 26, 2011 7:51 AM

Answers

  • Hi,

     

    Addition to Scorpio, you could reset the mapped drive with the following command in an elevated command windows.

     

    net use Z: \\server\folder /persistent:yes

     

    For more information, you can refer to the following article.

     

    http://technet.microsoft.com/zh-cn/library/bb490717(en-us).aspx

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Thursday, May 5, 2011 9:27 AM
    Thursday, April 28, 2011 8:46 AM
    Moderator
  • Hello chrispch,

    According to the research, the mapped drive lost issue may be caused by the several possible reasons:
     
    Possible reason1. The problematic client doesn't reconnect to the target share at logon.
     
    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.
     
    Steps:
     
    a. Open "My Computer"
     
    b. Click on "Tools" and then select "Map Network Driver"
     
    c. input the \\ipaddressofserver\sharename to give the path of the share
     
    d. Check "Reconnect at logon"
     
    e. Drive gets mapped
     
    f. Double click on the drive to check.
     
    Possible Reason 2. Antivirus software or Windows Firewall may block the SMB protocol on clients.
     
    Please check if there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.
     
    Possible Reason3. Fast Logon Optimization is enabled on the clients. 
     
    The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. He may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.
     
    Please also configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.
     
    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon
     
    When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.
     
    Please note: As this is a computer configuration, please run "Gpupdate /force" and then reboot the problematic clients to make it take into effect.
     
    For more information about Fast Logon Optimization feature, please check the following KB article.
     
    305293 Description of the Windows XP Professional Fast Logon Optimization feature
     
    http://support.microsoft.com/?id=305293
     
    831998 Mapped network drive shows no drive letter or will not allow you to create new long-named files or folders
     
    http://support.microsoft.com/kb/831998
     
    297684 Mapped Drive Connection to Network Share May Be Lost
     
    http://support.microsoft.com/kb/297684
     
    If the issue still exists on the problematic clients, please also try adding the following registry subkey on the problematic client to check it works.
     
    Steps:
     
    a. Click Start, click Run, type REGEDIT, and then click OK.

    b. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

    c. Click Edit, point to New, and then click DWORD Value.

    d. Type SilentForcedAutoReconnect , and then press ENTER to name the value.

    e. Double-click SilentForcedAutoReconnect .

    f. In the Value data box, type 1, and then click OK.
     
    Please feel free to let me know if you have any concen.
     
    Hope the information can be helpful for you.


    Thanks and Regards
    Scorpio_Milo
    MCTS: Windows Vista | Exchange Server 2007
    MCITP: Enterprise Support Technician
    MCITP: Server & Enterprise Administrator
    Microsoft Infrastructure Consultant
    Enterprise Service: Solution Architect
    Microsoft Storage Team - File Cabinet Blog
    My Blog
    • Marked as answer by Vivian Xing Thursday, May 5, 2011 9:27 AM
    Tuesday, April 26, 2011 12:57 PM

All replies

  • Hello chrispch,

    According to the research, the mapped drive lost issue may be caused by the several possible reasons:
     
    Possible reason1. The problematic client doesn't reconnect to the target share at logon.
     
    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.
     
    Steps:
     
    a. Open "My Computer"
     
    b. Click on "Tools" and then select "Map Network Driver"
     
    c. input the \\ipaddressofserver\sharename to give the path of the share
     
    d. Check "Reconnect at logon"
     
    e. Drive gets mapped
     
    f. Double click on the drive to check.
     
    Possible Reason 2. Antivirus software or Windows Firewall may block the SMB protocol on clients.
     
    Please check if there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.
     
    Possible Reason3. Fast Logon Optimization is enabled on the clients. 
     
    The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. He may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.
     
    Please also configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.
     
    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon
     
    When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.
     
    Please note: As this is a computer configuration, please run "Gpupdate /force" and then reboot the problematic clients to make it take into effect.
     
    For more information about Fast Logon Optimization feature, please check the following KB article.
     
    305293 Description of the Windows XP Professional Fast Logon Optimization feature
     
    http://support.microsoft.com/?id=305293
     
    831998 Mapped network drive shows no drive letter or will not allow you to create new long-named files or folders
     
    http://support.microsoft.com/kb/831998
     
    297684 Mapped Drive Connection to Network Share May Be Lost
     
    http://support.microsoft.com/kb/297684
     
    If the issue still exists on the problematic clients, please also try adding the following registry subkey on the problematic client to check it works.
     
    Steps:
     
    a. Click Start, click Run, type REGEDIT, and then click OK.

    b. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

    c. Click Edit, point to New, and then click DWORD Value.

    d. Type SilentForcedAutoReconnect , and then press ENTER to name the value.

    e. Double-click SilentForcedAutoReconnect .

    f. In the Value data box, type 1, and then click OK.
     
    Please feel free to let me know if you have any concen.
     
    Hope the information can be helpful for you.


    Thanks and Regards
    Scorpio_Milo
    MCTS: Windows Vista | Exchange Server 2007
    MCITP: Enterprise Support Technician
    MCITP: Server & Enterprise Administrator
    Microsoft Infrastructure Consultant
    Enterprise Service: Solution Architect
    Microsoft Storage Team - File Cabinet Blog
    My Blog
    • Marked as answer by Vivian Xing Thursday, May 5, 2011 9:27 AM
    Tuesday, April 26, 2011 12:57 PM
  • Hi,

     

    Addition to Scorpio, you could reset the mapped drive with the following command in an elevated command windows.

     

    net use Z: \\server\folder /persistent:yes

     

    For more information, you can refer to the following article.

     

    http://technet.microsoft.com/zh-cn/library/bb490717(en-us).aspx

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Thursday, May 5, 2011 9:27 AM
    Thursday, April 28, 2011 8:46 AM
    Moderator
    • I found the answer today - and have been looking for months.

    Go to Control Panel - under System settings - GoTo Power Settings

    Then GoTo "Change when the computer sleeps"

    Here is where you find "Change Advanced Power Settings" Click it

    You may need to click on "change settings that are currently unavailable" to make changes below

    1) uncheck Hard disk - and change settings for the hard disk "while plugged in" to 180 minutes. The hard drive will go to sleep after 3 hours of non-use. Make longer if needed.

    2) uncheck Wireless adaptor - and change "Plugged in" to maximum performance

    3) uncheck Sleep - and make sure all "Plugged in" options read Never

    4) uncheck PCI Express and make sure everything is on Maximum

    I don't know if all 4 changes above are needed - but one of these changes seem to be working on five of our new computers that were putting the Red X on the connected Network drives. I hope someone at Microsoft puts this information out to the public –

    ALSO – you need to go into Device Manager – open your Network Card(s) (properties) – GoTo Power Management and uncheck the boxes suggesting the device can go to sleep.

    I can be reached at 973-292-0025

    Scott

    • Proposed as answer by Scotty-Guitar Wednesday, October 17, 2012 11:19 AM
    Wednesday, October 17, 2012 11:19 AM
  • Hi chrispch and all of you, who have same problem,

       (this problem is painfull especially for application, which want to go to net drive which isnt connected)

    my simpliest workaround for you is to write this very simple batch file which just opens the drive/s and close them, so you dont have to doubleclick them every time you start computer:


    Workaround for you:

    timeout 5
    explorer P:
    explorer Z:
    explorer T:

    timeout 3

    taskkill /im explorer.exe
    taskkill /im explorer.exe
    taskkill /im explorer.exe
    exit

    What it does:
    Waiting (5 seconds) for network connection to come up.
    Open net drive/s in Explorer.
    Giving Explorer some time (3 seconds) to reconnect a drive.
    Close Explorer - this will close only last opened window/s, not entire desktop.
    Close cmd.

    Simpliest form of script:  (works for me on Win8.1 tablet)
    explorer Z:
    timeout 3

    taskkill /im explorer.exe
    exit

    TIP: Create a .lnk of this batch file and set it to run in minimised window (set it in .lnk properties) and put this .lnk file into startup folder.

    Hope it will help someone, somehow :)
    PavelJ





    • Edited by Pavel_J Saturday, April 5, 2014 5:01 PM
    • Proposed as answer by envisager Thursday, November 16, 2017 9:50 AM
    Saturday, April 5, 2014 4:59 PM
  • This is better

    explorer S:
    timeout 3 
    taskkill /im explorer.exe /FI "WINDOWTITLE eq S:\\"
    exit

    • Proposed as answer by Wasterman Thursday, April 26, 2018 4:14 AM
    Monday, October 19, 2015 8:00 PM
  • This worked for me thanks PavelJ
    Saturday, September 24, 2016 12:20 AM
  •  

    Possible reason1. The problematic client doesn't reconnect to the target share at logon.
     
    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.
     
    Steps:
     
    a. Open "My Computer"
     
    b. Click on "Tools" and then select "Map Network Driver"
     
    c. input the \\ipaddressofserver\sharename to give the path of the share
     
    d. Check "Reconnect at logon"
     
    e. Drive gets mapped
     
    f. Double click on the drive to check.

    I have a problem that the above suggestion partially fixed.

    My trouble is this: my roaming profile specifies a share that should be mapped at logon as my U: drive. It is set up to have files available offline. The trouble is, for the past week, the drive is always "unavailable". I use quotes because it is actually available, but Windows 10 does not see this. Several other shares are configured to connect at logon, though not in the profile, but they connect fine.

    The problem is that I cannot find a way to FORCE Windows 10 to connect, so the offline files are being used and getting out of sync with what is on the share.

    When I tried the steps above, using the IP address of the share server instead of its name, it can connect.

    The problem is, the offline files need to be synchronized with what is on the share, but this won't happen unless it can connect with the share using the server's name. It won't synchronize with with the connected share that uses the IP address. 

    How do I fix this?

    Wednesday, December 28, 2016 11:03 PM
  • Thanks Pavel. Much appreciated
    Thursday, November 16, 2017 9:51 AM
  • This is better

    explorer S:
    timeout 3 
    taskkill /im explorer.exe /FI "WINDOWTITLE eq S:\\"
    exit

    AKakoka, thanks a bunch man!

    1. The reason its better in case anyone is wondering is that with out the /FI switch added to the taskkill command, it will even close the core explorer.exe process running the base functions like your taskbar. Normally not a big deal. It should restart itself automatically but it adds delay to your boot time. Also depending on what types of programs your running at boot and their settings/dependencies, this could actually cause failures in those applications.
    2. Pavel's answer is a great start and for most is probably just fine. However for some people, using this could cause you problems. Without the extra {/FI "WINDOWTITLE eq S:\\"} added, it caused my company's user profile backup software to have failures. Due to the application and not the code, I actually lost the documents that i had created the previous day.

    *I know this is old but i just found this and felt i should provide warning to those who may find this after me


    Thursday, April 26, 2018 4:32 AM
  • can i use the containts comparator like this:

    taskkill /im explorer.exe /FI "WINDOWTITLE contains S:"

    My drive name has the full path, so window title obviously is not just eq to S.

    Thursday, October 18, 2018 2:31 PM