none
Windows 7 Logon - Displaying Users RRS feed

  • Question

  • I've been looking around on various forums about displaying a local user account at a Windows 7 Ultimate login screen, after Ctrl-Alt-Delete. Most of them say it's not possible, or go down the route of explaining various options in the machines local security policy. Others have said about deleting unnecessary registry entries under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.

    I've tried a number of options. Some have said it's not possible, but I have seen something working (or at least something similar). At a local university, when you press Ctrl-Alt-Delete you get the usual user name and password entry screen. However, if you hit escape you get an option to either "Change Password" or "Activate Account". These may not be actual user accounts (I'm not sure) however, there are two options plus the "Other User" login option.

    Wednesday, August 14, 2013 10:52 AM

Answers

  • Go to start->type secpol.msc->press enter. Click Yes if UAC prompts. On the left pane, expand Local Policies and click on Security Options. On the right pane, look for the policy Interactive logon: Display user information when the session is locked. Double click on it and select the option you want: User display name only or Username, user display name and domain name. Click Ok. Press Windows key + L to check. 

    Balaji Kundalam

    Saturday, August 17, 2013 12:14 PM

All replies

  • Hi Jack,

    I would like to suggest you verify if you has configured the following group policy.

    1.Press WinKey+R > type secpol.msc and press enter
    2.Navigate to Local policies -> Security options
    3.Find the entry "Interactive Logon: Do not display last user name" and make sure it is disabled.

    If the group policy doesn’t work , try to modify the registry and edit the permission.
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch

    In the right pane, change Enable value data to 1.

    After modifying the data, then change the permission as following:

    1. In the left pane of Registry Editor, right click on the UserSwitch key, and click/tap on Permissions.
    2. Click/tap on the Advanced button, Click/tap on the Disable inheritance button.
    3. Click/tap on Convert inherited permissions into explicit permissions on this object.
    4. Click/tap on Change and set the owner to Administrators.
    5. Check the Replace owner on subcontainers and objects box.
    6. In the Permissions tab, select SYSTEM, and click/tap on the Edit button.
    7. Deny set Value for System, check the Only apply these permissions to objects and/or containers within this container box

    Regards,

    Blair Deng


    Blair Deng

    TechNet Community Support

    Friday, August 16, 2013 10:16 AM
    Moderator
  • Go to start->type secpol.msc->press enter. Click Yes if UAC prompts. On the left pane, expand Local Policies and click on Security Options. On the right pane, look for the policy Interactive logon: Display user information when the session is locked. Double click on it and select the option you want: User display name only or Username, user display name and domain name. Click Ok. Press Windows key + L to check. 

    Balaji Kundalam

    Saturday, August 17, 2013 12:14 PM