none
On Screen Keyboard RRS feed

  • Question

  • I have searched high and low for a fix for this that works, but have yet to find anything.

    I have a Gateway laptop running Win8.1. As it is a laptop, I have absolutely no need for the on screen keyboard. However, there is no way that I have found to turn it off. It is bulky, obtrusive, and gets in the way. On a tablet or a Surface, I can see how it would be useful, but again, I have a laptop. It's just taking up space. There should be a setting to turn it off when it is not needed.

    I have found the same couple fixes listed everywhere that have supposedly worked for others and tried them, but nothing has worked. They included disabling the on screen keyboard in the ease of access center (even though it was already disabled), and opening Services, finding Touch Screen Keyboard and Handwriting, and telling it to stop. I even changed it to a manual start-up instead of automatic, but it didn't work, no matter how many times I switched it over, hit Apply first instead of just Ok, or rebooted after switching.

    Is there any way that I could just get rid of it entirely, since I apparently can't just tell it to stop popping up? I have no need for it and would rather just be rid of it entirely if I can't hide it. An uninstall would be preferred, but if there is at least a way to hide it for good, then that would be incredibly helpful.

    Monday, January 13, 2014 3:44 AM

Answers

  • Hi NephereFirefly,

    You’re welcome. I did see that you already attempted the workaround but I am unsure as to why the work around may not be working for you. I have tested this on my SurfaceRT2 and I do not seem to have the same issue. Does it work at all but the service simply restarts when the system is restarted? As I said, it is not a documented or truly supported method but it’s the only workaround known at this time.

    I also found this thread on Microsoft Answers that has some additional suggestions but again, nothing that is fully documented.

    Unfortunately, the official answer is that what you’re trying to do is unsupported at this time.

    Tuesday, January 14, 2014 7:08 PM
    Moderator

All replies

  • Presuming you are using just a laptop without a touch screen interface, you’re right – you do not need access to the on screen keyboard nor should it be popping up. If your laptop includes a touch screen interface then we have a bit more troubleshooting to do. For the next paragraph of this response I am going with the assumption you are using a standard laptop, without any touch features.

    There should be an icon in the bottom right hand corner that is shaped like a keyboard if you click it then the keyboard should disappear and reappear on each subsequent click. If the icon is not present, you can add it by right clicking on your taskbar, selecting properties, then selecting the toolbars tab and checking the touch keyboard box. One thing that is important to note though is that if the touch screen keyboard shows on the screen, it should automatically disappear. Since the automatic disappearing feature does not sound as though it is the case with your scenario then I am wondering if you have a corrupt install of Windows 8.1 on your system. It might be best to attempt a repair install or, on a worst case scenario basis, a clean install.

    Now, if you do have a touch screen laptop and are referring to the keyboard that pops up in the Windows Modern UI apps then that’s an entirely different answer. While there isn’t a specific or documented method for turning the on-screen touch keyboard entirely, there is a way to effectively disable the keyboard by stopping the service that controls it.


    • Press the Windows key + W
    • Type "services," and press Enter
    • Scroll down to "Touch screen keyboard and handwriting panel"
    • You can either right click and "Stop" or you can double-click and change it from "Automatic" startup to "Manual."


    "This will of course, disable both the touch keyboard and handwriting service, so you'll lose handwriting recognition. This was totally worth it to me and has made my touch screen laptop experience much better, especially when I'm using the Full Screen Browser. I hope this helps!"



    Monday, January 13, 2014 9:31 PM
    Moderator
  • Jessica,

    Thank you for your reply. I am currently using a touch screen laptop. I really do like the fact that it is a touch screen, it is just this one things that makes me incredibly frustrated, even trying to type up anything on word, because, for example, every time I try and scroll it pops open the keyboard and gets in the way.

    In my post I stated that I had already tried finding it in Services and stopping it, then trying to switch it to manual. I stated that it never worked no matter how many times I would change it, reboot, etc. I am looking for other methods that will hopefully work, as that one did not. If it comes down to it, I would also be ok with a way to completely remove the Touch Keyboard and Handwriting Service. I never use it, so it is no real loss to me.

    Thanks again for your reply :)

    Tuesday, January 14, 2014 6:20 PM
  • Hi NephereFirefly,

    You’re welcome. I did see that you already attempted the workaround but I am unsure as to why the work around may not be working for you. I have tested this on my SurfaceRT2 and I do not seem to have the same issue. Does it work at all but the service simply restarts when the system is restarted? As I said, it is not a documented or truly supported method but it’s the only workaround known at this time.

    I also found this thread on Microsoft Answers that has some additional suggestions but again, nothing that is fully documented.

    Unfortunately, the official answer is that what you’re trying to do is unsupported at this time.

    Tuesday, January 14, 2014 7:08 PM
    Moderator