How to enable a USB audio device in windows7 by program


  • I have a USB audio device and have a application to control it, in windows XP it work well , but in windows 7 the application can not found it.
    Have to "show Disabled Devices" is Sound control panel and Enable this device then our application can work on it.
    I want to know is there any way to enable this audio deivce by the application (program) . that will easy to use for end user.
    The windows 7 I have tried is Build 7100
    Wednesday, June 17, 2009 7:21 AM


All replies

  • Eric,

    Just to be clear - this audio device has installed properly, and is configurable from the Sound Control Panel, but is not detected by any of the programs which you would like to use it? In this case, it sounds to me as though the problem is with the program's Windows 7 API support - you could try running it in compatibility mode for Windows XP or Windows Vista. To do this, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    Wednesday, June 17, 2009 1:16 PM
  • Alex,
    Yes, it install properly and configurable , I just hope my customers don't have to configure the device by themselves,
    as you know not every one are computer expert , more over they could probably don't know how to find the Sound Control Panel.
    So if I can enable the device by the application, the user just run the application then all things have done for them.

    As you know in windows XP  all audio devices can be accessed , but windows 7 not,  it disable all audio devices as default.
    Hope there are some function call could enable audio device.

    Best regards,

    Thursday, June 18, 2009 3:17 AM
  • Eric,

    I understand - at this point, it sounds as though you'd be better served by the MSDN forums .
    • Marked as answer by Nick FV Thursday, June 18, 2009 3:54 PM
    Thursday, June 18, 2009 2:57 PM
  • Alex,
    Thanks , I will check there.

    Friday, June 19, 2009 4:04 AM