how te re-enable SMB1 in windows1o RRS feed

  • Question

  • I can'nt find a simple way to how re-enable SMB1 in windows10
    Wednesday, January 3, 2018 1:32 PM

All replies

  • Hello,

    See if this guide helps you:


    Let us know if this helps!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Wednesday, January 3, 2018 1:58 PM
  •   If you are running Version 1709, there are now three separate checkboxes for SMB 1.0.


    Thursday, January 4, 2018 5:51 AM
  • Hi,

    SMBv1 is not installed by default in Windows 10 Fall Creators Update(1709), but we still can enable it via Windows Features.

    Tick all of SMB 1.0/CIFS File Sharing Support, SMB 1.0/CIFS Client, SMB 1.0/CIFS Server and SMB Direct.

    If you are using 1703 and earlier version, SMB 1.0/CIFS File Sharing Support is ticked by default.


    SMB 1 should be enabled by default but it won`t be used if SMB2.0 or SMB 3.0 is available. If your NAS device only supports SMB 1.0, we could try to disable SMB 2.0 and SMB3.0 to force the Windows 10 machine to use SMB 1.0

    How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 4, 2018 6:38 AM
  • We have not heard from you in a couple of days. Please post back at your convenience if we can assist further.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 22, 2018 8:38 AM
  • You should be able to enable SMBv1 client without an issue.
    I think the real problem is with the server...

    Am using Windows 10 Home. Clean install of FCU has this
    under Programs and Features -> Windows Features
    -> SMB 1.0/CIFS File Sharing Support:
       Checked - SMB 1.0/CIFS Automatic Removal
       Checked - SMB 1.0/CIFS Client
       UnChecked - SMB 1.0/CIFS Server

    Yup, SMBv1 is not installed by default in Windows 10 Fall Creators Update and
    Windows Server, version 1709. So I'd like to re-enable SMB 1.0/CIFS Server.
    I tried enable SMBv1 Server package in Windows Feature and reboot host over
    and over again. But I can't re-enable SMB 1.0/CIFS Server.

    Of course I tried another ways run as Administrator as below:

    PS C:\Windows\system32> Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol


    PS C:\Windows\system32> Set-SmbServerConfiguration -EnableSMB1Protocol $true
    + CategoryInfo : NotSpecified: (MSFT_SmbServerConfiguration:ROOT/Microsoft/...erConfiguration) [Set-SmbSe rverConfiguration], CimException
    + FullyQualifiedErrorId : Windows System Error 1243,Set-SmbServerConfiguration


    PS C:\Windows\system32> Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol" -All

    All failed, can't re-enable SMB 1.0/CIFS Server;-) Anyone can re-enable SMB 1.0/CIFS Server on Windows 10 Home clean install of FCU?
    Thursday, February 15, 2018 12:09 PM
  • Anyansomari - Are you able to find a solution?

    I have one machine with the same issue, cannot enable SMB1 Server.

    Tuesday, March 13, 2018 12:46 AM
  • Thanks a lot. I have tried a lot of others things but this is so simply and why I havent come to think of it myself, I m still wondering :D
    Sunday, March 18, 2018 1:31 PM
  • I have 2 Win 10 laptops, one without the 1709 update, the other with it. I, too, needed to re-enable SMB v1 because of my primary NAS (backup) and other legacy devices. Sorry, Microsoft, these do not all have SMB2 updates, but some of us need to continue working w/o interruption. Below is what I did to get everything back to normal, with my NAS folders mounted as drives to facilitate nightly backups.

    I found extra info, besides "Turning Windows features on and off" as shown above (didn't work for me). I was not able to insert links or images as my account here is not verified. But on github under docksal>docksal> issues>382, there are command line pointers that completed the trick for me:

    Specifically....running cmd.exe as administrator

    C:\Windows\system32\dism /online /enable-feature /featurename:SMB1Protocol-Server
    Check that it is working by:
    C:\Windows\system32\dism /online /get-features /format:table | find "SMB1"
    SMB1Protocol                                | Enabled
    SMB1Protocol-Client                         | Enabled
    SMB1Protocol-Server                         | Enabled
    SMB1Protocol-Deprecation                    | Enabled
    Also, check SMB 1.0/CIFS under "Turn Windows features on or off" (search Windows Features). I checked everything which is also the way my pre-1709 laptop is configured (can't show image as I'm unverified)

    • Proposed as answer by nc3man Tuesday, March 27, 2018 7:34 PM
    Tuesday, March 27, 2018 7:33 PM
  • You must go to Control Panel > Programs > Turn Windows Features On or Off, then turn SMB1 on.

    Tuesday, May 29, 2018 6:33 PM
  • It worked. Thank you :) 
    Thursday, July 26, 2018 7:16 PM
  • Thank you so much for posting this!  We have several Sony HAP-S1's and we could no longer update the music on them.  Re-enabling SMB1 fixed it.


    Friday, July 27, 2018 3:51 PM