none
Location is not available, E:/is not accessible, Access is denied. RRS feed

  • Question

  • Hi All
    I have a problem with disc access, the disc is not broken I can defrag and check with win7 via the security centre.
    But when I try to read via "Computer" I get this error.

    Location is not available
     E:/is not accessible
      Access is denied.

    I have full acces in safe mode, DOS, and via linux
    I Have tried resetting permisions etc to no avail.

    Any ideas?

    Regards
    Roy
    Sunday, November 8, 2009 1:33 AM

Answers

  • Hi,

     

    I suggest you disable UAC to check if it is the cause.

     

    Disable UAC

    ==========

    1. Click the Start Button, type "User account control" and press Enter.

    2. When the User account control settings box appears, move the slider to Never notify.

    3. Click OK.

     

    If it does not work, I suggest you check the permission for your Drive E.

     

    Take ownership and change the permission for Drive E

    ===========

    1.   Right click on Drive E and click Properties.

    2.   Switch to Security tab, click Edit and Add to add your user account, if it is not listed. Assign the full control permission for your own account and click OK.

    3.   Click Advanced, switch to Ownership tab and click Edit button.

    4.   Highlight your user account and click Apply, OK.


    What’s the result?


    Arthur Li - MSFT
    Monday, November 9, 2009 8:45 AM
    Moderator

All replies

  • Can you access the drive after a clean boot:

    http://support.microsoft.com/kb/331796
    Sunday, November 8, 2009 1:51 AM
  • It is visible in the "My computer" window, but if you click on the Icon you get that errror message (Above) the only time I can actualy read it with windows is in safe mode?
    The only times windows can do anything with it is in "safe mode" (Read & write) "security centre" (Defrag)

    Oh its NTFS 500gigbtw.

    It worked fine untill I had trouble reinsalling "XP prof" (my insall disc failed? some filles missing, runtime I think)
    so I went with "win7" eval copy and cant read this drive?

    I vaguely remember a similar problem some months back, insalling linux fixed it, some sort of setting was wrong on the hard drive?
    I cant remember what though! didn't work this time.

    Thanks
    Roy
    • Proposed as answer by sancheznestorm Monday, February 7, 2011 6:51 PM
    Sunday, November 8, 2009 4:02 AM
  • Nope clean boot no good either!

    Have noticed I cant uncheck read only box on some folders.

    In safe mode it runs through the motions of unchecking the files (A few get the cant access message) when I reload the folder the box is ticked again?

    There is also a little padlock on some folders on the drive what do these mean?

    Thanks for your trouble
    Regards
    Roy
    Sunday, November 8, 2009 9:30 AM
  • Hi,

     

    I suggest you disable UAC to check if it is the cause.

     

    Disable UAC

    ==========

    1. Click the Start Button, type "User account control" and press Enter.

    2. When the User account control settings box appears, move the slider to Never notify.

    3. Click OK.

     

    If it does not work, I suggest you check the permission for your Drive E.

     

    Take ownership and change the permission for Drive E

    ===========

    1.   Right click on Drive E and click Properties.

    2.   Switch to Security tab, click Edit and Add to add your user account, if it is not listed. Assign the full control permission for your own account and click OK.

    3.   Click Advanced, switch to Ownership tab and click Edit button.

    4.   Highlight your user account and click Apply, OK.


    What’s the result?


    Arthur Li - MSFT
    Monday, November 9, 2009 8:45 AM
    Moderator
  • i follow your instruction but it still not working.

    my windows 7 said drive not accessible after i change the letter.it work only drive C and D, the drive E to Z isn't work all.please help!!! Thank in advance.

    Sunday, November 14, 2010 10:51 AM
  • i follow your instruction but it still not working.

    I am getting E:/ is not accessible . Access is denied  in windows 2008 R2 SP1.

    Kindly do the needful help.

    


    Thursday, October 25, 2012 8:57 AM
  • I am facing the same problem in Windows 7. I know the root cause- that means the reason for this problem, but i dont know the remedy.

    I choose D: drive and choose 'share with' -> Advanced Sharing, there i removed all the users access(including me).. it means no one is able to access the folder and after it's moves like a wizard, i just pressed next and ok, finallllly i am unable to access the D: drive(it show NTFS below)

    Location is not available

    D:\ is not accessible.

    Access is denied.

    Wednesday, October 31, 2012 11:51 PM
  • I wish contingent staff moderators would STOP marking questions as answered, & especially their OWN answers!

    The OP didn't verify that your reply helped at all, & two other people plus myself have had the same problem (I'm having this on Windows 8.1), but seeing as the question has been marked as "answered", nobody else has tried to supply an answer.

    This practice of marking answers just for the sake of closing questions has got to STOP. It's diluting the effectiveness of the forums.

    Now I guess I'll just have to go & GOOGLE the problem!


    Yann Duran
         - Co-Author of Pro Visual Studio LightSwitch 2011
         - Author of the  LightSwitch Central Blog

    FREE Download: Luminous Tools for LightSwitch
    (a Visual Studio productivity extension for LightSwitch)
     
    Click Mark as Answer, if someone's reply answers your question
    Click  Vote as Helpful, if someone's reply is helpful
     
    By doing this you'll help everyone find answers faster.

    Wednesday, November 6, 2013 6:40 AM
  • The real answer was found here:

    http://www.techsupportforum.com/forums/f16/solved-location-is-not-available-o-is-not-accessible-access-is-denied-644886.html

    I keep forgetting that with Windows 8, even with an administrative account, you're not really an administrator - no message telling you that you can't do something, it just pretends to do it, but doesn't really.

    I long for the days where I used to be the owner of my own machine! And where Windows used to do what I told it to do. So much wasted time!


    Yann Duran
         - Co-Author of Pro Visual Studio LightSwitch 2011
         - Author of the  LightSwitch Central Blog

    FREE Download: Luminous Tools for LightSwitch
    (a Visual Studio productivity extension for LightSwitch)
     
    Click Mark as Answer, if someone's reply answers your question
    Click  Vote as Helpful, if someone's reply is helpful
     
    By doing this you'll help everyone find answers faster.

    Wednesday, November 6, 2013 6:50 AM
  • But this worked for me 20 minutes ago, follow these six steps and you will get access to your D:\

    1. Click Start > Type "diskmgmt.msc"

    2. Right-click "diskmgmt" and click "Run as Administrator"

    3. On Disk Management Window, select the drive letter which is "D:\" in your case (mine too)

    4. Right-click "D:\" and click "Change Disk Letter and Paths"

    5. Choose a letter from the drop-down menu on the top-right corner

    6. Click "OK"

    I hope this helps. Please let me know...

    Check my blog if you want: (Removed by me).


    JM: Blog: http://progammingalone.wordpress.com Learn Through Mistakes. Fear to risk, fear to learn!

    Saturday, November 9, 2013 9:42 AM
  • Hey I tried this, now I still  get the notification only for the newly chosen path name (drive was called H, now B) "acces denied."

    Also added the advanced sharing permissions, which didn't change anything either. 

    I really hope someone has the remedy.

    Reinstalled my windows 7 to 8. Used to have the problem with this (external) usb disk drive when connecting it to other computers or laptop's, but now that my windows has reconfigured, obviously I forgot it would deny my access. :S

    Sunday, November 10, 2013 1:17 PM
  • Hi,

    Mine too was stubborn for a while. My disk D:\ was changed to B:\ and it was now accessible, but after few minutes, the same error came back "Access Denied". What I did was to change the drive letter again and then I copied all folders and files to another folder I named Drive D Contents.

    Please try again the same procedures and see whether change will come. When you get access to the drive, you can move its contents to another place (Your desktop for example).

    I hope you will fix the problem as I did my few days ago :).


    JM: Blog: http://progammingalone.wordpress.com Learn Through Mistakes. Fear to risk, fear to learn!

    Monday, November 11, 2013 6:28 AM
  • I had the exact same problem, and the solution was embarrassingly simple. My HP computer has a HDD with 3 partitions for system restore points and web quickconnect features. These "extra" partitions are unavailable to open in win7. I thought that when I plugged in the flash drive that my flash drive would appear a the bottom of the list, however it appeared in the middle and the "new" drive icon had just been bumped down one position in the list. As soon as I realized this I was back in business! Hope that helps someone!
    • Edited by randalamyett Saturday, December 7, 2013 5:21 AM
    • Proposed as answer by randalamyett Saturday, December 7, 2013 5:21 AM
    Saturday, December 7, 2013 5:20 AM
  • Hi All
    I have the same problem with disc access,
    when i double click on e drive it says this

    Location is not available
     E:/ application not found

    if i want to open the files then i want to rightclick and explore

    all this happened after i uodated to windows8.1

    now this is the 3rd issue with win8.1 which is not yet solved

    (which include 1. graphics driver and amd catalyst, 2. windows automatic update and control panel)

    Any ideas to solve this?

    regards

    alby




    • Edited by alby19791 Monday, December 16, 2013 2:28 PM
    Monday, December 16, 2013 2:22 PM
  • OMG! I can't believe that worked for me!

    Thank you!!

    Monday, December 16, 2013 6:16 PM
  • I may have a couple of clues to offer.

    For what it's worth, this problem began for me when I simply disconnected and reconnected a portable USB drive (on different computers). The computer from which I unplugged the drive runs windows 8.0, and the "destination" computer into which I later plugged the drive (and first had this problem) runs Windows 7.

    I couldn't resolve the issue on the Windows 7 computer, but was surprised when I found that I could access the disk's contents if using the "Command Prompt" with elevated (administrator) permissions and copy the contents using the "xcopy" command.

    When I gave-up on accessing the disk on the Windows 7 machine, I brought the disk back over to the Windows 8 machine. Surprisingly, I had the same problem! So, in my case, this problem is not specific to Windows 7 or 8. It seems specific to NTFS.

    After trying everything else mentioned here with respect to owner/permission (change owner to me, replace all ownership and permissions recursively, etc.), changing the drive letter assignment, and disabling UAC, I was at a loss.

    I booted into Linux was pleased to find that I could see and access all of the files on the disk. So, clearly, this is an OS/NTFS/permissions issue.

    Next, I opened the Disk Management console and right-clicked on the disk in question and chose "Properties". It was at this time that I received a dialogue about the Recycle Bin being corrupted on this drive, and whether or not I wanted to empty the Recycle Bin to fix the issue. This is when I realized that the results of choosing "Properties" for the drive were different than when I performed the same action from within the Computer (AKA "My Computer") view. When viewing the drive properties from within the administrative MMC "Disk Management" snap-in, I was actually able to see the amount of used and free space on the disk, which I could not do when viewing Properties from within the explorer.exe shell. Furthermore, I was able to run a Disk Check (which passed with no problems, by the way) from within the Disk Management console, whereas I could not do the same from within the Explorer shell ("The disk check could not be performed because Windows can't access the disk"). Again, this is consistent with a level-of-access problem.

    Anyway, I am still unable to access the disk via the explorer.exe shell. Just thought I'd share these clues:

    1.) It is possible to "get closer to a solution" by accessing Disk Management console because it has the elevated rights required to, for example, view used/free space and run a Disk Check.

    2.) The disk's contents are available to copy using a command prompt (cmd.exe) with elevated (administrator) permissions.

    Maybe someone else will be able to take this information and "run with it".




    • Edited by GeraldCough Wednesday, January 1, 2014 12:55 AM
    Wednesday, January 1, 2014 12:06 AM
  • Hi have had exactly the same problem,but try this it worked for me

    1. Navigate to the target file/folder.
    2. Right-click on the file/folder and choose Properties.
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click Edit-> Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.
    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".
    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.
    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.
    7. Click "OK" to save changes and wait for Windows 7 to transfer the ownership of all the objects on the partition.
    8. Click OK  to save changes and exit the Properties window.

    9. After that just repeat the first three  steps

    10. Add another user "authenticated users" but with unchecked full control and modify.

    11. Skip 4-7 steps

    12. Click OK again to save changes and exit the Properties window

    • Proposed as answer by GarrettHDO Saturday, March 29, 2014 2:48 AM
    Tuesday, January 21, 2014 4:30 PM
  • i have a same problem please help me......
    Sunday, May 25, 2014 1:51 AM
  • please tell me i have the same problem

    Sunday, May 25, 2014 1:53 AM
  • Hi have had exactly the same problem,but try this it worked for me

    1. Navigate to the target file/folder. 
    2. Right-click on the file/folder and choose Properties. 
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click Edit-> Add button, type "EVERYONE" in the "Enter the object names to select " box, then click "OK" to add this group. 
    4. Select the user - "EVERYONE" from the list and then check the "Allow" checkbox next to "Full Control".
    8. Click OK  to save changes and exit the Properties window.

    I did the Above, and it worked!

    • Proposed as answer by NMPeter Friday, November 25, 2016 9:10 PM
    Sunday, June 8, 2014 8:03 AM
  • 3. Click the "Security tab" --- What if there is no "Security Tab" like in the removable disks?

    Also, what can I do with the disk write protection?


    JM: Blog: http://progammingalone.wordpress.com Learn Through Mistakes. Fear to risk, fear to learn!

    Monday, June 9, 2014 7:30 AM
  • EVERYONE worked for me! Thank you!
    Tuesday, July 15, 2014 8:17 PM
  • Hi have had exactly the same problem,but try this it worked for me

    1. Navigate to the target file/folder. 
    2. Right-click on the file/folder and choose Properties. 
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click Edit-> Add button, type "EVERYONE" in the "Enter the object names to select " box, then click "OK" to add this group. 
    4. Select the user - "EVERYONE" from the list and then check the "Allow" checkbox next to "Full Control".
    8. Click OK  to save changes and exit the Properties window.

    I did the Above, and it worked!

    This process also worked for me. You have to follow the instructions just as they are displayed above. THIS WILL WORK
    • Proposed as answer by Colliek Tuesday, February 10, 2015 1:35 AM
    Tuesday, November 4, 2014 6:18 AM
  • DUDE, IT HELPED TO ME, AT LEAST TO ME... THANKS MAN!!! 
    Sunday, December 28, 2014 3:06 AM
  • where is the 'target file/folder'?
    Thursday, January 1, 2015 7:39 PM
  • THANK YOU,  THANK YOU, THANK YOU , I did exactly as you stated and it worked, what a clever person you are. ,Thanks so much as it was driving me crazy !!!!!.. People this really does work .
    Tuesday, February 10, 2015 1:37 AM
  • Thanks a lot ... it worked for me ....
    Tuesday, March 31, 2015 11:13 AM
  • Helpful .. I have opened my M:/ drive with your instructions Thank you :) 
    Monday, May 18, 2015 10:13 AM
  • This worked!  The solution was so simple too
    Saturday, June 13, 2015 12:50 AM
  • perfect! I did what you wrote and  now the disk works well.

    thanks a lot☺

    Wednesday, July 8, 2015 2:13 PM
  • In case this happen to your server, you can't enable the disks for all users via disk management.

    Disable the UAC from registry: https://gallery.technet.microsoft.com/Registry-Key-to-Disable-UAC-45d0df25


    Monday, November 16, 2015 10:44 AM
  • when I connect pen drive security tab does not apper

    what is the solution??

    Thursday, June 23, 2016 6:44 AM
  • Thank You Sir, it helps me.

    But one more issue, now I'm not able to search any thing into my partition.

    So, can you suggest what to do next?


    Thanks & Regards

    Friday, September 9, 2016 12:47 AM
  • This was "the fixer" for me, ran thru _all_ the fixes, permissions, chkdsk and the rest, seem this drive had no everyone group, soon as I added it, I was able to access the drive from inside windows.

    The ide drive had been moved from a pretty old windows box to a win7 box via a USB adapter

    remember when a 400GB drive was just the shizz?

    now onto the same deal with the other archive drive a 750GB IDE model.

    +1

    ----------------------------------------------

    Hi have had exactly the same problem,but try this it worked for me

    1. Navigate to the target file/folder. 
    2. Right-click on the file/folder and choose Properties. 
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click Edit-> Add button, type "EVERYONE" in the "Enter the object names to select " box, then click "OK" to add this group. 
    4. Select the user - "EVERYONE" from the list and then check the "Allow" checkbox next to "Full Control".
    8. Click OK  to save changes and exit the Properties window.

    I did the Above, and it worked!


    Friday, November 25, 2016 9:13 PM
  • Hi,

    I follow your instructions and changed drive permission but still not working.


    • Edited by Aslam32 Tuesday, June 20, 2017 5:52 AM
    Tuesday, June 20, 2017 5:49 AM
  • I developed the same problem with an HP 2TB personal media drive --- "access is denied".

    I added "EVERYONE" as you suggested and it worked!  Thanks

    Sunday, November 5, 2017 11:13 PM
  • Hi Arthur,

    your method did the trick...works great now!!!

    many thanks :)

    Monday, December 4, 2017 7:48 AM
  • After right-clicking <g class="gr_ gr_42 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="42" id="42">in</g> the drive  not getting the Security Tab 
    Wednesday, January 3, 2018 10:56 AM
  • No working at all

    Wednesday, January 3, 2018 10:57 AM