Windows has blocked this software because it can't verify the publisher


  • I receive this every time the RC1 download manager starts. It is very frustrating especially after several attempts. I tried reducing my IE security settings, fooled with active X controls but I get the same warning. I am running Vista Ultimate & IE8.
    Wednesday, May 06, 2009 7:57 PM

All replies

  • Hmm.. I was able to download the RC using Windows 7 and IE 8 - without so much as a complaint here. Try clearing out your IE 8 history and cache. If that doesn't work, you could try running IE 8 without any add-ons. And if all else fails, you could try fully resetting IE 8 to it's default settings and trying again. A full reset should clear out EVERYTHING including any addons that could be conflicting.
    Wednesday, May 06, 2009 8:49 PM
  • Well you are more fortunate then I. I have treied to download RC1 from a Vista Ultimate PC, Windows XP SP2 PC and a virtual session of Windows 7 and all have given me the same result. That stupid download manager wil not run because Windows does not recognize the publisher.
    I have tried you suggestions on all 3 and I receive the same annoying message. How about you burn a 64 bit version to DVD for me and mail it to me? Kidding.
    Thursday, May 07, 2009 12:35 PM
  • I had to extract the direct download link from the url from the download manager, and then downloaded it. I kept getting a file size mismatch error with IE 8 and Firefox. I would post the link but I think thats a no no.
    • Edited by crt Thursday, May 07, 2009 9:49 PM
    Thursday, May 07, 2009 8:23 PM
  • So how did you extract the direct download link? Or is that illegal to post?
    Thursday, May 07, 2009 8:54 PM
  • jt -

    It's actually kinda obvious.. You can see the URL when you've got the file being downloaded in the Download Mangager. You might have to play with the display to read it all, but it's there.

    I'd send you a DVD, but somehow, I don't think I'd be in Microsoft's good graces for doing so...
    Thursday, May 07, 2009 9:07 PM
  • IE is blocking it because the activex cannot verify the publisher.

    to download it, go to
    log in,
    click "Windows 7 Release candidate"
    and download it.
    • Proposed as answer by Shub_b Thursday, March 10, 2011 5:48 AM
    Thursday, May 07, 2009 9:33 PM
  • This does not work. I have the same problem when trying to download from this site as well.
    Friday, May 08, 2009 2:22 PM
  • In IE / Tools / Options / Security tab - unckeck "Enable Protected Mode" and then click the "Reset all zones to default level" button (which will cause the above to be rechecked.

    Stop and restart IE and try the d/l again.  sorry you're have such a problem with this one.

    Friday, May 08, 2009 2:31 PM
  • This was one of the first steps I tried. This does not help either.
    Friday, May 08, 2009 2:54 PM
  • At this point, I have to defer to an MVP or such.

    I will not encourage you to bypass the protection as I know it works w/o that on most systems, and I would be responsible for any subsequent demise.  This protection is there for a reason!.
    Friday, May 08, 2009 3:02 PM
  • My computer won't download anything including windows updates, internet explorer updates, firefox or any other files. It keeps telling me it don't regonise publisher from any of them which is annoying because i can't download my anti virus software i have paid for. any suggestions would be most welcome.
    Thursday, August 06, 2009 9:48 AM
  • Sounds like you may have a virus, see if you can get to any of the antivirus sites, mcaffee or norton.  Also try and lower the security settings in IE to medium low, default is Medium high.

    Thursday, August 06, 2009 10:21 AM
  • I had to use Firefox of all things to download the Windows 7 RC. Internet Exporer wouldn't let me but I can't remember the exact problem I had.
    Thursday, August 06, 2009 2:44 PM
  • I just downloaded Wondows 7 RC after successfully running a shonly version for a couple of days. Why not longer? Because as I learned although it said RC1, it also said Beta somewhere, and it seized to operate for more than 2 hours on August 1, as I learne the Beta Win 7 would do.

    So, I downloaded it, but not really, because after about 10 hours when finally it sat on 99% getting close to the finish, it said `file error`!

    Any clues on that?

    I use a HP Pavillion Entertainment PC.
    Thursday, August 06, 2009 3:04 PM
  • GO to tools>options>security(tab)>custom level(button)>download unsigned activeXcontrols(under heading of- activeXcontrols and plug-ins) choose prompt. Problem will be solved. Hv a gr8 time while browsing.
    Wednesday, September 14, 2011 5:06 PM