locked
Windows 10 not updating from WSUS RRS feed

  • Question

  • Hey there,

    we have Windows 10 deployed for some clients now. But the client seems to get his updates from the Windows Update Servers instead of our new WSUS Server.

    Because of the much log text: http://pastebin.com/96KmQF3e

    The client reports to this WSUS that it needs Office Updates but no Windows 10 Updates. Latest cumulative update got installed from the MS servers.

    I have "Do not connect to any Windows Update Internet location" not configured in GPOs because it seems that it has nothing to do with this.

    Can anyone help with this?

    Regards

    Stephan


    Regards Stephan

    OneDrive / Sharepoint Blog

    Thursday, February 23, 2017 2:16 PM

Answers

  • Hi Kate,

    thank you for your answer. I somehow got it managed.

    I reconfigured these 3 WSUS Options to "not configured":

    - Do not include drivers with Windows Updates
    - Select when Feature Updates are received
    - Select when Quality Updates are received

    Then i got a new error stating the "normal" 0x8024401C. No report or download possible.

    Then i did this:

    • Open the IIS Manager on the server, expand Sites, press on WSUS Administration site. Press on the Advanced Settings on the right. Expand Limits and in the field „Connection Time-out (seconds)“ instead of 180 put higher value, e.g. 320.
    • In the Application Pools window press on the WsusPool, then go to Advances Settings > and in the Recycling section change Private Memory Limit (KB) to 0 (means unlimited size).
    • Stop the IIS service (by pressing Stop in the IIS Manager, when you are on the SERVER (SERVER\administrator))
    • Run Notepad via Run as administrator and edit C:\Program Files\Update Services\WebServices\ClientWebService\web.config file replacing:

    <httpRuntime maxRequestLength="4096" />
    with
    <httpRuntime maxRequestLength="204800" executionTimeout="7200"/>
    Save the file overwriting the original (make sure it’s not of the txt extension).
    Start the IIS service.

    Big thanks to this blog: http://www.wroot.lt/wp/technology/wsus-woes-with-windows-10-en/

    Now the client reports to the WSUS Server and maybe would download something. I need to set up a fresh install because all clients got their updates from Windows Update online. So i can only see one request for flash.

    Sorry but this is not acceptable. With Windows 7 there were no problems at all and now you have to execute postinstalls and tweak the IIS settings so WSUS works.

    How about a hotfix (either Win10 to search faster or WSUS to react longer)



    Regards Stephan

    OneDrive / Sharepoint Blog

    Friday, February 24, 2017 7:25 AM

All replies

  • Hi Stephan,

    It seems that you have configured WSUS properly and Windows client can recognized.

    22.2017.02.23 14:06:57.0493113 452   6164  Agent           WSUS server: http://wsus.domain.local:8530
    23.2017.02.23 14:06:57.0493113 452   6164  Agent           WSUS status server: http://wsus.domain.local:8530
    

    Do you mean that this line appear that Update was not downloaded from WSUS server?

    47.2017.02.23 14:06:57.1399350 452   1608  Misc            Got 7971F918-A847-4430-9279-4A52D1EFE18D redir Client/Server URL: https://fe2.update.microsoft.com/v6/ClientWebService/client.asmx""

    This log line means that your client has good connection with Microsoft update site, but cannot indicate that the update is download from Microsoft site.

    We need to configure the GP  "Do not connect to any Windows Update Internet location" to force Client Windows update downloads from WSUS server, it worked fine on my computer with 14393.693 version.

    To confirm if the connection and downloading is OK, please check the IIS log file under this location on your WSUS server: C:\inetput\logs\logfiles\

    If the log appear that your client IP contact WSUS server as below, we consider they work well together. Please make sure your 8530 port is not blocked by the firewall.

    IP could be your client computer's IP.

    Please upload the whole windowsupdate.log onto Network share for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 24, 2017 7:17 AM
  • Hi Kate,

    thank you for your answer. I somehow got it managed.

    I reconfigured these 3 WSUS Options to "not configured":

    - Do not include drivers with Windows Updates
    - Select when Feature Updates are received
    - Select when Quality Updates are received

    Then i got a new error stating the "normal" 0x8024401C. No report or download possible.

    Then i did this:

    • Open the IIS Manager on the server, expand Sites, press on WSUS Administration site. Press on the Advanced Settings on the right. Expand Limits and in the field „Connection Time-out (seconds)“ instead of 180 put higher value, e.g. 320.
    • In the Application Pools window press on the WsusPool, then go to Advances Settings > and in the Recycling section change Private Memory Limit (KB) to 0 (means unlimited size).
    • Stop the IIS service (by pressing Stop in the IIS Manager, when you are on the SERVER (SERVER\administrator))
    • Run Notepad via Run as administrator and edit C:\Program Files\Update Services\WebServices\ClientWebService\web.config file replacing:

    <httpRuntime maxRequestLength="4096" />
    with
    <httpRuntime maxRequestLength="204800" executionTimeout="7200"/>
    Save the file overwriting the original (make sure it’s not of the txt extension).
    Start the IIS service.

    Big thanks to this blog: http://www.wroot.lt/wp/technology/wsus-woes-with-windows-10-en/

    Now the client reports to the WSUS Server and maybe would download something. I need to set up a fresh install because all clients got their updates from Windows Update online. So i can only see one request for flash.

    Sorry but this is not acceptable. With Windows 7 there were no problems at all and now you have to execute postinstalls and tweak the IIS settings so WSUS works.

    How about a hotfix (either Win10 to search faster or WSUS to react longer)



    Regards Stephan

    OneDrive / Sharepoint Blog

    Friday, February 24, 2017 7:25 AM