none
Windows 7 SP1 sleep issue RRS feed

  • Question

  • I installed windows 7 64 SP1 on tuesday 22 Feb 2011. after the install i have not been able to properly put my desktop into sleep mode. Prior to the SP1 install the desktop properly went into sleep mode and properly woke up. Now it will not wake up from sleep and i am forced to hit the power button to wake it up. when i do that i get the screen telling me that windows did not shut down properly. please help.

     

     

    Saturday, February 26, 2011 6:14 PM

Answers

  • ...hibernation does not work when you use a SCSIport miniport driver as the startup device driver [after installing Win7 SP1]
    http://support.microsoft.com/kb/2495523

    "I set 'Allow Hybrid Sleep' in Power Options/Advanced Settings to 'off' and the problem seems to be resolved." [Zestron]
    http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/cb5397b4-e312-4883-9963-a7271734991e


    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
    Saturday, March 5, 2011 6:13 PM
  • What is the model of the computer? I suggest you go to the download page of the computer and get the following drivers and firmware.

    BIOS
    Chipset driver
    Wireless adapter driver
    Video driver


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, March 1, 2011 8:41 AM
    Moderator

All replies

  • Check this KB article:

    Windows 7 does not go to sleep

    http://support.microsoft.com/kb/976877/en-us


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, February 26, 2011 8:57 PM
  • I am having the same issues. The article above does not describe the same problem.

    After installing Win 7 64 SP1, putting the computer to sleep has the same effect as turning off the power.

    Saturday, February 26, 2011 10:07 PM
  • I have exact same issue. Whenever Win 7 SP1 puts itself to sleep, it turns itself off altogether. On restart, indicates it did not shut down properly. Has anyone found a solution yet?
    Sunday, February 27, 2011 4:14 PM
  • check the event log for entries. And do you see dmp files in the folder C:\Windows\Minidump?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, February 27, 2011 5:14 PM
  • What is the model of the computer? I suggest you go to the download page of the computer and get the following drivers and firmware.

    BIOS
    Chipset driver
    Wireless adapter driver
    Video driver


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, March 1, 2011 8:41 AM
    Moderator
  • I've the same problem with a old 965P-DS3 MB. Prior to SP1 the sleep function with hybrid enabled worked perfectly. With SP1 it simply doesn;t shut down properly and needs a reboot to start. I rolled SP1 back out and every thing works perfectly again. Done a search and it appears there are many people with the same problem. Some have reported success by disabling hybrid sleep mode. Simply can;t be bothered to try reinstalling SP1 again to fine out if it does or down;t break my win7 installation. Not worth the effort of upgrading for little improvement but gaining something that I use all the time that no longer works.

     

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/sp1-disables-sleep-function/cb5397b4-e312-4883-9963-a7271734991e

     

     

    Best of luck.

    Friday, March 4, 2011 11:35 PM
  • ...hibernation does not work when you use a SCSIport miniport driver as the startup device driver [after installing Win7 SP1]
    http://support.microsoft.com/kb/2495523

    "I set 'Allow Hybrid Sleep' in Power Options/Advanced Settings to 'off' and the problem seems to be resolved." [Zestron]
    http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/cb5397b4-e312-4883-9963-a7271734991e


    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
    Saturday, March 5, 2011 6:13 PM
  • ditto what other have said. I do not use a SCSI miniport driver.

    I have the issue in Win7 Ultimate x64 on HP DC7600 - Default sleep settings did work perfectly.  No more. Seems to go to sleep peacefully enough, but will not awaken coherent - hard power cycle, resulting in errors is the only way to get up.

    Checking the System Event log shows nothing - no errors prior to the problem surfacing.

    Your only hope is to not use sleep.  Manually set all the power settings for discrete devices.

    I realize its "ungreen" but MS needs to awaken from hybrid sleep and address the issue.

    Friday, March 11, 2011 9:56 PM
  • I had this issue too on my machine after installing Windows 7 SP1 on my 64-bit machine, where it wouldn't come back from sleep.  I have a Gigabyte motherboard, and after updating the BIOS with their @BIOS util, it now recovers from sleep mode correctly.  Like most suggestions above, I'd try to update your BIOS and drivers for anything you have connected.  One other thing I did notice is that I once had LogMeIn on the machine, and even after uninstalling it, there was a "LogMeIn Mirror Driver" showing up in my Device Manager.  I uninstalled that at the same time I updated my BIOS, so it may also have been that.

    Good luck.

    Sunday, March 20, 2011 4:54 AM
  • Ditto with other users.

    Same issue...after installing SP1 yesterday, computer failed to wake properly. Worked perfectly for 10 months before upgrade.

    Everytime computer turned on after SP1 install, instead of 'waking' it was simply booting from scratch.

    I turned off "Allow Hybrid Sleep" and that patched the problem. It now wakes and sleeps again, just do not have the advantages of Hybrid mode.

    Looks like a bug Microsoft has to fix.

    Sunday, March 20, 2011 8:55 PM
  • I'd like to relay this same concern too. No problem prior to SP1, now I cannot sleep. Clicking the sleep button, doesn't allow me to return from it.

     

    I've checked my BIOS settings like suggested above, but I'm already fully updated, and have made no core changes or substantial changes since SP1. So I feel it is the cause

    I have the P6T Deluxe v2 motherboard.

    Thursday, April 7, 2011 2:52 AM
  • same problem here Gigabyte 965 board here. Win 7 Ultimate can't go to sleep or hibernate, both result in complete shutdown and the menu that asks me if I would like to boot into safe mode. Tried disabling / enabling S3/S1 in the BIOS , and disabling hybrid sleep, doesn't help.
    Wednesday, April 13, 2011 7:54 AM
  • Has anyone called?  This won't get fixed without someone calling and opening up a case.

     

    Thursday, April 14, 2011 7:26 AM
    Answerer
  • On my Dell XPS M1530 laptop running Win7 SP1 x64 this hotfix seems to have restored proper sleep functionality. It has only been two days, so I can't be sure.

    http://support.microsoft.com/kb/2519736: Stop error message in Windows Server 2008 R2 SP1 or in Windows 7 SP1: "STOP: 0x0000007F"



    Tuesday, May 3, 2011 8:20 PM
  • This Hot fix did not work for me.

    System: P5E, Q6600, Bios set for S3, Windows 7 HP 32bit, Hybrid Sleep=Disabled,

    I wakeup my computer from sleep using a USB infrared remote.  This was working until I loaded SP1 yesterday. 

    The Disks / Fans now spin up but the screen remains black. The system appears to be dead.  I have to perform a restart (reset button) to get it working again.

    I have now changed to use Hibernate and the system wakes up ok.  But sleep is very broken.

     




    Sunday, May 15, 2011 6:34 AM
  • None of the solutions in this thread worked for me.

    It turns out that for many users, the problem is actually a compatibility issue between Internet Explorer 9, and Skype versions 5+.

    FIXED

    Problem: After installing Windows 7 SP1, entering sleep/hibernate mode causes PC to hang for an extended period, and then bluescreen.

    I tried all of the following, and NOTHING worked:

    - Installed Win7 Hotfix KB2495523
    - Disabled "Allow hybrid sleep" in power options
    - Installed newest version of real-tek ethernet driver
    - Disabled "Allow Wake Timers" in power options
    - Set JavaScript Timer Frequency -> Maximum Power Savings in IE power options

    SOLUTION

    There are currently 2 solutions:

    1. Uninstall Skype v5, and roll back to version 4. (Version 4.2.0.187 confirmed working)

    or

    2. Uninstall Internet Explorer 9, and roll back to IE8. (Windows Update --> Installed Updates --> IE9, Uninstall)

     

    Skype Bug Report: https://jira.skype.com/browse/SCW-2796

    Monday, June 20, 2011 8:08 AM
  • NOTE:
    Another option is to simply close Skype before entering sleep mode.

    Confirmed: Reverting back to Skype version 5.0.0.156 fixes the issue. This is the newest version of Skype that does not lead to the crash when IE9 is installed.
    http://www.oldapps.com/skype.php
    Monday, June 20, 2011 7:09 PM