Missing desktop icons in Windows 8


  • Hi All,

    For some odd reason I seem to be missing only two of my desktop icons on my Windows 8 desktop. These are not system icons such as the recycle bin and computer ( I know you can enable them through Personalize ). The two icons I am missing are a folder and a powershell .ps1 file.

    The weird part is, any new file I add will appear, but these two will not even though they are indeed there. If I do a directory listing of my desktop I can clearly see the files, also I can see them when browsing to my user folder and clicking on Desktop.

    Anyone have any clue to why this is happening? I am thinking this may be some bug with RDPing to my machine from home. Seems like all of my icons were out of place this morning. Two of my icons were completely off-screen (close enough to where I could drag them back). The other two seem to be casualties..

    I have 3 monitors so when I RDP in my screen's all scrunch into one. This happened in Windows 7 as well but I never lost my icons.


    Thursday, September 13, 2012 8:24 PM


All replies

  • Well I probably answered my own question but if you just auto arrange your icons they will snap back into place.

    I did RDP back to my machine and they were way far off the screen.

    Thursday, September 13, 2012 8:29 PM
  • Windows 8 missing desktop icons SOLVED

    1.) Right click on the Desktop

    2.) Place mouse over the View option in the menu that appears

    3.) Select "Show Desktop Icons" to place a check mark next to it

    4.) Problem Solved.

    Sunday, June 23, 2013 6:06 PM
  • Thanks that worked like a charm :-)
    Thursday, July 04, 2013 6:47 PM
  • I have already tried all that stuff Right click on the desktop place mouse over the view option in the menu that appears Select Show Desktop Icons to place a check mark next to it Problem solved. It is not working for me at all.
    • Proposed as answer by Phoenix-22 Friday, October 10, 2014 4:33 AM
    • Unproposed as answer by Phoenix-22 Friday, October 10, 2014 4:33 AM
    Monday, July 08, 2013 8:30 AM
  • Hey there, thank you very much, this answer was simple, it was correct and more importantly it worked 100% correctly. I appreciate it.
    Sunday, July 14, 2013 9:31 PM
  • thanks very much it helps
    Saturday, July 27, 2013 4:31 PM
  • Thanks. That did it.
    Wednesday, August 14, 2013 4:10 PM
  • right click and view and the click on auto arrange. All icons should be back... this worked for me after my icons were missing soon after I connected an extended display.


    Saturday, December 14, 2013 9:24 PM
  • I just right clicked on the screen and I selected "Sort by" and I clicked on "date modified". and boom, all icons were back!
    • Proposed as answer by Phoenix-22 Friday, October 10, 2014 4:33 AM
    Tuesday, January 21, 2014 5:29 AM
  • Worked here also.  Thank you!!!!

    Chuck R.

    Monday, April 21, 2014 2:46 PM
  • thanks lot for ur help
    Sunday, August 10, 2014 3:06 PM
  • I had a similar experience. Mine happened after plugging the laptop to my tv but didnt realise that had happened. Like MosesVega said, right click the desktop - sort by - then click date modified.
    Friday, October 10, 2014 4:35 AM
  • Temporarily choose Duplicate Display then change back to single display and Icons may reappear on main display. (It worked for me.) The Show Desktop selection was already in place on my machine and toggling it does not fix this issue.

    The best fix would be on MS's end. Removing the extended display from my laptop inconsistently clobbers the Icon positions on the desktop.

    Since I park all my Icons on the main desktop (not on the extended display) there is no excuse for the OS to move the Icons to the extended display ESPECIALLY when the display is not present.

    Tuesday, December 23, 2014 5:31 PM