none
Vista business laptops wake themselves up from Hibernation RRS feed

  • Question

  •  

    Hi,

     

    I have two laptops, one of them is a Dell Vostro 1400 with Vista Business 32-bit, and the other one is a Lenovo T61 with Vista Business 64-bit with SP1.

     

    Recently, I have noticed that both computers will wake themselves up from hibernation at random time of the day. I thought that was because of wake-on-lan, however, I have the feature disabled on both laptops. When I checked the event logs on both laptops, they both have a Power-Troubleshooter log that says the system has resumed from sleep with an unknown wake source. Something more interesting is that the wake time in the log is sometime in the future! I ran a virus scan on both computers, and nothing was found. I also checked the task scheduler and made sure that nothing is scheduled to wake the computer up from sleep. Does anyone know the cause to this strange behavior?

     

    Thank you very much,

    Wednesday, March 5, 2008 1:58 AM

Answers

All replies

  • Hello,

     

    I think this issue may be a little complex. Let’s try the following steps firstly:

     

    1.    Go to DELL and Lenovo website and download the latest BIOS update. Refer to the manufacturer’s instructions and install them individually.

    2.    If the problem persists after updating BIOS, open Command Prompt as administrator, then type the following command line:

    powercfg –lastwake  (press Enter)

    Check if some more information is shown rather than unknown source.

    3.    Still in the Command Prompt window, type the following command-line:

    powercfg –devicequery wake_armed  (press Enter)

    The command will help you check which devices may wake the computer wake up.

    4.    In device manager, right-click the device listed in Step 3 and select Properties, switch to Power Management tab and clear the checkbox of Allow this device to wake the computer.

    If the problem is still there, please let me know if sleep mode, other than hibernate, is also involved in this issue?  

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Friday, March 7, 2008 3:03 AM
  •  

    Hi Lionel,

     

    Both of my laptops have the latest BIOS updates.

     

    My Lenovo laptop just woke up today at 6AM. So I tried powercfg from Command Promt and I got the following:

     

    C:\Windows\system32>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 0

    C:\Windows\system32>powercfg -devicequery wake_armed
    ThinkPad Modem
    High Definition Audio Controller

     

    This is what the event log Power-Troubleshooter says:

     

    The system has resumed from sleep.

    Sleep Time: 3/8/2008 8:09:01 AM

    Wake Time: 3/8/2008 2:10:09 PM

    Wake Source: Unknown

     

    Log Name: System

    Source: Power-Troubleshooter

    EventID: 1

    Level: Information

    User Local Service

    OpCode: Info

    Logged 3/8/2008 6:10:11 AM

    Task Category: None

    Keywords:

     

    The laptop wasn't connected to anything except for the AC power source. I don't know whether my laptop would wake up from sleep or not yet because it usually wakes up at 5-6AM, I will have to try sleep mode tonight. Sometimes it would wake up in the middle of the day though.

     

    Thank you very much.

    Saturday, March 8, 2008 7:14 PM
  •  

    This resolved my problem (without updating the Bios -though I think I have the most recent Bios version). It was very similar, except I do not have a wake-up loging program. Thank you Mr. Chen.
    Sunday, March 9, 2008 6:02 AM
  • Hello,

     

    According to your reply, the ThinkPad modern and audio controller are both playing the role as wake resource. You may try to disable them in Device Manager and test this issue again.

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Sunday, March 9, 2008 8:10 AM
  •  

    Hi Lionel,

     

    I disabled both the ThinkPad modem and the audio controller from waking my computer up.  However, my computer just woke up again.  Do you know any other reasons why this may happen?

     

    Thank you very much,

    Tuesday, March 18, 2008 2:59 AM
  • Hi wko,

     

    Give a try to clean boot your computer, let’s see if some 3rd party applications cause this strange behavior. You may refer to the following KB article:

     

    (KB929135) How to troubleshoot a problem by performing a clean boot in Windows Vista

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;929135

     

    Hope it helps!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Wednesday, March 19, 2008 9:42 AM
  • See also this thread:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2297868&SiteID=1

    My problem is still not fixed. The notebook is still randomly waking from hibernate by itself, even after a BIOS update, with wake-on-lan and wlan disabled, windows updates set to manual, powercfg -devicequery wake_armed only showing the 'Logitech Wheel Mouse (USB)' (which is not plugged in when the wake-up happens), open-notebook-lid-startup disabled, windows update switched to manual, and all unnecessary scheduled tasks removed/switched to manual.

    The information I get from the event log ("reactivation source unknown") and from powercfg -lastwake is not helping me at all. In my opinion, there are WAY too many causes that could wake up the notebook from hibernate, and no easy way to administrate them or even to find out what they are. A 'Disable all automatic wake-up from hibernate' switch would be very helpful. Could you add one?

    Thanks!

      Daniel Berger
    Friday, April 11, 2008 12:48 PM
  •  

    Hello

    I've had same problem, but I solved it yesterday. I've tried everything - latest BIOS,  "wake on" options disabled for all devices  and I have disabled Windows Update. No luck till yesterday  - I have found, that Windows Defender is waking up my laptop every day at 2. Check your Event log , you will find something like this :

    time 01:59:10

    The system has resumed from sleep.

    Wake Time: 00:58:54

    Wake Source: Unknown

     

    time 02:00:30

    Windows Defender signature version has been updated.

    Current Signature Version: 1.31.9205.0

    Previous Signature Version: 1.31.9142.0

     

    time 02:00:35

    Windows Defender scan has started.

     

    Solution: go to Control Panel->Windows Defender

    and then click Tools->Options

    uncheck "Automatically scan my computer"

    (on my was set to scan every day at 2)

     

    if have unchecked also

    "Use Windows Defender" (Bottom of page)

     

    Click Save Smile

     

    Good Luck

    pwgajda

    Tuesday, April 29, 2008 12:30 AM
  •  

    I did what you suggested, but my laptop is still waking up from hibernation.  I wonder if there is a super switch to turn off waking up from hiberation completely.
    Sunday, May 11, 2008 9:24 PM
  • I also have a problem with a new Toshiba (A300/009) doing the same things. It looked from the event log like it was to do with windows update.

     

    First try will be to disable all the hardware devices found with the powercfg program. When that is done i will move to defender and the windows update.

     

    Graeme

     

    Thursday, June 12, 2008 1:53 AM
  • Hi,

    I have similar problems only that in mz case the RTC (Realtime clock??) is involved and I do not know how to turn this off. Here is what the command line shows:

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\ioannis>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Fixed Feature
        Timer Expired (RTC)

    C:\Users\ioannis>powercfg -devicequery wake_armed


    C:\Users\ioannis>

    The wakeup times from sleep and hibernation seem to be quite random to me. Any suggestions how to deal with this kind of problem?

    Thank you, Jannis
    Friday, August 22, 2008 4:52 PM
  • I have the same problem on more than one pc. But I think a norrowed it down: my guess is, that it has something to do with Media Center, but I found no Task (and no BIOS setting, device, ...) that could explain the RTC wake up.

     

    Actually there is a "brutal" way to disable all wake events, I found that in two Microsoft sources:

     

    http://download.microsoft.com/download/0/0/b/00bba048-35e6-4e5b-a3dc-36da83cbb0d1/Optimize_Power.doc
    http://download.microsoft.com/download/a/f/d/afdfd50d-6eb9-425e-84e1-b4085a80e34e/SYS-T302_WH07.pptx

     

    Search the registry for bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d

     

    You find the "Allow wake on timer" settings for all powerplans. Replace (also in subfolders) the value 0x000000001 with 0x000000000. You could set it seperatly, you can see there are settings for AC / DC (battery).

     

    I am not very happy about this way, but it seems to work. Collateral damage: no wake up for recordings (MCE), no wake up for tasks,.. but on the other hand: no wake up of Laptops in the laptop case.

     

    Regards, Georg

    http://vistablog.at

     

    • Proposed as answer by ZedAlert Wednesday, March 16, 2011 6:50 AM
    Sunday, August 24, 2008 3:27 PM
  •  

    Thank you Georg! So far my laptop did not wake up anymore and the problems seems to be resolved.

     

    This is really anoying though, that there is no more convenient way to deactivate the wakeup events. After all, this is not what someone would expect from a laptop, to power up itself during strange times.

     

    @Microsoft, please do something to make this smoother.

     

    Thank you, Jannis

     

     

    Monday, September 1, 2008 4:05 AM
  • Georg, if this process works and turns off all the wake events, how do you actually wake the PC up from sleep (or hibernation I presume) when you want to use it ?????????????

     

    Regards

    Friday, September 26, 2008 11:38 PM
  • I have the same problem that you describe here. I have looked at the registry setting you indicate, but I have not been able to find "Allow wake on timer" setting you describe. Can you please provide detail instructions on how to turn off the RTC wake up.

     

    Thanks

     

    Thursday, October 23, 2008 1:52 PM
  • Actually there is no "Allow wake on timer"

    You just have to trust and change all entries under bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d fro 1 to 0.

    I did so, had the best of results.

    Regards,
    Monday, April 13, 2009 10:15 AM
  •  

    Hi,

     

    I have two laptops, one of them is a Dell Vostro 1400 with Vista Business 32-bit, and the other one is a Lenovo T61 with Vista Business 64-bit with SP1.

     

    Recently, I have noticed that both computers will wake themselves up from hibernation at random time of the day. I thought that was because of wake-on-lan, however, I have the feature disabled on both laptops. When I checked the event logs on both laptops, they both have a Power-Troubleshooter log that says the system has resumed from sleep with an unknown wake source. Something more interesting is that the wake time in the log is sometime in the future! I ran a virus scan on both computers, and nothing was found. I also checked the task scheduler and made sure that nothing is scheduled to wake the computer up from sleep. Does anyone know the cause to this strange behavior?

     

    Thank you very much,

    I know this was a year ago,  but for anyone who is having problems, i would check the Windows Automatic Update settings... Disable Automatically install updates, or at least set to a time that is not in the middle of the night....
    Solved my simple problem when hibernating, in the morning i would have a drained battery, and alert that windows was shutdown improperly, (losing battery)
    Wednesday, June 17, 2009 6:52 PM
  • I have the same problem with my HP/Compaq 8510W. Since I use Vista Business(Before Vista Enterprise).
    It's seems to depent on WLAN, because it does not awake spontanious when I disable the WLAN card in the Network connection panel.
    But disable WLAN every time I hibernate is not a verry good solution.
    Tuesday, September 8, 2009 6:56 PM
  • Thank you, this is what i was looking for two years of every night PC's wakeup. Now my PC is sleeping when i need to it, and can be waken from remote control.
    Thursday, March 17, 2011 9:59 AM