none
Windows 7 works perfectly except it will not sleep after inactivity timeout

    Question

  • Hi, can anyone help? I've installed W7 on a clean machine, and it now works perfectly. The only thing that my PC won't do is go to sleep after the inactivity timeout.  It will sleep, and stay asleep (network adaptor set to not wake PC) if, and only if, I send it to sleep. Otherwise it will run constantly.  Any clues how to solve this?

    Gigabyte GA-EP43-S3L
    Gigabyte Radeon 4650
    Corsair 4GB 800MHz
    Dell 2407WFP
    Microsoft keyboard & mouse
    Hauppauge WinTV HVR1300
    Friday, May 22, 2009 10:26 PM

Answers

  • Paul,

    The fact that you say you cannot get the screen saver to work either leads me to believe that this might be a different problem altogether. Are you, by chance, using any Microsoft-brand wireless input hardware (e.g. a mouse and keyboard)? If so, the drivers that install on Windows 7 by default will not allow the machine to display its screensaver or sleep properly.

    Refer to this Microsoft article , and see if there are any HID drivers available under "Optional Updates."
    -Alex
    • Marked as answer by paulkil Saturday, May 23, 2009 8:15 PM
    Saturday, May 23, 2009 7:13 PM

All replies

  • Paul -

    Two things...

    1.) There have been a lot of reports of various issues with sleep, hibernation and the like. It's an area that the dev team is, I'm sure, putting a lot of attention on.

    2.) One thing you CAN check - If you've got your system set to record something on that WinTV card, it's not going to sleep. There have been some posts on that as well.
    Friday, May 22, 2009 10:59 PM
  • I wonder if the system just needs some time to index files, and perhaps defrag.
    My system seems to be sleeping properly now after its been up and running for a few days now, and not initialy sleeping on its own.

    Update: I forgot that I made one system change as a test for the not sleeping on inactivity problem, and that was to "Leave the HomeGroup".
    I thought I read somewhere that a possible bug related to sharing media with HomeGroup could be a cause.
    I suppose I will have to now create the HomeGroup and see if the sleep problem comes back.
    First I need to continue testing that sleep is working now before turning HomeGroup back on.
    Note that I had some "file not found" problems related to leaving the HomeGroup. Granting myself access to the folder containing those files solved that problem. But I could be on the wrong track anyway as a possible source of sleep problems.

    Saturday, May 23, 2009 4:06 AM
  • There are definitely bugs to work out with the sleep function - I have dealt with some myself with my laptop. One thing I've noticed though is that some problems were specific to the Balanced power plan on my machine. I created my own plan by combining the High Performance and Power Saver plans and have not had further problems.    That might be one area where you might experiment.  I am assuming though that Microsoft must be working on this one - I can't believe they would repeat the problems with sleep, etc., that some Vista early adopters encountered....

    Stephen
     


    Saturday, May 23, 2009 6:01 AM
  • Seeing is believing.

    What's to see or believe? The last I checked this is still a RC that is a few months from RTM.  Perhaps one might want to keep that in mind and not imply that Microsoft has wronged anyone by making the RC (with flaws) available.  No one has paid for it and they still (very much) provide the standard disclaimers regarding the fact that it is a product under testing.  We are identifying issues to address - that is the point of this process.  Seeing and believing matter when this thing goes RTM....

    Stephen
    Saturday, May 23, 2009 7:04 AM
  • Proton & Wolfie2k6, thanks for your suggestions, you gave me hope! I've tried leaving the homegroup and starting my machine in safe mode with all non-MS services disabled; unfortunately this PC just will not sleep on its own.  I can't even get the screen saver to kick in. Any other suggestions?
    Saturday, May 23, 2009 5:24 PM
  • Swyost, I had numerous problems with my old PC freezing after resuming from sleep, but never has any issues with not sleeping.  I put it down to my hardware in the end which is why I'm trying a fresh start.  And I really like W7 - feels nippier and cleaner. If I could fix the sleep problem then I could even see myself handing over some hard cash to keep it!
    Saturday, May 23, 2009 5:27 PM
  • Stephen, you're the one who said he observed the same power management bugs that came with early Vista.


    Are you saying Microsoft wronged the public with Vista ?
    Please try reading my reply without a desire to agitate.  I stated that there are problems and I experienced some, I found a solution to my problem, suggested experimentation in that area without implying that would solve the OP's problem, stated that I assume Microsoft is working on the issue, and that I can't believe they would repeat the same mistake (with the same issue) that occurred a couple years ago with the RTM release of the previous OS.  I don't believe I suggested anyone wronged anyone - those would be your words and your implication. The use of the phrase "seeing is believing" before someone has been given a chance to address is also, typically, an expression of cynicism.  Mistakes happened with the release of Vista - enough said on that one since it was better than two years ago. In the present tense we are working with a RC and the goal is to identify this stuff so that it can get fixed. 

    BTW, as per my response in another thread, I will uncheck the alert me box on this one.  I don't see the point in engaging in a debate whem I believe the goal of the other part is to agitate.  It has been a long time since I was in grad school....

    Stephen
    Saturday, May 23, 2009 5:57 PM
  • Paul,

    The fact that you say you cannot get the screen saver to work either leads me to believe that this might be a different problem altogether. Are you, by chance, using any Microsoft-brand wireless input hardware (e.g. a mouse and keyboard)? If so, the drivers that install on Windows 7 by default will not allow the machine to display its screensaver or sleep properly.

    Refer to this Microsoft article , and see if there are any HID drivers available under "Optional Updates."
    -Alex
    • Marked as answer by paulkil Saturday, May 23, 2009 8:15 PM
    Saturday, May 23, 2009 7:13 PM
  • Axfelix - awesome advice. Downloaded the update and now my PC sleeps. Thanks!
    Saturday, May 23, 2009 8:18 PM
  • Hey Paul can you please tell me which update did you download for your issue as it is a very common issue that even I am having to deal with. Please..!!
    Wednesday, December 23, 2009 5:15 AM
  • Um, no sorry. I followed axfelix's advice and that fixed the problem. I've since installed the commerical release of Win7 x64 without any further problems so I conclude this issue is fixed. 
    Wednesday, December 23, 2009 9:41 AM
  • I am having the same issue on the production version of Win7 x64. Dell Latitude E6400 with nVidia Quatro NVS 160M video and 4 GB of RAM. Any fix, Microsoft?
    Wednesday, January 20, 2010 7:05 PM
  • Ive just encountered this problem and found my way here. hope im not too late.

    I tried all the suggested fixes and none worked, then i thought of jumper settings on the mobo. Turns out my mobo has usb power mode jumper settings to select either S1 or S3. They defaulted to S1.

    If anyone is still having this problem, check for mobo jumpers. Also try setting the bios power to S3 only instead of S1 or S1 and S3.

    Its a bit old, but if ive just encountered this so maybe there are more to come.

    Thanks.

    David Ranieri

    Thursday, January 20, 2011 5:35 AM
  • This problem, along with a non-functioning screen saver, was solved when I manually downloaded all available Windows 7 updates to my new computer.  The system then noticed that I have  Microsoft wireless keyboard and mouse, and, I assume, loaded the appropriate  drivers.  Now things are lovely. 

    Not sure why this stuff didn't download automatically, as I have every kind of automatic system update, including for drivers, activated.
    The computer has been in service for a week+ and lots of updates were installed, not sure why it took so long for these

    Tuesday, May 17, 2011 12:22 PM
  • Paul,

    I had the same issue - read a lot of forums and nothing. 

    I have a wireless Microsoft Mouse and Keyboard - Windows 7 installs default drivers and they work fine however it prevents the sleep mode.  Download the "Actuall" Drivers and install them.  It worked for me. 

    Make sure you install both mouse and keyboard drivers as mine were seperate.

    Take care

    Spec

    Wednesday, June 15, 2011 11:50 PM
  • I've had a very similar issue with Win7, after ~6 weeks of searching & trying different suggestions I found a solution.   I carefully browsed Windows Event Logs (Windows Logs, System) via Event Viewer.   Found the following entry:

    >>>  The driver WSDPrintDevice for device uuid:1c852a4d-b800-1f08-abcd-18a905084b5e\UMB\3&30394efd&3&uri:1c852a4d-b800-1f08-abcd-18a905084b5e stopped the power transition.

    Apparently this driver was installed incorrectly by Win7 when I plugged in a new HP printer.   I uninstalled the printer previously and ran HP's install, but apparently the uninstall does not uninstall this driver.   I looked in Device Manager and near the bottom of the device list I found WSDPrintDevice and uninstalled it.

    My PC has been sleeping/waking perfectly now for the past few days.

    Good Luck...

    • Proposed as answer by Kent Birder Friday, September 30, 2011 8:35 AM
    Tuesday, September 13, 2011 6:17 AM
  • I had a similar issue where the computer suddenly stopped being able to stay asleep.  On testing it manually instead of waiting for it to time out and go to sleep I noticed that it was staying asleep for only a few seconds.

     

    After trawling the forums I came across this post so I went to look for the event log (which I should probably have done earlier!) and found the following entry:

     

    Wake Source: Device -Intel(R) 82566DC Gigabit Network Connection

     

    For some reason after working properly for goodness knows how long it seems th enetwork connection was waking up the puter as soon as it went to sleep.  I have no idea how this happened and can onluy assume it was something to do with a recent windows update.

    Still... all seems ok now so many thanks for the heads up.

    • Proposed as answer by Kent Birder Friday, September 30, 2011 8:34 AM
    Friday, September 30, 2011 8:34 AM
  • I have the same problem and found it is caused by my wireless mouse. If I unplug the wireless mouse from the USB port the problem goes away,
    Wednesday, October 26, 2011 8:26 PM