none
wifi constantly drop

    Question

  • I have broadcom 802.11 ac network adapter with window 8.1 64 bits. And my internet very usually drop so i think there is problem about compatibility between the router and the wifi driver. So how can i config my driver so solve this problem. And pls, microsoft support, dont tell me to troubleshot or update driver or something about not turn off driver to save energy. I did, i have done all of it and i know the problem must b solved only by do something in the advance setting of the driver. So pls someone from microsoft work on it, so many other people have the same problem. WE PAY MONEY NOT TO GET FRUSTRATED. 
    Friday, December 27, 2013 3:49 AM

Answers

  • Hi

    based on screenshot, error DNS event id 1014

    https://social.technet.microsoft.com/wiki/contents/articles/3336.event-id-1014-microsoft-windows-dns-client.aspx

    possibility cause of this issue:

      -  TCP/IP Offload is enabled for a network adapter
      -  TCP/IP v6 is enabled and their ISP does not yet support TCP/IP v6.
      -  The spanning tree “portfast" setting is not enabled on your servers switch ports.
      -  Router and PC communicating on different channel or standard.

    How to fix this:


    Method one: Disable RSS, Autotuning, and Taskoffload
    1.   Run the following command in an elevated command prompt in Windows 7:

     
    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     
    2.  Disable the Scalable Networking Pack (SNP) in Windows 7 by changing the registry settings as follows:

    Perform a full-system backup before you disable the SNP.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

    EnableTCPChimney=dword:00000000
    EnableTCPA=dword:00000000
    EnableRSS=dword:00000000
     
    If the registry keys do not exist, create them, and then assign the previous values.

    Method two : Disable TCP/IP v6
    To disable TCP/IP v6
    1.  Click Start, click Control Panel, click Network and Internet, and then click
    View network status and tasks.

    2.  In the left pane, click Manage Network Connections.

    3.  Right-click Local Area Connection, and then click Properties.

    4.  In the pop-up box, clear the Internet Protocol Version 6 (TCP/IPv6) check box.

    5.  Click OK, and then restart your computer.

     To enable TCP/IP v6

    1.  Follow steps 1 through 3 in the previous procedure.

    2.  In the pop-up box, select the Internet Protocol Version 6 (TCP/IPv6) check box.

    3.  Click OK, and then restart your computer.

    Method three: Enable the spanning tree portfast setting in your router
    This action varies depending on your infrastructure router. Consult your manufacturer for further details.

    Method four: Set you router and PC to communicate on same channel and standard manualy
    1. Go to your router admin page which should be 192.168.1.1 (confirm with router manufacturer).

    2. Navigate to WiFi settings and choose a channel which should comply with your location, for ex: 11. Save.

    3. Choose Standard to broadcast WiFi signal as G only not abgn, bgn, gn (If your router is N capable and any PC in your home/office is only G ready). Save.

    4. Go to your PC Network and Sharing Center (Windows 7) and Click on Change Adapter Settings, select you WiFi adapter, right click and choose Properties.

    5. In pop up window select Configure, in next window click on Advance tab and browse settings there and choose same channel you choose in you router for ex: 11 and the same standard as G not abgn, bgn or gn. Save and Exit.

    Hope it will fix after you do step above, I very understand your frustration.

    Thursday, January 2, 2014 6:34 AM
  • Hi

    Yes you can try apply this to Windows 8, as per suggestion backup your registry before changing value.

    If the registry keys do not exist, create them, and then assign the previous values

    Change channel depend on your router setting, you can check at your router website or contact them

    Thursday, January 2, 2014 8:57 AM

All replies

  • NT

    The problem is local to your machine.  There is nothing to "work on it"

    To enable us to help you better, you need to provide as many details as you can about the problem you are experiencing.

    If you design your question effectively, you can get good information from people who are knowledgeable about the topic and who are happy to help you.

    Prepare your question. Think it through. Hasty-sounding questions get hasty answers, or none at all.

    What troubleshooting have you done so far?


    Wanikiya and Dyami--Team Zigzag

    Friday, December 27, 2013 4:02 AM
    Moderator
  • Please provide information that Zigzag questioning and request, also your PC or laptop specification
    • Edited by britishdhez Friday, December 27, 2013 4:34 AM
    Friday, December 27, 2013 4:34 AM
  • this is information about my asus g750 jw:

    Windows 8.1 ‎(X64)‎

    Intel Core i3/i5/i7 4xxx clocked at 2.40 GHz

    ASUSTeK COMPUTER INC. G750JW 1.08 GB total memory type DDR3

    NVIDIA GeForce GTX 765M Sr about my words but u must know that this problem is so frequent and happen for a long time but there still no solution. MS developer, they like ignore us. 

    Friday, December 27, 2013 6:51 AM
  • this is the problem: its like there is still the signal strength but the internet stop working. I cant load a website or while i playing game i get disconnected from the game. It happen every 5 or 10 minutes and last for 10 or 15 seconds sometimes 1 min.
    Friday, December 27, 2013 6:52 AM
  • is there any solution for this yet. Can something like downgrade to window 7 help? I will do everything can do to solve this. I bought this gaming laptop right before the break with the only thought of gaming every day and now i am googling the whole break :(((
    Friday, December 27, 2013 9:21 PM
  • NT

    Yet?  It hasn't even been a single day and you have given us no information.

    Please provide us with your Event Viewer administrative logs by following these steps:


    Click Start Menu
    Type eventvwr into Search programs and files (do not hit enter)
    Right click eventvwr.exe and click Run as administrator
    Expand Custom Views
    Click Administrative Events
    Right click Administrative Events
    Save all Events in Custom View As...
    Save them in a folder where you will remember which folder and save as Errors.evtx
    Go to where you saved Errors.evtx
    Right click Errors.evtx -> send to -> compressed (zipped) folder
    Upload the .zip file to skydrive or a file sharing service and put a link to it in your next post


    Wanikiya and Dyami--Team Zigzag

    Friday, December 27, 2013 10:47 PM
    Moderator
  • when i open the Administrative Events, it says that ' the system cannot find the file specified' and when i tried to save all events in custom view as .... it says the same thing again and i cannot save it
    Saturday, December 28, 2013 3:27 AM
  • There is a part also in Custom Views is '' broadcom 802.11 ac network adapter'' and I can save this. I dont know if you needed it then i just let you know
    Saturday, December 28, 2013 3:30 AM
  • i can save the event in Administrative Event by click to the event and choose : Save selected event. And here is the link, there are 4 of them ( because it allow 256 files at once) and i zip them in one folder. here is the link:

    mediafire .com /download/q4pjxp9nr2r7gg2/Errors.zip ( there are spaces between mediafire and .com and download because i cant upload a link)

    Saturday, December 28, 2013 4:15 AM
  • NT

    This is a known problem on some systems that were updated from win 8>>>>win 8.1

    There is a registry fix.

    *

    Press Win+r and input regedit
    Navigate to:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels] Delete "Microsoft-Windows-DxpTaskRingtone/Analytic" Back it up just in case something goes wrong. Open Local Services. Go search settings if you don't know where that is. You need to restart "Windows Event Log".

    *

    Verify your account to upload a link or replace the http with hxxp

    If you are being told you cant post a link, or embed a picture (or any other restriction) you just need to post to this thread saying your account has not been validated


    Wanikiya and Dyami--Team Zigzag


    Saturday, December 28, 2013 5:22 AM
    Moderator
  • here is the link: https://www.mediafire.com/?w88580lrkcsq4nf
    Sunday, December 29, 2013 1:07 AM
  • is the any trace of which cause this ?
    Monday, December 30, 2013 4:59 AM
  • Hi,

    Have you tried to update your router's firmware?

    Please test the issue in Safe mode with networking, and let me know the results. 

    If there is any 3rd part security app installed, please temporarily remove it to check the results.

    Also, let's disable IPv6 to check the issue.

    In further, if the driver is not compatible well with Windows 8.1, we can try to install the older version in Windows 8.1 compatible mode to see what's going on.

    Let me know if there is any update on your issue.


    Kate Li
    TechNet Community Support

    Monday, December 30, 2013 3:31 PM
    Owner
  • i even bought a newest router recently and i did disable the IPv6. And i think there is no older version of this driver at this time. I ll try safe mode with networking
    Monday, December 30, 2013 3:44 PM
  • i just try and it doesnt help. Btw, can you tell me how can i exit safe mode with networking ?
    Monday, December 30, 2013 4:32 PM
  • NT

    It is a DHCP/DNS issue.  The server you are using for DNS is not responding in time and the wifi drops out. There a re literally hundreds of these errors

    I suspect you are using Google's open DNS and it is timing out because you are in Vietnam.


    Wanikiya and Dyami--Team Zigzag

    Monday, December 30, 2013 9:12 PM
    Moderator
  • im in Troy, MI, US. I tried to use both DNS of google and no DNS and it makes no difference.
    Monday, December 30, 2013 10:04 PM
  • NT

    I only mentioned Vietnam because there are dozens of Vietnamese sites in the event viewer logs.  My apologies but the problem remains the same.  It is a DNS/DHCP problem. 


    Wanikiya and Dyami--Team Zigzag

    Monday, December 30, 2013 11:00 PM
    Moderator
  • Its ok nothing offensive here when you think im in vietnam I just want to tell you. So how can i fix this problem ?
    Monday, December 30, 2013 11:02 PM
  • NT

    I would contact your ISP to find what DNS/DHCP settings they recommend.


    Wanikiya and Dyami--Team Zigzag

    Tuesday, December 31, 2013 12:02 AM
    Moderator
  • Oh thank you so so so so much.

    I also did contact them but they say i should buy a new modem and i did but no thing changes. If this time you can find out what setting should i set, that would be the greatest thing a person can do for me now.

    Tuesday, December 31, 2013 12:18 AM
  • NT

    Its probably not the modem.  What are you using for DHCP & DNS.  Does your ISP recommend you use their servers or others?


    Wanikiya and Dyami--Team Zigzag

    Tuesday, December 31, 2013 1:25 AM
    Moderator
  • they did not recommend me anything, they said they did not know what is wrong and i should properly buy new modem. My DNS setting for the ipv4 is '' obtain DNS server address automatically'' and i dont know what is DHCP and where can i find it.
    Tuesday, December 31, 2013 1:39 AM
  • Have you had any news from my ISP ? I saw that there are others who have the same issue and your team did tell them to send event log. Do they got the same cause with me ?
    Tuesday, December 31, 2013 9:26 PM
  • Hi

    based on screenshot, error DNS event id 1014

    https://social.technet.microsoft.com/wiki/contents/articles/3336.event-id-1014-microsoft-windows-dns-client.aspx

    possibility cause of this issue:

      -  TCP/IP Offload is enabled for a network adapter
      -  TCP/IP v6 is enabled and their ISP does not yet support TCP/IP v6.
      -  The spanning tree “portfast" setting is not enabled on your servers switch ports.
      -  Router and PC communicating on different channel or standard.

    How to fix this:


    Method one: Disable RSS, Autotuning, and Taskoffload
    1.   Run the following command in an elevated command prompt in Windows 7:

     
    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     
    2.  Disable the Scalable Networking Pack (SNP) in Windows 7 by changing the registry settings as follows:

    Perform a full-system backup before you disable the SNP.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

    EnableTCPChimney=dword:00000000
    EnableTCPA=dword:00000000
    EnableRSS=dword:00000000
     
    If the registry keys do not exist, create them, and then assign the previous values.

    Method two : Disable TCP/IP v6
    To disable TCP/IP v6
    1.  Click Start, click Control Panel, click Network and Internet, and then click
    View network status and tasks.

    2.  In the left pane, click Manage Network Connections.

    3.  Right-click Local Area Connection, and then click Properties.

    4.  In the pop-up box, clear the Internet Protocol Version 6 (TCP/IPv6) check box.

    5.  Click OK, and then restart your computer.

     To enable TCP/IP v6

    1.  Follow steps 1 through 3 in the previous procedure.

    2.  In the pop-up box, select the Internet Protocol Version 6 (TCP/IPv6) check box.

    3.  Click OK, and then restart your computer.

    Method three: Enable the spanning tree portfast setting in your router
    This action varies depending on your infrastructure router. Consult your manufacturer for further details.

    Method four: Set you router and PC to communicate on same channel and standard manualy
    1. Go to your router admin page which should be 192.168.1.1 (confirm with router manufacturer).

    2. Navigate to WiFi settings and choose a channel which should comply with your location, for ex: 11. Save.

    3. Choose Standard to broadcast WiFi signal as G only not abgn, bgn, gn (If your router is N capable and any PC in your home/office is only G ready). Save.

    4. Go to your PC Network and Sharing Center (Windows 7) and Click on Change Adapter Settings, select you WiFi adapter, right click and choose Properties.

    5. In pop up window select Configure, in next window click on Advance tab and browse settings there and choose same channel you choose in you router for ex: 11 and the same standard as G not abgn, bgn or gn. Save and Exit.

    Hope it will fix after you do step above, I very understand your frustration.

    Thursday, January 2, 2014 6:34 AM
  • i got window 8. Can i apply these fix to my laptop?
    Thursday, January 2, 2014 6:53 AM
  • and where can i change channel and standard in the Advance tab o adapter setting ?
    Thursday, January 2, 2014 7:04 AM
  • and in the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

    i creat a subkey or a dword value?

    If its dword value so i creat 3 value named EnableTCPChimney, EnableTCPA and EnableRSS ?

    Thursday, January 2, 2014 7:11 AM
  • Hi

    Yes you can try apply this to Windows 8, as per suggestion backup your registry before changing value.

    If the registry keys do not exist, create them, and then assign the previous values

    Change channel depend on your router setting, you can check at your router website or contact them

    Thursday, January 2, 2014 8:57 AM