none
FTP via Windows Explorer

    Question

  • on Windows 7 64-bit system:

    I can ftp using Intenet Browser all day long.

    If I use Windows Explorer for FTP it opens it in Internet Browser.

    If I try to FTP via Mapped Drive (Add Network Location) it gives me an error: The folder you entered does not appear to be valid. Please choose another.

     

    on Windows 7 32-bit system it works both ways.

    Any ideas why it doesn't work in 64-bit?

    Friday, October 28, 2011 6:10 PM

All replies

  • That is weird. I just tried it on my Windows 7 64 bit system and it works find.

    How do you type in the hostname? I do it like this: ftp://host.com

     

     

    Friday, October 28, 2011 6:52 PM
  • ftp://ftp.host.com or ftp.host.com

     

    Either way it opens IE9

    Friday, October 28, 2011 6:54 PM
  • I've just tried it by typing

    ftp://ftp.nameofthehost.com

    both in Windows Explorer and Internet Explorer 9 (both the 32 bit version and the 64 bit version): everything is working fine.
    I'm currently running Windows 7 Ultimate x64 SP1.

    Bye.


    Luigi Bruno - Microsoft Community Contributor 2011 Award
    Friday, October 28, 2011 9:59 PM
    Moderator
  • I know. I have tried it on other systems and it works but not on mine.

     

    What could be redirecting FTP to the browser instead of it working in Windows Explorer?

     

    I am stumped.

    Friday, October 28, 2011 10:07 PM
  • Hi,

     

    This is odd issue, in order to further research this problem, please use Network monitor to capture the network package on both these computers:

     

                  1) Download NetMon3.4 from the following website and install it on the Windows 7 64bit based computer.

                  http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

                  2) Launch NetMon3.4 on the machine.

                  3) In the Microsoft Network Monitor 3.4 window, click Create a new capture tab …

                  4) In the new tab, select all the Network Adapters in the Select Networks window.

                  5) Then, switch to Network Monitor, press F5 to start NetMon.

                  6) Map a network drive for this FTP folder

                  7) Go back to the NetMon window and press F7 to stop the NetMon.

                  8) Press Ctrl+S to save the Netmon file named test. Repro the steps above, access the folder use the shortcut and produce another log file.

                  9)Repeat the actions above on the Windows 7 32bit based computer.

                  10) Upload the files via SkyDrive ,and post a link here.     

     

    I would assist you to analyze these log, and post the result here.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, November 07, 2011 2:26 AM
  • The same thing is happening on my W7. It used to be fine and the behaviour just changed recently. Entering ftp.nameofhost.com in Windows Explorer used to open the ftp directory in WE. Now it redirects to my default browser (Firefox). I've no idea what has triggered this new behaviour, but I'd really like to be able to open ftp sites in WE again.
    Monday, November 28, 2011 9:22 PM
  • did you try resetting your IE settings to default

    http://support.microsoft.com/kb/323446

     

    How to change the Internet Explorer FTP Client mode

    1. Start Internet Explorer.
    2. On the Tools menu, click Internet Options.
    3. Click the Advanced tab.
    4. Under Browsing, click to clear the Enable folder view for FTP sites check box.
    5. Click to select the Use Passive FTP (for firewall and DSL modem compatibility) check box.
    6. Click OK.

    Internet Explorer behaves as a Standard mode FTP client if you select the Enable folder view for FTP sites check box, even if you also select the Use Passive FTP check box. If you clear the Enable folder view for FTP sites check box and then select the Use Passive FTP check box, Internet Explorer behaves as a Passive mode FTP client.

    Monday, November 28, 2011 11:05 PM
  • I have reset my IE settings. I have restored the advanced settings.

    Still uses IE for FTP.

    Doesn't matter if either one or both are unchecked.

    Monday, November 28, 2011 11:23 PM
  • Same problem here - Windows 7 64-bit Ultimate!
    theWeissGuy
    Tuesday, November 29, 2011 12:09 AM
  •  

    I think you are having issues with firewall.

    You need to enable firewall rule for ftp. (port 20, 21)

    What's probably happening is that your firewall is blocking default ftp ports and as result you are being redirected to the IE as ftp client.

     

    check this link out

    http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/this-ftp-site-cannot-be-viewed-in-windows-explorer/e699d41e-98ae-48c1-9231-d570d46c0f38

    They said that this is a fix for it.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ftp]
    @="URL:File Transfer Protocol"
    "AppUserModelID"="Microsoft.InternetExplorer.Default"
    "EditFlags"=dword:00000002
    "FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
    "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\ftp\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
    6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

    [HKEY_CLASSES_ROOT\ftp\shell]
    @="open"

    [HKEY_CLASSES_ROOT\ftp\shell\open]

    Tuesday, November 29, 2011 5:54 AM
  • I have the exact same problem! I'm running Windows 7 SP1 64-bit and when trying to access an ftp site using Explorer so I can upload a document I get the same error. The frustrating part is my co-worker is able to do this with out any problems on his computer.

    Monday, February 03, 2014 11:42 PM
  • I'm experiencing the exact problem I am currently running Windows 7 SP1 64-bit and my co-worker is not having a problem mapping the same site.  We have proven that this is a local problem to my computer and it is exactly the same as what you are describing.  I've enabled the settings for FTP in Internet Explorer and in the Fire Wall settings and still can't map the FTP site that I need to upload documents.  When using Internet Explorer I can access the FTP site and view files, but need to upload using Explorer.

    Do any of you have any ideas on how to make this work???

    Tuesday, February 04, 2014 4:00 PM
  • I also have IE11 installed, but not sure if that makes a difference.
    Tuesday, February 04, 2014 4:02 PM