none
KB4517211 - Edge app reset notification for new users in win 10 1903 RRS feed

  • Question

  • Hello,

    we are testing Win 10 1903 and use the 1903 iso from the vlsc. 

    Everything is working fine but if we install KB4517211 we get a lot of app reset notifications from the Microsoft Edge.

    This only happens for users that log on the first time on this device (after installing this KB). For existing users this app reset notification is not displayed.

    If we uninstall this KB the app reset notification is not displayed anymore for users that login the first time on this device.

    Is this a know bug in the KB4517211?

    Wednesday, October 2, 2019 10:03 AM

All replies

  • There is not official statement mentioned this app reset notification situation.

    Please feedback this situation to Microsoft via Feedback Hub app, I am also going to submit this case, let’s wait for update and keep monitoring

    Regards

      


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 3, 2019 7:02 AM
    Moderator
  • Hi,

    i will feedback this microsoft via feedback hub.

    It looks like that this problem occurs only with an unattended installation.

    We use the original vlsc 1903 iso and did a unattended installation with a AutoUnattend.xml. After that installation we install the update 4517211 in the base image and run sysprep. Then we make a image (wim) and restore this image. Then we get for all new users the edge app reset notification.

    I run the dism /export /defaultappassociations and dism /import command to import the correct settings to to wim file an i also run the command after the unattended installation into the base image. Same problem.

    I dont know what to do. I hope someone can replicate this problem because its very annoying.

    Greeting

    EDIT:

    if i run a dism /online /get-defaultappassociations on the image with the update 4517211 installed, these 3 lines are new:

      <Association Identifier="microsoft-edge" ProgId="AppX7rm9drdg8sk7vqndwj3sdjw11x96jc0y" ApplicationName="Microsoft Edge" />
      <Association Identifier="microsoft-edge-holographic" ProgId="AppX3xxs313wwkfjhythsb8q46xdsq8d2cvv" ApplicationName="Microsoft Edge" />
      <Association Identifier="MS-XBL-3D8B930F" ProgId="AppXdn5b0j699ka5fqvrr3pgjad0evqarm6d" ApplicationName="Microsoft Edge" />

    This lines are not included in the get-defaultappassociations on the image without the update 4517211.

    EDIT2: it looks like here is the same problem: https://social.technet.microsoft.com/Forums/en-US/dec0ff68-360d-44a1-963d-fff23cff84fa/twinui-app-reset-to-default-browser-set-to-default?forum=win10itprosetup and here https://social.technet.microsoft.com/Forums/en-US/fe3d027c-de98-4ce3-aa4a-48452dd4d8cd/filetypes-being-reset-to-edge-on-user-logon?forum=win10itprosetup




    • Edited by skt-tec Tuesday, October 8, 2019 7:26 AM
    Monday, October 7, 2019 6:22 AM
  • If you are using copyprofile in your unattend configuration, remove these two registry keys from the default user account.

    DEFAULTUSER\Software\Microsoft\Windows\CurrentVersion\FileAssociations

    DEFAULTUSER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    I have determined that when CopyProfile is used in 1903 with latest updates, despite the the default app associations procedure, it would produce app reset notices after sysprep. 

    If you continue to have random app reset notices (TWINUI, .epub, .htm, .etc), check that you are importing a recent app association file, this has changed and includes a few more Edge type extensions. Also, if your default profile includes , %systemdrive%\users\Default\AppData\Local\Microsoft\Windows\UsrClass.dat - this registry file may produce app reset notices too. 


    • Proposed as answer by MilanD3 Friday, October 11, 2019 5:32 PM
    Friday, October 11, 2019 3:32 PM
  • I’m not using copy profile and I still have this issue. I’m using an xml from earlier this year that does not have the additional edge types included.
    Sunday, October 13, 2019 3:28 AM
  • I'm fairly certain you will need the new app associations no matter if you are creating a new base image or upgrading to 1903 from an earlier version. You can copy the new app associations from \windows\system32\oemdefaultassociations.xml before importing anew. Then manually include them in your own default association list.

    Here are the app associations that I pulled and that work for me:

      <Association Identifier="microsoft-edge" ProgId="AppX7rm9drdg8sk7vqndwj3sdjw11x96jc0y" ApplicationName="Microsoft Edge" ApplyOnUpgrade="true"/>
      <Association Identifier="microsoft-edge-holographic" ProgId="AppX3xxs313wwkfjhythsb8q46xdsq8d2cvv" ApplicationName="Microsoft Edge" ApplyOnUpgrade="true"/>
      <Association Identifier="ms-xbl-3d8b930f" ProgId="AppXdn5b0j699ka5fqvrr3pgjad0evqarm6d" ApplicationName="Microsoft Edge" ApplyOnUpgrade="true"/>

    I've seen this problem twice:

    1. When capturing a base image of 1903 with copyprofile via unattended answer file.

    2. When upgrading to 1903 from 1809 (and possibly earlier versions). New user account shows app reset notice. 

    My initial finding for the #2 fix is not working as expected after a second attempt. I'm still trying to determine how this can be fixed or avoided. 



    • Edited by MilanD3 Friday, October 25, 2019 6:38 PM corrected response
    Friday, October 25, 2019 4:54 PM
  • I am having the same issue. Milan I tried your fixes and they are not working for me. Even when I do not use copy profile functionality, I still get notifications but down to about 4. Are you making the registry changes before sysprep. Any additional information on your fixes would help. I hope Microsoft resolve this bug soon. 
    Monday, October 28, 2019 10:15 PM