Desktop icons slow to display


  • I have Win7 (64-Bit) and lately the desktop icons are slow to display. They start with white boxes and then slowly they fill-in with the correct icon.

    I tried the following, and now the icons show right away, but then the screen blinks (for lact of a better word) and the icons show 'white' and then in a second or two they return to the regular (colored) icons.  Anything else I can do to make the icons appear as fast as they did orginally and stay that way rather than turning "white" and then changing back to the regular colored icons?

    Hope it wasn't caused by installing MSE (removed AVG which was acting up).

    Thank you.

    P.S. I am not receiving emai notifications when someone adds reply. Do I hae to check something? I do not see an Advise button.


    1. Close all folder windows that are currently open.

    2. Launch Task Manager using the CTRL+SHIFT+ESC key sequence, or by running taskmgr.exe.

    3. In the Process tab, right-click on the Explorer.exe process and select End Process.

    4. Click the End process button when asked for confirmation.

    5. From the File menu of Task Manager, select New Task (Run…)

    6. Type CMD.EXE, and click OK

    7. In the Command Prompt window, type the commands one by one and press ENTER after each command:

    CD /d %userprofile%\AppData\Local
    DEL IconCache.db /a
    8. In Task Manager, click File, select New Task (Run…)

    9. Type EXPLORER.EXE, and click OK.


    • Edited by AliceZ Sunday, October 23, 2011 11:33 PM add
    Sunday, October 23, 2011 4:04 AM

All replies

  • Hi Alice,


    Probably its nothing much to worry about. You might have installed some application which is starting at startup and that might make the icon repainting a bit slow. Check your startup applications by running msconfig. Uncheck anything that you don't want to run, and then check the result.

    Sunday, October 23, 2011 6:02 AM
  • My original message was Edited. Does your answer still remain the same?
    Sunday, October 23, 2011 4:41 PM
  • For me , this began to occur after installing SP1 for Windows 7.
    Sunday, October 23, 2011 5:24 PM
  • I already put this question in other forums:

    "Why the shortcuts on desktop may be repainted at startup of Win 7? At boot or startup of Windows 7, all of my shortcuts appear correct on the desktop, but after a few seconds they will change to white pages, and are then repainted with their original design. This is a visual annoyance. It is possible to avoid this 'repaint'?"

    The problem has nothing to do with the IconCache.db rebuild or resize.
    After a little work with the Windows 7 services the result is as follows:
    If you do not use the Home Group you can disable the following services (after saving: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services):
    Go to: System Services (services.msc);
    search for: Computer Browser and DISABLE it;
    search: Server and DISABLE it.

    That's All folks!

    Saturday, September 06, 2014 2:26 AM