none
Can't access win xp share folders from win 7

    Question

  • Hi

    i have win 7 ultimate.

    my problem is that i can't access share folders which exists in another machine with win xp sp2.

    in the win xp client, i've turn off firewall and disable network filter from it's anti virus (it have norton)

    Note : i can ping the client and also use internet sharing, but only i can't access share folders.

    can anybody help me which how to solve my problem ?

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Sunday, July 17, 2011 8:07 AM

All replies

  • Is that a purely AV or a internet security when you mention norton product? If is the latter then Norton would prevent one from accessing it's network, either you uninstall it for the time being or configure it to allow the network to pass through
    Sunday, July 17, 2011 9:05 AM
    Answerer
  • Hi

    i don't have other security apps in win xp machine. before this, i could access to shared files.

    configure it to allow the network to pass through

    how can i do this ?


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Sunday, July 17, 2011 11:25 AM
  • بسم الله الرحمن الرحيم

     

    try disable AV just one min and try access your share folders if it was opend we will fix the problem from AV configure

    if the same problem still we try anothe this

    check it please


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    Sunday, July 17, 2011 11:56 AM
  • بسم الله الرحمن الرحيم

     

    try disable AV just one min and try access your share folders if it was opend we will fix the problem from AV configure

    if the same problem still we try anothe this

    check it please


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.

    Hi

    i've turned off my norton anti virus realTime protection on win xp machine and then try to access shared files, but i'm facing the same problem.


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Sunday, July 17, 2011 10:35 PM
  • If the Windows XP machine shares out the file without a user ID/password requirement (i.e. simple file sharing), you will need to turn off password sharing on the Vista/7 machine:

     

    To turn off Password Protected Sharing:
    ===============

    1. Click Start, enter "Network and Sharing Center" in the Start Search box .
    2. Click "Change advanced sharing settings" in the left pane.
    3. Make sure that "Password protected sharing" is turned off.

     


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Sunday, July 17, 2011 11:54 PM
  • بسم الله الرحمن الرحيم

    this clients in domain environment or work group


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    Monday, July 18, 2011 7:14 AM
  • Hi again

    There is a problem!

    i think the problem is related to my win 7 machine (not win xp machine), because today i can access win 7 shared files from my laptop but i can't access to my laptop shared files. i think the problem is inside in my win 7 machine. also in my laptop i have win 7

    i have a workgroup.


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Monday, July 18, 2011 6:48 PM
  • بسم الله الرحمن الرحيم

    try this on win 7 :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    the parameter was Size - and value was set at 1. I changed the value to 3.

     

    http://windows7forums.com/windows-7-networking/14569-i-cant-access-shared-folder-2.html

     


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    Monday, July 18, 2011 7:20 PM
  • بسم الله الرحمن الرحيم

    try this on win 7 :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    the parameter was Size - and value was set at 1. I changed the value to 3.

     

    http://windows7forums.com/windows-7-networking/14569-i-cant-access-shared-folder-2.html

     


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.

    Thanks

    i've tried your advice, but my problem was not solved. 


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Monday, July 18, 2011 9:03 PM
  • Dear Hamed_1983, what version of Windows XP do you have? Home or Pro?
    If Pro, go to Start > Control Panel > Administrative Tools >  Local Security Policy
    Expand the Local Policies Tree and Select the Security Options. Find the option Network access: Sharing and security model for local accounts and double-click on the policy. Select Guest Only so that other people can access your files.

    Also, on Windows XP Pro, search for Network Security: LAN Manager authentication level, double-click to open the properties and select Send LM & NTLM - Use NTLMv2 session security if negotiated or send LM & NTLM Responses.  Also, make sure the 128-Bit Encryption is disabled in the security policy as well. The two security policies that use the 128-bit encryption option are: Network Security: Minimum session key for NTLM SSP based (inclu. Secure RPC) clients and Network Security: Minimum session key for NTLM SSP based (inclu. Secure RPC) servers and uncheck the Require 128-Bit Encryption and click OK. Then, restart your computer. Do the same for Windows 7 Pro/Ultimate as well.

    For XP Home, go to Start > Run, type in regedit and click Run... or hit Enter. Go to HKLM (HKEY_LOCAL_MACHINE) > System > CurrentControlSet > Control > LSA and find the LMCompatibilityLevel and double-click on the registry key to edit the value. Replace 0 with 1 (0 = Send LM & NTLM Responses, 1 = Send LM & NTLM - Use NTLMv2 session security if negotiated) and click OK to save the changes.  Find the Registry Key MSV1_0 and edit the values NtlmMinClientSec and NtlmMinServerSec. The default value is 20000000 (0x20000000) change it to 0 (0x00000000) if needed. Edit the forceguest in the Registry Key Lsa from 0 to 1 (0 = Credentials needed, 1 = Guest Only) and click OK. Restart your computer to save changes and to make the changes in effect. Do the same for Windows 7 Home Premium as well.

    As for your Windows XP SP2 machine, make sure your client machine has the same workgroup as your Windows 7 Ultimate machine. Example: Windows 7 Default Workgroup is WORKGROUP, Windows XP is MSHOME. To change this, go to Network Connections on Windows XP, click on Setup a Home Network Wizard (picture of a house connected to a network), Follow the instructions. Since your Windows 7 Ultimate machine is using ICS (Internet Connection Sharing), try bridging the network cards for better results. At the page where you input your Workgroup Name, input WORKGROUP in the text box in place of the MSHOME text, and restart your machine.

    To bridge a network, go to the Network icon in the Task Bar, right-click and select the Open Network and Sharing Center, select Change Adapter Settings, and right-click on the NIC (Network Interface Card) that is the ICS for your Windows XP computer. Uncheck the box "Use Internet Connection Sharing" and click OK. Then, select the two Network Cards (e.g. Wired to Wired, Wireless to Wired), right-click on any Network Card, and select "Bridge these Connections." It might take a while. The downside with ICS is that you have to input a Static IP in the computer(s) and Xbox LIVE will have lagging issues (NAT Type Strict), while Bridging a network uses DHCP from the DHCP Server (e.g. a router). If you have the Internet connected via modem on your Windows 7 machine, use ICS, or build a DHCP server* in your house (easier option). Reset your Windows 7 machine to apply the changes as well.

    *Windows 2000 Server or higher (server OSes only)

    If this solved your problem, congrats. If not, please feel free to reply to this post for further questions or problems.

    In regards,

    Benjamin Wilson
    Enrolled CCNA Student at Macomb Community College

    Monday, July 18, 2011 11:21 PM
  • Thanks Benjamin

    But, as i told in my earlier posts, win xp machine does not have problem, i think the problem is related to my win 7.

    also i could not find Network security in my win xp pro.


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Tuesday, July 19, 2011 2:03 PM
  • Hi,

    Please follow the steps provided by Benjamin Wilson to check the policies in GPO.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, July 20, 2011 1:33 AM
    Moderator
  • Hi,

    Please follow the steps provided by Benjamin Wilson to check the policies in GPO.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Hi

    I've tried to follow, but win xp does not have network security.

    what's GPO ?


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx
    Wednesday, July 20, 2011 6:15 AM
  • Hi

    All right, please access the following link.

    http://support.microsoft.com/kb/307882


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, July 20, 2011 6:21 AM
    Moderator
  • بسم الله الرحمن الرحيم

     

    i hope the issue was solved. tell us please


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    • Proposed as answer by PrinceDray Tuesday, November 01, 2011 3:17 AM
    • Unproposed as answer by PrinceDray Tuesday, November 01, 2011 3:17 AM
    Tuesday, October 04, 2011 6:46 AM
  •  

    i have a similar problem: Window 7 and window XP are connected via wireless router . . . from win7 machine under network i can see "sharedocs" from my xp machine and access its files, but when i enable share on another folder on the xp machine, it shows up in the win7 machine but when i try to open it say "i do not have permission to access (file name). 

    Tuesday, November 01, 2011 3:16 AM