none
Windows 7 won't connect to Internet

    Question

  • I normally use a Desktop PC with Windows XP installed and my broadband internet works well and fine on it. I use the same internet connection on my laptop too running Windows 7. It worked fine at the start but then it won't connect anymore. It takes the invalid IPs, 169.xxx.xxx.xxx.

    Normally the adapter is set to 'Obtain IP address automatically'. The internet still works fine on XP, but not on Windows 7. I've already tried to specify the IP address and gateway, but it doesn't work. I did update my LAN card adapters, they're Win7 drivers so I'm sure there's no problem there.

    Wednesday, June 02, 2010 3:45 PM

Answers

  •  

    Hi,

     

    Is the Windows 7 machine connected to Internet via a router or a switcher?

     

    To troubleshoot the issue, please perform the following steps.

     

    1. Bypass the router or switcher and connect to DSL Modem directly via wired cable to check the result. If everything is working fine, please upgrade the router’s firmware. Otherwise, please move on the following steps.

     

    2. Temporarily turn off firewall and antivirus program.

     

    3. Reset WinSock

     

    a. Click Start, click "All programs", and click "Accessories". 

    b. Right-click "Command Prompt", and click "Run as administrator". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    c. Please enter the following command, and press Enter.

     

    Netsh winsock reset

     

    d. A message stating "Successfully reset the Winsock Catalog" will appear. Please restart the computer

     

    4. Run the Troubleshooting Problems tool to check whether the issue can be detected by Windows.

     

    What’s the result?

     

    If the issue persists, please type “IPCONFIG /ALL” in Command Console and post the result here for research.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, June 16, 2010 1:11 AM
    Thursday, June 03, 2010 2:13 AM

All replies

  • If you're not using a router, unplug your ISP's modem for about a minute or two then power it up. Reboot your laptop.

     

    Wednesday, June 02, 2010 3:48 PM
  • Hi

    If you are Not using a Router, get one.

    It provides better, safer Internet and LAN.

    The Router will keep the connection alive all the time to prevent a situation like the one that you are expeirencing now which might be a result of the ISP's logon cretential policy (Id/PW).

    If you do have a Router, please explain better the make and configuration of you your Network/Internet system.

     

     


    Jack, MVP - Networking.
    Wednesday, June 02, 2010 5:33 PM
  •  

    Hi,

     

    Is the Windows 7 machine connected to Internet via a router or a switcher?

     

    To troubleshoot the issue, please perform the following steps.

     

    1. Bypass the router or switcher and connect to DSL Modem directly via wired cable to check the result. If everything is working fine, please upgrade the router’s firmware. Otherwise, please move on the following steps.

     

    2. Temporarily turn off firewall and antivirus program.

     

    3. Reset WinSock

     

    a. Click Start, click "All programs", and click "Accessories". 

    b. Right-click "Command Prompt", and click "Run as administrator". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    c. Please enter the following command, and press Enter.

     

    Netsh winsock reset

     

    d. A message stating "Successfully reset the Winsock Catalog" will appear. Please restart the computer

     

    4. Run the Troubleshooting Problems tool to check whether the issue can be detected by Windows.

     

    What’s the result?

     

    If the issue persists, please type “IPCONFIG /ALL” in Command Console and post the result here for research.

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, June 16, 2010 1:11 AM
    Thursday, June 03, 2010 2:13 AM
  • Everytime I have to reboot my laptop I have to cycle the power on my model. Is there any other way to resolve this? It has to be a setting somewhere?

    Friday, April 27, 2012 5:11 PM