none
Windows 7 Smart Card Login Issue RRS feed

  • Question

  • We use a Smart Card for two factor authentication to RDP into servers.  However, when the card is inserted and your desktop gets locked, when you go to unlock it defaults to the Smart card instead of the credentials you logged in with.  Is there a way to turn off the smart card for the Windows interactive login but still have it available for RDP sessions?
    Wednesday, November 16, 2016 1:44 PM

All replies

  • Hi ,

    Due to the limited working environment, it is not available for me to test this. I suggest you test it to get the exact answer. Based on my understanding, local logon process is different and isolated from smart card RDP logon process. Please refer to the following link to disable smart card credential provider, turn off the smart card for locally logon.
    How to disable additional credential providers
    https://social.technet.microsoft.com/Forums/windows/en-US/9c23976a-3e2b-4b71-9f19-83ee3df0848b/how-to-disable-additional-credential-providers?forum=w8itprosecurity
    Then, make sure smart card service is running, test if it still available for RDP sessions. We would appreciate it if you would post back the test result.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 17, 2016 7:26 AM
    Moderator
  • Thanks for the suggestion.  However, I have already tried that method and it disabled the Smart Card for both the interactive login and the RDP sessions.  So, this method does not accomplish what I need...


    Thursday, November 17, 2016 12:20 PM
  • Smart card(s) as with any storage hardware should simply be in its default OS configuration,it should not have

    ability to do that..Either way,try resetting it to the OS values,in run or cmd,type: diskmgmt.msc  in msc,L.click

    on a storage device,go up to actions/all locate & set to "make active" close out.Also,pc boot options are set

    in the BIOS,boot prefrence,set C: as 1st boot priority...

    Thursday, November 17, 2016 10:59 PM
  • Sorry but I'm not really sure how your suggestions relate to my question.  I'm not needing to reset anything to factory defaults and everything is working.  I'm just looking to tweak the way Windows responds to the PC being locked when a smart card is inserted.

    Thanks for your suggestions though...

    Friday, November 18, 2016 12:15 PM
  • Hi , 

    Thanks for posting back the test result. Sorry to hear that it is not worked as expected. If so, I am afraid that it is a default behavior and cannot be tweaked.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 21, 2016 9:34 AM
    Moderator