none
Wireless before Login RRS feed

  • Question

  • I have seen somethings related to this - but never a true fix..   I have windows 7 machines that have a piece of software for remote management installed on them.   All of these computers connect via wireless - with a saved profile - so when a user logs in - it automatically connects..   The issue is, if no one is logged into the machine - the wireless (hardware is turned on) - is not connected..   I cannot seem to find anywhere - how to have the wireless connect pre-login (domain or locally)..  Has anyone had any luck with this?   I have to imagine this is possible.  My XP machines do not have this issue...
    Wednesday, November 23, 2011 5:12 PM

Answers

  • Fixed this finally!   The network availability was set to me only - I delete the profile and made it "all users" and now it is connected to the network at the login screen..   Might fix some of those domain login issues I see people having...

    Wednesday, November 23, 2011 5:47 PM

All replies

  • Fixed this finally!   The network availability was set to me only - I delete the profile and made it "all users" and now it is connected to the network at the login screen..   Might fix some of those domain login issues I see people having...

    Wednesday, November 23, 2011 5:47 PM
  • Could you please share the steps you took to delete the wireless profile and create a new one?  I have VPN users who need to be able to have a wireless network available for start before login to work.  Thanks for your help.
    Monday, March 26, 2012 6:00 PM
  • Feel free to check out this delete wireless network profile article to delete the profile, after that create a new one manually or by connecting PC to wireless network. 

    Hope this helps.

    Tuesday, March 27, 2012 2:44 PM
  • I was beating my head against the wall on this one. Thanks
    Tuesday, November 5, 2013 12:57 PM
  • @Dawooddoe

    These instructions worked on Windows 7 Pro Dell Latitude E5450 laptop.

    Had to delete and readd the profile (while WiFi adapter was disabled)


    • Edited by A J 007 Wednesday, April 5, 2017 12:42 AM
    Wednesday, April 5, 2017 12:42 AM
  • The correct answer is here.  However it's not as detailed as I'd like so I'm adding (even though this thread is 8 yrs old) in case it helps someone else).

    1. Make sure to jot down the WIFI profile and password you want to connect to.
    2. Use Netsh to validate you're on "Current User Profile" - you want to (eventually be on All User Profile)
      Current User Profile that will disconnect your rdp session.
    3. Next, go in to control panel-->Network and Internet--Manage Wireless Networks (in the upper left hand side)
    4. Delete all of your profiles that were listed with NETSH that stated "Current User Profile"
    5. Then click "ADD"
    6. Manually type in your Wireless profile you want to connect to including the correct security type, encryption type and security key.  I clicked both the "Start this connection automatically" and the "Connect even if the network is not broadcasting".
    7. At this point, accept everything and you should connect to your WAP.
    8. Next, rerun the NETSH command and you'll see the output change below.  If you don't, then you'll have to dig further.  All of the other recommendations about changing the registry and modifying the power settings are fine and dandy, but this was the only thing to help me solve the problem.

    HTH!

    Friday, December 20, 2019 12:46 PM