Windows Installer Stopped REsponding (FIX) includes Java and other app issues

    General discussion


    This has been posted on other sites. I can confirm it fixed install isues with Java and many other apps. Some how it got renamed and many people have this issue, fixed visual studio installs as well.

    You should have base registry editing knowledge to do this.

    Run Regedit  (Start...All Programs...
    Accessories... Run     then enter Regedit)

    navigate to: HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Windows\DisabledSessions

    select MachineThrottling Right click and select Rename

    Rename MachineThrottling  to    _MachineThrottling    (The underscore is the key to fixing it)
    exit Regedit and the MSI (installer) should now work without hanging.

    Tuesday, January 20, 2009 2:33 AM

All replies

  • Completely fixed the problem simply genius 
    Tuesday, January 20, 2009 3:01 AM
  • Perfect!  Fixed my Java install plus the MyNetflix plugin install for Media Center.  Thanks!

    This one is very important - needs to get to the Microsoft higherups ASAP.

    Tuesday, January 20, 2009 5:17 AM
  • MS needs to pin this or create info up top of the forum because people are missing the fix and get stressed out over it. Not sure why the reg key became such an issue for a missing _ in the reg key.  I submitted feedback so they can at least patch things right. Oddly it seems most common on the 32bit version of the install over the 32bit that has it more often.

    THis allso fixed my Kasperky update issue, I didn't realize Kaspersky was workign effient either.

    Tuesday, January 20, 2009 10:50 AM
  • Hello,
    I am not sure if this is the right thread, but I have some problems with my MSI.
    I am not able to install, uninstall or change programs that need the installer. All the tricks I found for older versions had no effect, so I wanted to try this one, but I could not find the value-name MachineThrottling. Should I now create this (if yes, can someone give me details, like what kind of value, what is the value etc.) or is there anything else I could do.
    Tuesday, January 20, 2009 2:07 PM
  • That is the temporary fix...
    I found this post elsewhere, which describes the more permanent fix...

    "There are two workarounds for this issue.  One may only be temporary, while the other should be permanent.  I will list the permanent method here so everyone can cure the issue once and for all.

       1. Delete the string values (Except for (Default)) in HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions
       2. Start gpedit.msc
       3. Expand Computer Configuration, expand Administrative Templates, expand System, expand Internet Communication Management, and then click Internet Communication settings.
       4. In the details pane, double-click Turn off Windows Customer Experience Improvement Program, and then click Enabled.

    Yes, doing the above WILL disable the anonymous usage data (CEIP), but until Microsoft fixes the issue and issues a hotfix or a new build I don’t see any other options to ensure the issue does not occur again."

    Windows 7 32bit beta
    Tuesday, January 20, 2009 2:38 PM
  • I used to get an unspecified error while Trend Micro Housecall 6.6 was updating the greyware/malware, but now that I turned off the Windows Customer Experience Improvement Program I get an additional error window telling me that "an error occured while trying to transfer data from the Internet!". Resending the data will give me the same error over and over again, but after cancelling I get the aforementioned unspecified error again.

    Apparently the WCEIP does block certain error messages concerning the installation of Java applets, but how would I go about to get Trend Micro Housecall 6.6 to work properly?
    Tuesday, January 20, 2009 3:02 PM
  • THat other fix is not permenant nor does it affect this install issue. I'm not sure who posted that info but that is not what adresses it, since I had the issue and that other setting for reportign was already disabled. By deletign the reg with the throttling issue that caused MSI to hang, they probably caused the reg key to be replaced, bu tit may accur again. I been running constint installs and have people say once they cahgned it as I psoted they had no issues for 2 weeks. BAsically we are forcign the throttling off which has an incorrect reference.

    REGISTRY VALUE TO ENTER: (not sure why you don't have it)

    Value Name:

    Value Data:


    Value Data:

    Base: Decimal

    • Edited by diiorio Tuesday, January 20, 2009 3:18 PM
    Tuesday, January 20, 2009 3:02 PM
  • I don't have that particular registry entry either, but you might want to make sure your post contains proper spelling and whatnot before you suggest people to edit registry keys (I for one expect errors in your suggestion as well).
    Tuesday, January 20, 2009 3:05 PM
  • If you corrected the throttling installs won't be an issue. However other errors are not effected. Kaspersky AV also can be a pain with the ANti Hacker stuff  blockig nregistry entries withotu askign to allow it. Soem problems have issue with DLL's  so that is another set of issues.

    Tuesday, January 20, 2009 3:05 PM
  • Frop said:

    I don't have that particular registry entry either, but you might want to make sure your post contains proper spelling and whatnot before you suggest people to edit registry keys (I for one expect errors in your suggestion as well).

    And what spelling error in the part regarding the registry fix are you referring to? It seems a few people here had no issue fixing their install issue using it.

    I wouldn't expect you to have the entry if you deleted it, but without it you will run into issues with visual studio C# and C+.
    Tuesday, January 20, 2009 3:09 PM
  • Thanks this really helped, when trying to install MySQL it crashed.
    Tuesday, January 20, 2009 3:47 PM

  • The error has been recognized by the Action Center and their recommended course of action:

    [QUOTE]Solve a problem with Windows 7 beta

    An issue with the Customer Experience Improvement Program (CEIP) client in Windows 7 beta is causing Explorer and some MSI-based installers to stop working properly.

    To solve this problem, follow these steps:
    1. Click the Start button , click All Programs, and then click Accessories.
    2. Right-click Command Prompt, and then click Run as administrator. In the User Account Control window, verify that Program name is Windows Command Processor, and then click Yes.
    3. In the Administrator: Command Prompt window, type or paste the following text at the prompt:
      reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions /va /f
    4. Press Enter to install the solution.
    5. If The operation completed successfully displays, close the Administrator: Command Prompt window to complete this procedure. If "ERROR: Access is denied" displays, repeat this procedure from the top, making sure you clicked Run as administrator in step two.[/quote]
    Tuesday, January 20, 2009 4:11 PM
  • Hello all..

    Thanks a lot for repliers.. But i try all ways you are mentioned above, cant fix this damn error..

    what must to i do else ?

    - tried uninstall and install windows installer.. its last version 5 now..

    - tried regedit fix by adding qword key and changed key values mentioned above..


    - sfc /scannow   , is this can solve this error ?

    and i have a question too is this error linked up with microsoft office 2003 ? i installed it and after every thing goes bad..


    1 is Possible 0 is imposible.. That is all of the matter..
    Saturday, April 23, 2011 4:46 PM
  • Hello again and happy new years..

    if anyone encountered this problem after tried mentioned fixes above, formatting pc etc. and if you are getting this problem with other Applications setup like java, and other setups uses windows installer (.msi packages)..

    I fix this problem a few months ago on my windows 7 (encountered both of x86 and x64).. and formatted it hundreds times cant fix. 

    last time i delete all partitions on my hard drive (especially delete system volume { partition of C: drive }) and eureka..!

    now im using java and other .msi packages of game setups with any problem :)

    if you cant fix it formatting try this..

    and reply here after try.. so we can realize this to fix of problem

    i hope everybody can fix this boring problem.. :)


    1 is Possible 0 is imposible.. That is all of the matter..
    Sunday, January 01, 2012 10:03 PM