none
Bash on Windows 10 just opens and closes RRS feed

  • Question

  • Bash on windows 10 not showing up (It just opens and closes immediately). I tried switching off the Linux subsystem and re-enabling it but still the problem persists. 

    Any suggestions? 

    Thanks

    Monday, September 5, 2016 5:04 PM

Answers

All replies

  • Have a check in C:\Users\%USERNAME%\AppData\Local\lxss just see what files there, remove Bash from Turn Windows features on or off again reboot. Check that folder delete that folder. Add again Bash.

    So checking you do have Developer mode on? You do type Bash in an command prompt Window first? Does that work ok? Does this guide http://www.omgubuntu.co.uk/2016/08/enable-bash-windows-10-anniversary-update help at all?


    Monday, September 5, 2016 8:45 PM
  • The linux subsystem is a beta feature so support is limited.  Microsoft did recommend a method of reaching the team that is developing it which is here


    First, this is the first time we’re releasing this technology – it’s marked as beta for a reason: We know that there are some rough edges and that some things will break! Do not expect every Bash script and tool that you run will work perfectly – there will be gaps. But by trying out this feature, you’ll help us figure out what we need to work on in order to greatly improve our reliability, coverage, and reach.




    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Monday, September 5, 2016 9:30 PM
    Moderator
  • So I disabled the subsystem, deleted the folder, restarted, re-enabled the subsystem and restarted again. It worked this time. 

    Thanks. :)

    Tuesday, September 6, 2016 1:20 AM
  • Hi USat_92,

    Glad to hear that you have solved the issue and thank you for sharing it here, it will be helpful to other community members who have same questions.

    For the new function in Windows 10, we could check it by turn Windows features on/off in Control Panel. Meanwhile we have set up a forum about the bash. You could get more information from it.

    https://github.com/Microsoft/BashOnWindows/issues

    Best regards,

    Carl Fan


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 7, 2016 7:39 AM
    Moderator
  • Hey,

    Which folder did you delete exactly? I have the same problem of the bash terminal closing immediately after opening. 

    Saturday, October 1, 2016 12:27 AM
  • Hey,

    Which folder did you delete exactly? I have the same problem of the bash terminal closing immediately after opening. 

    From my post above;

    "Have a check in C:\Users\%USERNAME%\AppData\Local\lxss just see what files there, remove Bash from Turn Windows features on or off again reboot. Check that folder delete that folder. Add again Bash."

    Saturday, October 1, 2016 10:00 AM
  •  I had the same problem, wherein I had the "Windows for Linux Subsystem (Beta)" feature enabled, but attempting to open Bash resulted in a console window opening and almost immediately closing. I entered Developer mode and it solved it for me, without the need to do anything with the "Linux" file system folder.

    For anyone having this problem, just open the settings and type "developer" in the search bar, and click on the "Use developer features" result. From the opened settings page just check the "Developer mode" option, click yes on the dialog and restart the computer. Bash should work from there on, if there's no other reason why it shouldn't.




    • Proposed as answer by arsaccol Saturday, December 3, 2016 1:35 AM
    • Edited by arsaccol Saturday, December 3, 2016 1:59 AM
    Saturday, December 3, 2016 1:33 AM
  • Thanks! Turning on developer mode fixed this for me.
    Wednesday, December 7, 2016 5:00 AM
  • Thank you SO MUCH! This fixed it for me :D
    Tuesday, March 7, 2017 4:04 PM
  • Hi @USat_92, 

    What folder exactly are you talking about? 

    Thank you,

    Thursday, April 25, 2019 3:25 PM
  • I could not find the lxss folder, or the updated folder suggestions and the issue was there even after re-enabling the linux subsystem.

    Eventually I went into Microsoft Store, searched for Ubuntu and installed the version from Canonical Group.

    Now I run the Ubuntu app which gives me the bash shell

    Wednesday, May 22, 2019 3:21 AM
  • I report my solution since only a single person mentionned it.
    I enabled/disabled the feature several times, rebooting every time without any success...
    No lxs... folder into AppData...

    Finally, I just had to go to the windowsstore and install the ubuntu app. It installed I think the ubuntu distri and since I'm finally able to start bash directly =)

    Thanks for your help everyone
    Friday, June 7, 2019 6:25 PM