Drivers won't install correctly for 802.11n USB Wireless LAN Card


  • Hi all,

    I bought a Mediallink Wireless-N USB 2.0 Adapter from amazon, and I have not been able to get the device to work.  I've tried several different drivers and they either fail to install or the OS does not find any available networks and reports that "there might be a problem with the driver for the Wireless Network Connection adapter" whenever I right-click on the networking icon in the task bar and select "Troubleshoot problems."

    Some info:

    • My OS is Windows 7 64-bit Pro.
    • The card uses an Ralink networking chipset RT-2870.

    What I've tried:

    • installing the Win7 64 bit drivers that came on the MediaLink install CD.
    • allowing Win7 to pick a driver.
    • installing the drivers from Ralink's website for the RT-2870.

    I took a look at this post:

    which seems relevant, but I don't have access to the vista driver and my netr28ux.sys file is already a newer version:


    Does anyone have any help or suggestions?

    Friday, April 08, 2011 12:02 AM