none
Printer Problems in Windows 7-Ricoh

    Question

  • Hi Everybody,
    Recently i have installed windows 7 in my system. Installation goes to very smooth its working perfectly. Now im suffering with some Printer problems. I could not Connect my system with the Network Printer. Im using a Richo Aficio MP 1600L/MP 2000L  (DDST). Im having the driver CD for Win Xp & Vista . but im unable to install the printer in Windows 7..

    whats the solution for this ?
    Thursday, June 11, 2009 9:27 AM

All replies

  • Hi mrriyad,
    is the printer connected to a win7 machine or a computer running a different o/s?

    Regards FAGAN
    Saturday, June 13, 2009 9:59 AM
  • Can you see the network printer on the network? Is the printer connected to your router, or to another PC with a different OS?
    Saturday, June 13, 2009 6:12 PM
  • Hi Fagan,
    i connected the printer with   my router.and the printer IP address is 192.168.30.10...


    Regards
    Riyad M R
    Sunday, June 14, 2009 3:35 PM
  • Hi Riyad,
     sounds as though you maybe using a print server, or Wireless/Bluetooth printer?
    Is the printer showing on the Win7 computer?
    Are you trying to connect to the printer from a XP or Vista computer as well?

    In adding a printer on Win7 if you need to add a print server (via IP address) go to "devices & printers" in the start menu,
    'click add printer',
    'click add a network printer, wireless or Bluetooth printer'
    If the printer you are looking for is not found quickly, click 'STOP'
    then click 'the printer I wan't is not listed'
    Check 'add a printer using TCP/IP address or hostname' I will leave you to follow the prompts from there! 

    Let me know if this work, as I don't use a print server

    Regards Fagan

    PS :
    Riyad,
    you could also try this If the printer was connected directly to another computer?, type in the dialogue box next to "select a shared printer by name" \\computername\make model take note of the space between make and model (eg : Ricoh mp1600)
    Monday, June 15, 2009 9:14 AM
  • Hi fagan & Adam
     i tried to connect the  printer with the network port. i added the IP address in a new port. then goes to the "have disk option" ( note there is no driver were found for this particular  printer ( Richo Aficio MP 1600L/MP 2000L  (DDST))  in win 7 default drivers. rest of the drivers was there ), when i insert the CD in my drive. it says the driver incompatibilty ( Do u want to install this driver anyway)..

    Rest of the Systems are Win Xp and vista. This printer is not connected to a particular system, an IP address is assigned for the printer).

    what i have to do for this. i tried many times.. expecting a valuable reply


    Thanks and Regards

    Riyad M R
    Monday, June 15, 2009 3:21 PM
  • Can you plug the printer into the computer to install the driver, then put it back on the network?
    Monday, June 15, 2009 3:56 PM
  • Adams,

    That is not possible now. because the printer is locating in another place. 7 is for a testing purpose now. anyways i will check it once.

    thank u ..
    Monday, June 15, 2009 4:07 PM
  • Hi mrriyad,

    try use only CD shipped with printer. just insert CD to drive follow the installation wizzard and try to instal printer this way. I noticed thinks like you describing with HP printers. No idea why it is not working correctly or at all when user use windows way to install printer and its working when the printer is installed from CD. sounds littlebot strange, but this is the way I was able to get my w7 print on net printer.

    druid
    Monday, June 15, 2009 8:43 PM
  • Why would you be printing to a remote location?
    Monday, June 15, 2009 8:44 PM
  • Druid,

    i tried installing with CD shipping with the printer. Now its showing printer is installed and set as default printer, but i could not take printouts. i set all the printing option. but the printer still  showing printing error.

    Adam

     I meant the printer is locating in another room. not in the lab. this printer is used to print bulk printing.

    I need to check the printer setup again, thanks for the guidance..:)


    Regards
    Riyad
    Friday, June 19, 2009 6:15 AM
  • You will need to directly connect your printer to your machine when you first install it or it will not likely work.
    Tuesday, June 23, 2009 3:46 PM
  • Even my computer running on Windows 7 gave an error while installing Ricoh printer. I disabled the the anti-virus for a few minutes and Installed the printer..still it didn't work. just try with a different printer. cheers
    Tuesday, May 31, 2011 12:10 PM
  • This is a bit old, but I did see where someone has recently responded with this issue.  It does appear that this is not really an issue with Windows 7 or the Ricoh, but just may be different in the way it is accessed.  I have connected hundreds of printers on our domain, but the Ricoh in the Windows 7 environment was certainly unique and frustrating for such a simple task.

    I will give you the details on how it finally worked for me.  Just so you know, there were absolutely no errors returned when I was attempting to print.  In this case, the data would be sent to the printer, but just hang in the queue and then time out.  I believe the problem was the validation the printer was requiring from the client.  The user finally told me that some functions required a user ID long after I had struggled with getting this to print.   With that in mind, here is a nice guide about connecting to a Ricoh and the validation process: http://fulmerit.chem.wsu.edu/ptr_Ricoh7.html.  Basically, you go to preferences in the printer settings (assuming you already have the driver loaded of course), this guide recommends putting the "Job Type" as "Hold Print", click "Details" and then enter in your (or the user's) user ID.  You then go to the "Valid Access" tab and enter the User Code.

    From what I experienced, it was just quick and easy to open up explorer, enter in the IP address of the Ricoh, right click on the printer and then "Connect."  You will then just need to ensure that all the unique codes are entered for the device as mentioned above.  I kept running into trouble trying to add a printer using the TCP/IP port as I normally do.  I am truly at a loss as to why, unless I did not properly follow all the steps that I advised above.  But frankly after it started working, I really didn't care anymore. :)

    Hopefully this will be of use to someone who is experiencing a similar issue with the Ricoh.

    Thursday, July 07, 2011 2:34 PM