none
Windows 10: Resume from Sleep - Windows Resolution Changes RRS feed

  • Question

  • When my computer awakes from sleep, my resolution changes, If I restart, it goes back to normal. I have upgraded graphic drivers with latest version, tried to adjust the "Simulated" related keys but no success. Any Clue?

    Laptop Model: Dell Latitude E7270

    Windows 10 Build: 10.0.15063 (Creators update) 'By the way, issue started after creators update'

    Tuesday, June 6, 2017 8:02 AM

All replies

  • Hi ,

    Usually this will be caused by the graphics driver not properly supporting sleep modes and therefore disabling the ability to detect a connected display when the computer goes to sleep. It seems that DELL only released Windows 10 64 bit compatible drivers for Latitude E7270. We suggest installing Windows 10 64 bit system. Did you install Windows 10 64 bit system? If so, download and install the last version of graphics drivers from the following link as a test.
    http://www.dell.com/support/home/us/en/04/product-support/product/latitude-e7270-ultrabook/drivers/advanced

    In addition, I found a similar case for your reference. Some third application/service on the computer could also cause this issue. Some user use “Clean Boot” found the culprit. I think it can be considered as a reference. Hope it helps.
    Windows 10 Display Resolution Changes After Sleep
    https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-display-resolution-changes-after-sleep/7a9ebf7e-2ef2-4355-98d0-5ae8847443ae

    Lastly, if the above recommendations do not help, I also found a workaround. It worked for many users, hope it works for you as well.
    https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa


    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 7, 2017 6:26 AM
    Moderator
  • Hi,

    Thanks for your reply. 

    Its Windows 10 Enterprise 64 bit (Creators Update). Laptop is connected to docking station and a secondary display is connected. Secondary display is dell 4K monitor in which I am facing issue with. There is no issue with Laptop resolution and scaling, however when removing laptop from docking station at my shift end and connecting it back at morning, this issue appears with 4K monitor. This is happening on daily basis. 

    Every thing was working fine before Creators Update :(

    I have tried everything you suggested but no luck.

    Regards,
    Nishant

    Thursday, June 8, 2017 5:31 AM
  • Hi ,

    Did you update drivers for the dock station?
    As every thing was working fine before Creators Update, you have 10 days to go back previous version of Windows after upgrading to Creators Update. Hope it is helpful for you.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 8, 2017 7:41 AM
    Moderator
  • Hi,

    Actually I have upgraded to Creators update in April only when it was launched, so can't go back now. Any other suggestion would be highly appreciated.

    Monday, June 12, 2017 6:02 AM
  • Did you update drivers for the dock station?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 16, 2017 9:09 AM
    Moderator
  • This was solved for me by following these instructions:

    https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106a

    ***************************

    I have found a work-around.
    Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path;
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    My system had three entries;
    DELF003YY7707BR0MUL_30_07D7_6A^9A3774EB79DEE3E3E38496CC7DF4D936
    QHD32000001_31_07D6_D5^63E1ABDD175E7871DCAEB710418A0F75
    SIMULATED_8086_2A42_00000000_00020000_1010100^CDE365D1B3F0942F0CF38BFB8E127AB4

    Under each is a tree called "00" two of the keys are
    PrimSurfSize.cx
    PrimSurfSize.cy

    Under "00" was another branch also called "00" two of the keys are;
    ActiveSize.cx
    ActiveSize.cy

    The first two of the configs (ie DELF00... & QHD3...) the above keys were 1440x900,
    so they were not involved.

    The third (SIMULATED...) were set to 1024x768.

    I changed these to 1600x900 and the problem was solved.

    **************************************

    NOTE! Values are in hex - probably one of the values are correct - copy and paste.

    NOTE! You might have more than 3. I had 6 - As I didn't check for everytime - I changed all of them.

    NOTE! These changes might affect the behaviour if you change monitor - as it forces the resolution I would guess.

    • Proposed as answer by __Phil__ Sunday, March 10, 2019 8:53 PM
    Saturday, March 31, 2018 5:52 AM
  • https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106a

    Weird.  There is a slash in the title which apparently gets dropped incorrectly.  A slash would be %5C so let's see what that does...  Oh.  The slash does get dropped.  You dropped the final a in the thread GUID.

    https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa 

    Thanks for sharing your resolution.



    Robert Aldwinckle
    ---

    Saturday, March 31, 2018 6:12 PM
  • Got the same problem & your solution looks spot-on. Will report back.

    Many Thanks

    NB My current workaround is to restart the video drivers with a PS script...

    cls
    devcon listclass display
    # PCI\VEN_10DE&DEV_1C03&SUBSYS_37181458&REV_A1\4&3834D97&0&0008: NVIDIA GeForce GTX 1060 6GB
    devcon restart "PCI\VEN_10DE&DEV_1C03&SUBSYS_37181458&REV_A1"

    Saturday, March 2, 2019 10:47 AM
  • Reporting back... 

    Your registry fix appears to have done the trick. Thanks again ;)

    Sunday, March 10, 2019 8:51 PM