Unable to access registry keys in Windows 7


  • Several keys in the Local Machine section of my Windows 7 registry are inaccessible. I recently installed Omnipage, and the program doesn't start, apparently because permission to access the Scansoft registry key is denied. When I try to change permissions (as Administrator, I am the only user of the computer), I get a message telling me I don't have permission to change permissions.

    Can anyone tell me how to gain access to these keys?

    • Moved by Novak Wu Tuesday, June 15, 2010 1:51 AM permission issue (From:Windows 7 Installation, Setup, and Deployment)
    Friday, June 11, 2010 3:34 PM

All replies

  • Hi Chris,


    I suggest you try to modify the Registry key in Safe Mode since this issue should be caused by one program lock the key or permission issue.


    If it is a permission issue, you can try to assign permission to this key.


    Hope it helps.


    Tuesday, June 15, 2010 1:48 AM
  • To change the permissions using Regedit

    The instructions are as follows.

    1.Find the line of code that is failing, for example:


    The text string, "MSWC.BrowserType", is the ProgID (Program ID).

    2.On the Start menu, click Run. At the command prompt, type the following command to start the registry editor:

    3.In the HKEY_CLASSES_ROOT window, click to expand the ProgID key, and then click CLSID. Record the UUID value of this key. For example, the ClassID for "MSWC.BrowserType" is {0ACE4881-8305-11CF-9427-444553540000}.

    4.In the HKEY_CLASSES_ROOT window, click to expand the CLSID key, and then select the ClassID entry (UUID). On the Security menu, click Permissions. Make sure that the Everyone entry has Read permission; if not, add this permission entry.


    Find TypeLib
    Expand the ClassID entry from the preceding step 3, and locate the TypeLib entry beneath it. Record the UUID value, and then proceed to the "Change Permission for TypeLib" section.

    Do changes on your own Risk

    Thursday, June 17, 2010 4:46 PM
  • I have tried using Safe Mode, but I am still denied access to the same keys, and still do not have permission to change permissions.
    Friday, June 18, 2010 12:41 PM
  • Hi,


    Since the issue persists, I suggest you refer to the following article to manually assign permission to the registry key.


    assign permission to this key


    If the registry key still cannot be modified, I suggest you enable the built-in Administrator account and login on that account for a test. To enable the built-in account, please refer to the following article:


    Enable and Disable the Built-in Administrator Account





    Monday, June 21, 2010 1:47 AM
  • I tried enabling the built-in administrator account from MMC, but apparently this is not possible in Windows 7 Home Premium.

    I found an alternative method using the command prompt, typing: " net user administrator /active:yes".

    This did generate a new user account, but I am still denied access to the registry keys.

    Have I enabled the same built-in administrator account that you suggested? If not, how do I do this in Home Premium?

    If I do now have the built in administrator account, why can I still not access certain registry keys?

    Thursday, June 24, 2010 9:47 AM
  • Bump

    I would like to Know too. Mine is on vista business.
    Sunday, February 27, 2011 1:59 AM